# Table of Contents

1. **Product Overview** .......................................................... 9  
   1.1 Vaisala viewLinc Enterprise Server ................................... 9  
   1.2 How Does viewLinc Work? ............................................... 9  
      1.2.1 System Components .................................................. 9  
      1.2.2 Optional Feature Requirements ............................... 10  
      1.2.3 Security Requirements ............................................. 10  
      1.2.4 Hardware Requirements .......................................... 11  
      1.2.5 Server Requirements .............................................. 11  
      1.2.6 Installed System Size .............................................. 13  
      1.2.7 End User PC and Remote Display Requirements ......... 14  
      1.2.8 Default Application File Locations ......................... 14  
   1.3 What's New .................................................................... 15  
      1.3.1 What’s New for Upgrade Users ............................... 16  
      1.3.2 Watch a Tour ......................................................... 20  
   1.4 Device Connection Options ............................................ 21  
      1.4.1 Ways to Connect Hardware ...................................... 21  
      1.4.2 Using Wireless Devices .......................................... 22  
      1.4.3 Using vNet Devices ................................................. 23  
      1.4.4 Using Single or Multi-Port Ethernet Device Connectors . 23  
      1.4.5 Using USB Ports ................................................... 24  
      1.4.6 Using Serial Ports .................................................. 25  
   1.5 Version Information ...................................................... 25  
   1.6 Related Manuals .......................................................... 26  
   1.7 Documentation Conventions .......................................... 26  
   1.8 Trademarks .................................................................... 27  
   1.9 Training .......................................................................... 27  

2. **Setup and Installation** .................................................. 28  
   2.1 Setup Roadmap ............................................................. 28  
   2.2 Setup Checklist ............................................................ 29  
   2.3 Installation ................................................................. 30  
      2.3.1 Installing viewLinc Enterprise Server Software ....... 30  
      2.3.2 Installing viewLinc on a Device Host Server .......... 32  
      2.3.3 Installing viewLinc - Upgrade an Existing Server ... 32  
      2.3.4 Installing viewLinc - Upgrade on a New Server ....... 34  
   2.4 Install Devices ............................................................... 35  
      2.4.1 Install Access Points .............................................. 36  
      2.4.2 Install Data Loggers and Transmitters .................... 36  
   2.5 Log in to viewLinc ........................................................ 36  
   2.6 Discover and Accept Devices ....................................... 37  
   2.7 Configuring viewLinc Enterprise Server ....................... 38  
      2.7.1 viewLinc Planning Worksheet ................................. 39  
   2.8 System Test ................................................................. 42  
   2.9 Validate your System .................................................... 43
6.4 Device Alarms
6.4.1 Types of Device Alarms
6.4.2 Editing Host Communication Alarm Settings
6.4.3 Editing Host Configuration Alarm Settings
6.4.4 Creating Device Alarm Templates
6.4.5 Applying Device Alarm Templates
6.4.6 Editing Device Alarm Templates
6.4.7 Editing Location Device Alarm Settings
6.5 Alarm Notifications
6.5.1 Web Service for SMS and Voice Alarm Notifications
6.5.2 Creating Alarm Notification Templates
6.5.3 Applying Alarm Notification Templates
6.5.4 Editing Alarm Notification Templates
6.6 Notification Content
6.6.1 Creating Custom Message Content

7. System Preferences
7.1 Modifying General System Settings
7.2 Allowing Remote Acknowledgement
7.3 Enabling or Disabling Schedules
7.4 Enabling or Disabling Audible Alarms
7.5 Setting Temperature Measurement Units
7.6 Setting MKT Activation Energy Value
7.7 Setting Device or Channel Alias Preferences
7.8 Setting System-Wide Default Calibration Duration
7.9 Enabling or Disabling Timebase Synchronization
7.10 Enabling or Disabling viewLinc Aware
7.11 Entering New License Key
7.12 Setting Authentication Requirement
7.13 Changing Technical Support Log Settings
7.14 Setting System Language
7.14.1 Making Additional Languages Available
7.15 Setting Measurement Unit Display Preferences
7.16 Configuring Email/SMS/Voice Notification Preferences
7.16.1 Configuring Email Settings
7.16.2 Configuring SMS Settings
7.16.3 Configuring Voice Call Web Service
7.17 Setting System Alarm Preferences
7.18 Setting Comments Preferences
7.19 Adding Predefined Comments

8. Additional Setup Tasks
8.1 Permissions
8.1.1 Permission Levels
8.1.2 Applying Group Permission to Zones
8.1.3 Using Permissions Viewer
8.2 Schedules
8.2.1 Creating Schedules
8.2.2 Setting Threshold Alarm Schedules
8.2.3 Adding User Schedules
8.3 Views
8.3.1 Your Views
8.3.2 Creating Views
8.3.3 Organizing Locations in a View
8.3.4 Sharing Views
8.3.5 Setting Default View
8.3.6 Creating Views for Remote Display
8.4 Signal Towers
8.4.1 Adding Signal Towers
8.5 viewLinc Access through Remote Display or Mobile Device
8.5.1 Remote Display Requirements
8.5.2 Setting Up Remote Display
8.5.3 Using viewLinc Mobile
8.6 Setting Up Voice or SMS Web Services
8.7 Vaisala OPC UA Server

9. Daily Tasks
9.1 Desktop Orientation
9.1.1 Icons
9.1.2 Searching for Zones and Locations
9.1.3 Working with Columns
9.2 Monitoring Conditions
9.2.1 Identifying Active Alarms
9.2.2 Using Status Tab
9.2.3 Triggering Threshold Alarms
9.2.4 Responding to Alarms
9.2.5 Viewing Conditions on Dashboards
9.2.6 Viewing Dashboard Location Trends
9.2.7 Finding Linked Dashboard Location
9.2.8 Printing Current Alarm Data
9.2.9 Exporting Current Alarm Data
9.3 Receiving Alarm Notifications
9.3.1 Acknowledging Alarms
9.3.2 Acknowledging Inactive Alarms
9.3.3 Responding to Audible Alarms
9.4 Pausing Alarms
9.4.1 Pausing Threshold Alarming
9.4.2 Pausing Device or Host Alarming
9.4.3 Resuming Threshold, Device or Host Alarming
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.5</td>
<td>Tracking Events</td>
<td></td>
</tr>
<tr>
<td>9.5.1</td>
<td>Viewing Events</td>
<td>162</td>
</tr>
<tr>
<td>9.5.2</td>
<td>Adding Comments to Events</td>
<td>163</td>
</tr>
<tr>
<td>9.5.3</td>
<td>Viewing Comments to Events</td>
<td>164</td>
</tr>
<tr>
<td>9.5.4</td>
<td>Adding Custom Events</td>
<td>164</td>
</tr>
<tr>
<td>9.5.5</td>
<td>Printing Event Logs</td>
<td>164</td>
</tr>
<tr>
<td>9.5.6</td>
<td>Exporting Event Logs</td>
<td>165</td>
</tr>
<tr>
<td>9.6</td>
<td>Creating Trends</td>
<td></td>
</tr>
<tr>
<td>9.6.1</td>
<td>Building Trends</td>
<td>167</td>
</tr>
<tr>
<td>9.6.2</td>
<td>Trend Functions</td>
<td>168</td>
</tr>
<tr>
<td>9.6.3</td>
<td>Trend Navigation</td>
<td>169</td>
</tr>
<tr>
<td>9.6.4</td>
<td>Modifying Trends</td>
<td>170</td>
</tr>
<tr>
<td>9.6.5</td>
<td>Saving Trends</td>
<td>171</td>
</tr>
<tr>
<td>9.7</td>
<td>Viewing Quick Trends</td>
<td></td>
</tr>
<tr>
<td>9.7.1</td>
<td>Viewing Quick Trends in Sites Window</td>
<td>173</td>
</tr>
<tr>
<td>9.7.2</td>
<td>Viewing Quick Trends in Sites Manager Window</td>
<td>173</td>
</tr>
<tr>
<td>9.7.3</td>
<td>Viewing Quick Trends in Overview Window</td>
<td>173</td>
</tr>
<tr>
<td>9.8</td>
<td>Reporting</td>
<td></td>
</tr>
<tr>
<td>9.8.1</td>
<td>Types of Reports</td>
<td>173</td>
</tr>
<tr>
<td>9.8.2</td>
<td>Generating Reports</td>
<td>174</td>
</tr>
<tr>
<td>9.8.3</td>
<td>Sharing Quick Reports</td>
<td>175</td>
</tr>
<tr>
<td>9.8.4</td>
<td>Generating Quick Reports</td>
<td>176</td>
</tr>
<tr>
<td>9.8.5</td>
<td>Viewing Report Downloads</td>
<td>176</td>
</tr>
<tr>
<td>9.8.6</td>
<td>Deactivating Reports</td>
<td>177</td>
</tr>
<tr>
<td>9.8.7</td>
<td>Activating Reports</td>
<td>178</td>
</tr>
<tr>
<td>9.8.8</td>
<td>Generating Alarm Reports</td>
<td>178</td>
</tr>
<tr>
<td>9.9</td>
<td>Creating Custom Reports</td>
<td></td>
</tr>
<tr>
<td>9.9.1</td>
<td>Creating Location History Reports</td>
<td>179</td>
</tr>
<tr>
<td>9.9.2</td>
<td>Creating Alarm Reports</td>
<td>185</td>
</tr>
<tr>
<td>9.9.3</td>
<td>Creating System Reports</td>
<td>188</td>
</tr>
<tr>
<td>9.10</td>
<td>Viewing Data with viewLinc Mobile</td>
<td></td>
</tr>
<tr>
<td>9.10.1</td>
<td>Opening a Pop-up Trend</td>
<td>191</td>
</tr>
<tr>
<td>9.10.2</td>
<td>Pausing or Resuming Alarming with viewLinc Mobile</td>
<td>192</td>
</tr>
<tr>
<td>9.10.3</td>
<td>Acknowledging an Alarm with viewLinc Mobile</td>
<td>193</td>
</tr>
<tr>
<td>9.10.4</td>
<td>Viewing Data on a Remote Display</td>
<td>194</td>
</tr>
<tr>
<td>9.10.5</td>
<td>Changing a Display Terminal View</td>
<td>194</td>
</tr>
<tr>
<td>10.</td>
<td>Administrator Tasks</td>
<td></td>
</tr>
<tr>
<td>10.1</td>
<td>Groups and Users</td>
<td>195</td>
</tr>
<tr>
<td>10.1.1</td>
<td>Editing User or Group Details</td>
<td>195</td>
</tr>
<tr>
<td>10.1.2</td>
<td>Deactivating Users</td>
<td>195</td>
</tr>
<tr>
<td>10.1.3</td>
<td>Reactivating Users</td>
<td>196</td>
</tr>
<tr>
<td>10.1.4</td>
<td>Deactivating Groups</td>
<td>196</td>
</tr>
<tr>
<td>10.1.5</td>
<td>Reactivating Groups</td>
<td>196</td>
</tr>
</tbody>
</table>
Table of Contents

11.5 Troubleshooting Tips ................................................................. 229
  11.5.1 Responding to Alarms ......................................................... 232

Glossary .......................................................................................... 235

Index ................................................................................................ 241

Warranty .......................................................................................... 257

Technical Support ............................................................................ 257

Recycling .......................................................................................... 257
List of Tables

Table 1  Server Requirements..............................................................11
Table 2  Device Host Server Requirements........................................12
Table 3  Requirements Based on System Size........................................12
Table 4  Client Requirements..............................................................13
Table 5  Network Ports.............................................................................13
Table 6  Server Requirements Based on System Size.............................14
Table 7  Default Installation Folders.....................................................14
Table 8  New viewLinc 5.1 Features.......................................................15
Table 9  Key Features of viewLinc..........................................................15
Table 10  Enhancements............................................................................17
Table 11  Important Changes for Upgrade Users from 4.3 or earlier........17
Table 12  Document Versions......................................................................26
Table 13  Related Manuals........................................................................26
Table 14  Device Properties - Columns..................................................51
Table 15  Host Properties - Columns.......................................................53
Table 16  Rights Definitions.................................................................74
Table 17  Alarm Descriptions.................................................................80
Table 18  Permission Levels.....................................................................126
Table 19  Connecting to Vaisala OPC UA Server....................................141
Table 20  Home Screen Icons..............................................................144
Table 21  Window Icons...........................................................................144
Table 22  Status Tab Columns...............................................................148
Table 23  Dashboard Alarm Status..........................................................150
Table 24  Dashboard Navigation Tools.....................................................150
Table 25  Key Elements in a Trend Graph...............................................167
Table 26  Location Properties Columns..................................................198
Table 27  Definitions File Fields.............................................................224
Table 28  Notification Macros...............................................................227
Table 29  Tips for Managing Alarms......................................................230
Table 30  Tips for Responding to Alarms................................................232


1. Product Overview

1.1 Vaisala viewLinc Enterprise Server

Vaisala viewLinc Enterprise Server is the software used to support all combinations of the Vaisala viewLinc Monitoring System. It features triple-redundant data retention ensuring that data is immune to power outages, network interruptions, and human error.

Use viewLinc to monitor device readings locally on a PC, across a network using a supported Internet browser, or from mobile devices like the iPhone or Google Android.

Vaisala viewLinc Enterprise Server software provides continuous monitoring of real-time data, ensures data history is backed-up, recognizes alarm conditions, and can automatically send alarm notifications to individuals or groups wherever your business is located. This flexible and scalable system allows you to set up a server in Paris to monitor a sensor in Berlin, and schedule reports to be sent to your team members in their choice of eight languages.

viewLinc provides you with many configuration options. You can set up the system for users with different levels of responsibility, manage multiple alarm notification methods, display data for a wide range of display formats, and accommodate custom reporting requirements.

1.2 How Does viewLinc Work?

Every Vaisala viewLinc Monitoring System needs one installation of Vaisala viewLinc Enterprise Server software on a dedicated 24x7 Windows® server. Depending on your network requirements and data monitoring needs, you can install viewLinc Device Host software on additional Windows servers.

- **viewLinc Enterprise Server**: Gathers data from devices, recognizes fluctuating conditions, executes any associated alarm response actions, manages users and groups, and controls both system-wide and user-specific settings.
- **viewLinc Device Host**: Acts as a data distribution point for devices located in an off-site or remote location, forwarding device data to viewLinc Enterprise Server for processing and storage.

1.2.1 System Components

The Vaisala viewLinc Monitoring System is comprised of both software and hardware components, and can be configured to use one or more optional features:

- **Software**: viewLinc Enterprise Server (for data monitoring), and device drivers (if required to connect your devices to a network).
- **Hardware**: Vaisala data loggers, VaiNet access points, HMT140 Wi-Fi data loggers, 300-series transmitters, one or more PCs with a supported Internet browser, and, depending on how you connect the devices to your PC, various cables, Vaisala vNet or Digi network devices.
1.2.2 Optional Feature Requirements

Depending on the optional features you plan to use with viewLinc, you may need to configure these additional system requirements:

- A dedicated Vaisala OPC UA Server to transfer viewLinc data to OPC UA clients.
- An account with a service provider for web delivery of SMS and/or voice notifications.
- SMS modem for standard SMS notifications
- Vaisala or third-party Modbus-enabled devices.
- Purchase of a trusted security certificate.

1.2.3 Security Requirements

viewLinc ES requires a secure end-to-end HTTPS connection to encrypt and protect data transmitted to logged in users. Certificate and security key files (stored on the Enterprise Server and in some cases on a client PC) are used to make the connection secure. During viewLinc ES installation you can choose to automatically generate a viewLinc-signed certificate or upload existing certificate files (viewLinc-signed or CA-signed/trusted).

Refer to your company’s security policy to determine whether you can use generated certificates or require trusted certificates.

<table>
<thead>
<tr>
<th></th>
<th>viewLinc-signed Certificates</th>
<th>Trusted Certificates</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>When to use</strong></td>
<td>For companies with network access limited to a few PCs.</td>
<td>For companies with remote network access needs.</td>
</tr>
<tr>
<td><strong>How to install</strong></td>
<td>Automatically created during viewLinc ES installation.</td>
<td>Certificate request sent to a certificate signing authority for paid validation.</td>
</tr>
<tr>
<td><strong>Validity</strong></td>
<td>Valid for up to 10 years.</td>
<td>Valid for 2 years.</td>
</tr>
<tr>
<td><strong>Cost</strong></td>
<td>Free.</td>
<td>Cost varies/annual renewal fee.</td>
</tr>
<tr>
<td><strong>Action required</strong></td>
<td>A network administrator can automatically distribute the certificate to network PCs. The certificate must be installed individually on non-network PCs.</td>
<td>Install the trusted certificate on viewLinc ES.</td>
</tr>
<tr>
<td><strong>User experience</strong></td>
<td>Until the certificate is installed on a user’s PC, a warning message displays after user enters viewLinc address.</td>
<td>When user tries to access viewLinc from a network or remote PC, no warning appears.</td>
</tr>
</tbody>
</table>

If you require a trusted certificate but do not have one yet, during installation choose to automatically generate certificate files. You can replace the generated files with trusted certificates at a later time.
More Information

- Installation Tips (page 221)

### 1.2.4 Hardware Requirements

Your Vaisala viewLinc monitoring system requires a minimum of one data logger to monitor data, and can support any combination of the following hardware components (number of data loggers permitted is based on your viewLinc and/or Modbus license key):

- One or more Vaisala DL data loggers, RFL100-series data loggers and VaiNet access points, HMT140-series wireless data loggers, 300-series transmitters, Vaisala or third-party Modbus-enabled devices.
- Optional hardware requirements:
  - Additional servers to manage devices at multiple locations (running viewLinc Device Host software or OPC UA Server software).
  - Remote display terminals to provide monitoring opportunities in areas without PCs.
  - Vaisala cables for connecting data loggers and setting up HMT140-series data loggers or 300-series transmitters.
  - vNet or multi-port Ethernet interface devices for connecting Vaisala DL data loggers using an Ethernet connection.
  - Patlite signal towers to issue visual and/or audible notifications.

### 1.2.5 Server Requirements

**Table 1: Server Requirements**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description/Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Availability</td>
<td>Dedicated server available 24 hours a day, 7 days a week</td>
</tr>
<tr>
<td>Server management</td>
<td>Connected to an uninterruptible power supply (UPS)</td>
</tr>
<tr>
<td></td>
<td>Backup solution with support for open file backup</td>
</tr>
<tr>
<td></td>
<td>Synchronizes time with a Network Time Protocol (NTP) server</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows Server® 2019 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Windows Server® 2016 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Windows Server® 2012 R2 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Windows® 10 (64-bit)</td>
</tr>
<tr>
<td>Virtual server support</td>
<td>VMWare</td>
</tr>
<tr>
<td>Application disk space</td>
<td>350 MB</td>
</tr>
<tr>
<td>Database disk space ¹)</td>
<td>200 KB/data point ²)/day</td>
</tr>
<tr>
<td>Network traffic ³)</td>
<td>Approx. 100 KB/minute/device</td>
</tr>
<tr>
<td>Web interface protocol ⁴)</td>
<td>TLS 1.2</td>
</tr>
<tr>
<td>Property</td>
<td>Description/Value</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Security certificate for web interface</td>
<td>Authorized TLS certificate and key 5)</td>
</tr>
<tr>
<td>Email encoding</td>
<td>RFC 2047</td>
</tr>
<tr>
<td>Secure email protocol</td>
<td>TLS 1.2</td>
</tr>
</tbody>
</table>

1) Not applicable to Device Host installation.
2) Data points are device channels monitoring and recording data.
3) Depends on number of devices, system configuration and type of communication devices used.
4) viewLinc 5.1 includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. [http://www.openssl.org/](http://www.openssl.org/)
5) viewLinc-signed certificate and key can be generated during installation.

A supported Internet browser is only required on the viewLinc Enterprise Server computer if you plan to use it to run viewLinc.

### Table 2  Device Host Server Requirements

<table>
<thead>
<tr>
<th>Property</th>
<th>Description/Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Availability</td>
<td>24 hours a day, 7 days a week</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows Server® 2019</td>
</tr>
<tr>
<td></td>
<td>Windows Server® 2016</td>
</tr>
<tr>
<td></td>
<td>Windows Server® 2012 R2 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Windows® 10 (64-bit)</td>
</tr>
<tr>
<td>Disk space</td>
<td>2 GB</td>
</tr>
<tr>
<td>Internet browser</td>
<td>Google Chrome™</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Internet Explorer® 11</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Edge™</td>
</tr>
</tbody>
</table>

### Table 3  Requirements Based on System Size

<table>
<thead>
<tr>
<th>System Size in Data Points</th>
<th>&lt; 20</th>
<th>21 ... 399</th>
<th>400+</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dedicated or shared server</td>
<td>Either</td>
<td>Either</td>
<td>Dedicated</td>
</tr>
<tr>
<td>CPU</td>
<td>1.6 GHz dual core</td>
<td>1.6 GHz dual core</td>
<td>3.2 GHz quad core</td>
</tr>
<tr>
<td>RAM</td>
<td>8 GB</td>
<td>12 GB</td>
<td>16 GB</td>
</tr>
<tr>
<td>Disk space increase/year</td>
<td>1.5 GB/year for 20 data points</td>
<td>15 GB/year for 200 data points</td>
<td>75 GB/year for 1000 data points</td>
</tr>
</tbody>
</table>
### System Size in Data Points

<table>
<thead>
<tr>
<th></th>
<th>&lt; 20</th>
<th>21 ... 399</th>
<th>400+</th>
</tr>
</thead>
<tbody>
<tr>
<td>Continuous free disk space for reports 1)</td>
<td>2 GB</td>
<td>4 GB</td>
<td>10 GB</td>
</tr>
</tbody>
</table>

1) 1 month duration with 1 minute scan/sample

### Table 4  Client Requirements

<table>
<thead>
<tr>
<th>Property</th>
<th>Description/Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet browser</td>
<td>Google Chrome™&lt;sup&gt;™&lt;/sup&gt; Microsoft® Internet Explorer® 11 Microsoft® Edge™&lt;sup&gt;™&lt;/sup&gt;</td>
</tr>
<tr>
<td>Computer clients</td>
<td>Any network computer with a supported Internet browser, a minimum 2.4 GHz CPU, and 4 GB of RAM.</td>
</tr>
<tr>
<td>Display and tablet clients</td>
<td>Touchscreen or mouse-operated panel with a supported Internet browser. Must be connected to the same network as viewLinc Enterprise Server.</td>
</tr>
</tbody>
</table>

### Table 5  Network Ports

<table>
<thead>
<tr>
<th>Default</th>
<th>Type</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>TCP</td>
<td>Signal towers</td>
</tr>
<tr>
<td>443</td>
<td>TCP</td>
<td>Client connections to user interface (Internet-accessible)</td>
</tr>
<tr>
<td>502</td>
<td>TCP</td>
<td>Modbus TCP-enabled devices</td>
</tr>
<tr>
<td>771</td>
<td>TCP</td>
<td>vNet and multi-port Ethernet devices</td>
</tr>
<tr>
<td>950</td>
<td>TCP</td>
<td>Moxa serial-to-Wi-Fi devices</td>
</tr>
<tr>
<td>6767</td>
<td>UDP</td>
<td>HMT140</td>
</tr>
<tr>
<td>12600</td>
<td>TCP/UDP</td>
<td>VaiNet access points, viewLinc Enterprise Server connection with vNet or Device Host</td>
</tr>
<tr>
<td>55000</td>
<td>TCP</td>
<td>Vaisala OPC UA Server</td>
</tr>
</tbody>
</table>

### 1.2.6 Installed System Size

Depending on the number of device channels (data points) you plan to activate and monitor, the viewLinc Enterprise Server should also meet the following requirements:
Table 6  Server Requirements Based on System Size

<table>
<thead>
<tr>
<th>System Size</th>
<th>viewLinc Enterprise Server Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Large</strong></td>
<td>A dedicated machine, 3.2 GHz, Quad Core, 16 GB RAM; Sufficient HD space to support 200 KB / data point / day. For example, if you have 400 linked device channels, you need approximately 30 GB (400 × 200 × 365) per year.</td>
</tr>
<tr>
<td>More than 100 devices (400+ channels)</td>
<td></td>
</tr>
<tr>
<td><strong>Medium</strong></td>
<td>A dedicated or shared machine, 1.6 GHz, Dual Core, 12 GB RAM; Sufficient HD space to support 200 KB / data point / day. For example, if you have 40 linked device channels, you need approximately 3 GB (40 × 200 × 365) per year.</td>
</tr>
<tr>
<td>Up to 20 devices (up to 400 channels)</td>
<td></td>
</tr>
<tr>
<td><strong>Small</strong></td>
<td>A dedicated or shared machine, 1.6 GHz, Dual Core, 8 GB RAM; Sufficient HD space to support 200 KB / data point / day. For example, if you have 4 linked device channels, you need approximately 300 MB (4 × 200 × 365) per year.</td>
</tr>
<tr>
<td>Less than 5 devices (&lt;20 channels)</td>
<td></td>
</tr>
</tbody>
</table>

To increase the number of monitored devices on your network, make sure you have a license to support all the devices you need (see Help > About).

1.2.7  End User PC and Remote Display Requirements

Other machines connected to your network which have an Internet browser installed, can be used to monitor devices. The machine must meet these minimum requirements:

- 2.4 GHz
- 4 GB RAM
- Google Chrome™, Microsoft® Internet Explorer® 11, or Microsoft Edge®

1.2.8  Default Application File Locations

It is recommended that you use the default installation folders for data file storage, as other folders may have unique security restrictions placed on them (restrictions vary between operating systems).

Table 7  Default Installation Folders

<table>
<thead>
<tr>
<th>Installed Files</th>
<th>Default Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program files</td>
<td>\Program Files\Vaisala\Vaisala viewLinc</td>
</tr>
<tr>
<td>Data files</td>
<td>\Users\Public\Public Documents\Vaisala\Vaisala viewLinc</td>
</tr>
</tbody>
</table>
1.3 What’s New

Vaisala viewLinc 5.1 provides you and your team with new integrated feature functionality to expand your network monitoring and reporting capabilities.

Table 8 New viewLinc 5.1 Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signal tower support</td>
<td>Connect signal towers for wide-area visual and/or audible alarming (specific Patlite tower models supported).</td>
</tr>
<tr>
<td>Modbus device communication</td>
<td>Expand your system capability by connecting Modbus-enabled environmental measurement devices to viewLinc, such as Vaisala or third-party devices. Requires Modbus device license to connect non-Vaisala Modbus devices.</td>
</tr>
<tr>
<td>Voice and/or SMS notifications via web service</td>
<td>Set up call tree notifications using a web-enabled voice call messaging service. Sign up for an account with Twilio to allow this web service provider to manage outgoing voice and/or SMS notifications and incoming acknowledgements. Requires Voice and/or SMS web service license(s).</td>
</tr>
<tr>
<td>Vaisala OPC UA Server integration</td>
<td>Share viewLinc data with other applications. The Vaisala OPC UA Server is standalone software installed on a separate server. Requires Vaisala OPC UA Server license.</td>
</tr>
<tr>
<td>Web API</td>
<td>Use an HTTP application programming interface to initiate requests for viewLinc data from third party applications. Requires viewLinc Web API license.</td>
</tr>
</tbody>
</table>

To increase the number of monitored devices on your system, an additional viewLinc license may be required. To see the remaining available device room see Help > About.

Table 9 Key Features of viewLinc

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VaiNet support</td>
<td>Supports RFL100 and AP10 devices, using VaiNet wireless technology.</td>
</tr>
<tr>
<td>Setup support</td>
<td>Interactive tours help both new and seasoned users.</td>
</tr>
<tr>
<td>User guidance at your fingertips</td>
<td>User-focused design ensures more intuitive software interaction.</td>
</tr>
<tr>
<td>Flexible alarm notifications</td>
<td>Send visual, audible, email, SMS or voice alarm notifications when conditions you are monitoring are out of compliance or if there is a network communication problem.</td>
</tr>
</tbody>
</table>
### Feature Description

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlled access</td>
<td>Manage access to monitored areas, system configuration or alarm acknowledgement functions according to a user’s group.</td>
</tr>
<tr>
<td>Multi-level thresholds</td>
<td>Easily enable one or more threshold levels on one template.</td>
</tr>
<tr>
<td>Integrated software functionality</td>
<td>Configure data logger calibration duration and other important device settings in viewLinc, without requiring additional software.</td>
</tr>
<tr>
<td>Multi-language support</td>
<td>Send reports and notifications to your team members around the world in one of eight languages (EN, FR, DE, ES, PT, SV, JA, ZH).</td>
</tr>
<tr>
<td>Wireless device discovery</td>
<td>All new wireless devices connected to your network are automatically discovered by viewLinc.</td>
</tr>
<tr>
<td>System security</td>
<td>All users who log in to viewLinc require a secure connection. During installation you can upload existing security certificate and key files, or automatically generate viewLinc-signed certificate and key files.</td>
</tr>
<tr>
<td>Audit trail security</td>
<td>Store complete audit trail records for reporting compliance with 21 CFR Part 11 and other regulatory and accreditation requirements.</td>
</tr>
<tr>
<td>Monitoring visibility</td>
<td>Add site maps to the dashboard to easily identify your devices and the areas where they operate.</td>
</tr>
<tr>
<td>Easy alarm response</td>
<td>Create predefined comments that can be used to provide a quick response to alarm notifications.</td>
</tr>
<tr>
<td>Data monitoring</td>
<td>View real-time data in a customizable, graphical format.</td>
</tr>
<tr>
<td>Global reporting</td>
<td>Generate reports on historical data and alarm reports according to user-specified language.</td>
</tr>
<tr>
<td>Efficient data logger maintenance</td>
<td>Swap a device for calibration or replacement purposes without breaking the data audit trail.</td>
</tr>
</tbody>
</table>

### More Information

- Adding Modbus Devices (page 210)
- Web Service for SMS and Voice Alarm Notifications (page 97)
- Vaisala OPC UA Server (page 141)

### 1.3.1 What’s New for Upgrade Users

Here is a review of important enhancements and changes from viewLinc 4.3 and earlier.
Table 10  Enhancements

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reusable notifications</td>
<td>Separate alarm notification templates can be applied to device alarm and threshold alarm settings. These templates define the type of notification to initiate when an alarm is activated (email/SMS/command/voice call), who to notify, and whether to delay or repeat notifications.</td>
</tr>
<tr>
<td>Automatic TLS certificate</td>
<td>When you install viewLinc you can automatically generate the certificates required to keep your system secure. For more information see Security Requirements (page 10).</td>
</tr>
<tr>
<td>generation</td>
<td></td>
</tr>
<tr>
<td>Easy access to licensed feature</td>
<td>Access current licensing information, such as the number of supported devices on your network, in the About window (Help &gt; About).</td>
</tr>
<tr>
<td>status</td>
<td></td>
</tr>
<tr>
<td>Simplified access control</td>
<td>To ensure greater control over user access to different functional areas of viewLinc, rights and permissions are now only assigned to groups.</td>
</tr>
<tr>
<td>Verified site security</td>
<td>All new installations of viewLinc require that you provide a security certificate and key file. During viewLinc Enterprise Server software installation, you can install existing certificate and key files, or automatically generate certificate and key files.</td>
</tr>
<tr>
<td>Expanded email support</td>
<td>viewLinc now includes support for both IMAP and POP3 email settings.</td>
</tr>
<tr>
<td>Improved graphing options</td>
<td>Create data trends with up to 16 Locations and 4 measurement types.</td>
</tr>
<tr>
<td>Distributed system alarm</td>
<td>Never miss a notification—configure system alarm notifications to include distribution to members of the viewLinc Administrators group.</td>
</tr>
<tr>
<td>notifications</td>
<td></td>
</tr>
<tr>
<td>User-friendly terminology</td>
<td>Zones and Locations are collectively referred to as Sites; On-demand reports are now Quick Reports. To learn about all terminology changes, refer to the Glossary.</td>
</tr>
</tbody>
</table>

Table 11  Important Changes for Upgrade Users from 4.3 or earlier

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview window, Getting Started</td>
<td>The Getting Started tab in the Overview window displays links to online Help in three categories, Set up, Learn, Use.</td>
</tr>
<tr>
<td>Devices</td>
<td>When new wireless devices are recognized on your network, you are notified on the viewLinc desktop automatically. To learn more, see Accepting Wireless Devices (page 47).</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Zones and Locations</td>
<td>Management of Zones and Locations is performed in Sites Manager. To avoid confusion between device and Location descriptions, you can now only use drag and drop functionality to link Locations within Zones. To learn more, see Create Zones and Locations (page 61).</td>
</tr>
<tr>
<td>Access Control</td>
<td>Permissions are only assigned to groups. For users who had permissions assigned in an earlier version, those permissions are still valid (legacy permissions); however, it is recommended that you remove user permissions and add the user to a group with the required permission level. Configure Custom Thresholds, is now Configure Alarms, and Hide permission is now managed by removal of View permission. New permissions are granted at the Zone level. To learn more, see Applying Group Permission to Zones (page 126).</td>
</tr>
<tr>
<td>Users and Groups</td>
<td>Assign a user-preferred language for receiving alarm notifications and reports. Rights are now assigned only to groups. For users who had rights assigned in an earlier version, those rights are still valid (legacy rights); however, it is recommended that you remove user rights and add the user to a group with the required rights. Manage Comments is now included in the Manage System right; Manage Threshold Templates is now included in Manage Alarm Templates right. Manage Locations is renamed Manage Sites. To learn more, see Groups and Users (page 73).</td>
</tr>
</tbody>
</table>
| Alarm Templates             | Alarm notification details have been removed from threshold and device alarm templates, and are stored as independent alarm notification templates. Alarm notification templates can be added to a Location’s device alarm settings, and to a Location’s assigned threshold alarm settings. In Device and Threshold Alarm templates, the alarm color is identified as the alarm priority:  
  - High
  - Medium
  - Low
  - Information
To learn more, see Alarm Templates (page 79). |
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Threshold Alarm Templates:** | • All threshold alarms support up to 5 thresholds.  
• All upgraded single-level thresholds can remain single or be set up to include additional threshold levels.  
• All threshold settings are captured in threshold alarm templates. If you had created private thresholds for specific Locations they are converted to threshold alarm templates on upgrade. |
| **Alarm Notification Templates:** | • Alarm notification templates identify who gets notified in the event of an alarm condition, when the notification is sent, and how it is delivered (email, SMS, command).  
• If you had notification settings assigned to specific Locations (private settings), notification details are saved as alarm notification templates. The new alarm notification templates are applied to the original Locations.  
• If you had notification settings assigned to any alarm or threshold templates, they are separated and stored as independent alarm notification templates. |

Embedded alarm messages and comments are not saved on upgrade. Prior to upgrade, save them as predefined comments and then apply them to Location threshold settings or device alarm settings.

• Pop-up alarm notifications are no longer supported.  
• Email addresses to non-viewLinc users are removed on upgrade.

Create new user profiles in viewLinc to save external email recipients.

<table>
<thead>
<tr>
<th>Device Alarm Templates</th>
<th>are now applied and managed on Locations.</th>
</tr>
</thead>
</table>

**Email and SMS Content:**  
If you specify an alarm message or comment for auto-generated system alarm notifications or threshold alarm notifications, the content is included automatically in the associated default email templates and can be included in custom email or SMS templates. To learn more, see Notification Content (page 104).
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Preferences</td>
<td>System alarm, email and SMS settings are configured in the <strong>System Preferences</strong> window. To learn more, see [System Preferences](page 107).</td>
</tr>
<tr>
<td>Views</td>
<td>Find all your views in the new <strong>Overview</strong> window. All users have access to and can create their own views in the <strong>Views Manager</strong> window. Manage Views right is required to share a view with others. Note that a pinned view is now a default view. To learn more, see [Your Views](page 132).</td>
</tr>
<tr>
<td>Reports</td>
<td>To review changes in report output content and format, see samples in the <strong>Reports</strong> window. Email addresses to non-viewLinc users are no longer permitted, and are removed on upgrade. All users can create reports and assign ownership to other users. Ownership allows other users to modify or share a report. To learn more, see [Reporting](page 173).</td>
</tr>
<tr>
<td>Trends</td>
<td>Trends can be built in <strong>Sites</strong> or <strong>Overview</strong> windows. Set threshold line color in a threshold alarm template. To learn more, see [Building Trends](page 167).</td>
</tr>
</tbody>
</table>
| Terminology           | Terminology changes:  
  • Sites = a collection of Locations and Zones  
  • On-demand reports = Quick Reports  
  • Deadband = Alarm off margin  
  • Access Control List = Permissions  
  • Permissions Inspector = Permissions Viewer  
  To learn about all terminology changes, refer to the Glossary.                                                                 |

**More Information**

- [What’s New](page 15)

**1.3.2 Watch a Tour**

Learn about key changes with the redesigned viewLinc desktop or discover new viewLinc functionality. There are two types of tours available:

- **Orientation Tours:** Tour steps describe important functions.
- **Task Tours:** Tour steps allow you to complete specific viewLinc tasks.

Watch for the icon 🗻. Available tours can be found in [Help > Tours](#).
1.4 Device Connection Options

Your viewLinc Enterprise Server can support a combination of device connections and setup configurations.

1.4.1 Ways to Connect Hardware

How you connect devices to your network is a very important administrative decision. It is possible to use a mix of the following connection methods depending on your system requirements.

For specific installation and configuration information, see the device user guide.
1.4.2 Using Wireless Devices

VaiNet RFL100 Series

RFL100 series data loggers connect using Vaisala VaiNet protocol. To use VaiNet data loggers in your network, you require an AP10 access point. Refer to the RFL100 and AP10 device documentation for complete setup and configuration instructions.

Connected and configured RFL100 devices are automatically recognized by viewLinc.

HMT140 Series

HMT140 series data loggers connect using Wi-Fi protocol. To add HMT140 series data loggers to your network, you will need an HMT140 configuration cable and HMT140 Utility software (shipped with the device). Refer to the HMT140 device documentation for complete setup and configuration instructions.

Connected and configured HMT140 devices are automatically recognized by viewLinc.
300 Series Transmitter

300 series transmitters connect using a WLAN or LAN interface. To add HMT300 series data loggers to your network refer to the device documentation for complete installation instructions.

More Information

‣ Adding Access Point Hosts (page 46)
‣ Accepting Wireless Devices (page 47)
‣ Adding 300 Series Transmitters (page 49)

1.4.3 Using vNet Devices

vNet Power-over-Ethernet devices are 802.3af compliant and work with both end-point and mid-span systems. viewLinc Aware automatically detects and configures DL series data loggers connected with vNet devices (requires vNet device drivers provided with vNet devices). For information about connecting Vaisala data loggers to your network using vNet devices, see the vNet User’s Guide.

If you are installing vNet devices on the same subnet as viewLinc, device drivers are installed automatically when you enable viewLinc Aware functionality.

More Information

‣ Discovering Networked Devices (page 47)
‣ Enabling or Disabling viewLinc Aware (page 113)

1.4.4 Using Single or Multi-Port Ethernet Device Connectors

You can connect Vaisala DL series data loggers and Modbus devices to your viewLinc network using single- or multi-port Ethernet connection devices (such as Digi or Moxa devices).
When you set up viewLinc for the first time, viewLinc automatically detects and configures Ethernet-connected DL data loggers; Modbus devices must be added manually. DL data loggers can also be added with the Discover Devices function, or use the Add New Device procedure. For complete network installation instructions, refer to your Ethernet product documentation.

More Information
- Discovering Networked Devices (page 47)
- Adding Modbus Devices (page 210)
- Adding Devices Manually (page 48)

1.4.5 Using USB Ports

Connect Vaisala DL series data loggers or Modbus RTU devices directly to viewLinc Device Host servers using a Vaisala USB-to-logger cable connected to a USB port.

1. Install USB drivers on each server used to connect devices.
2. Connect the Vaisala device to a Vaisala USB-to-logger cable.
3. Connect the Vaisala USB-to-logger cable to your viewLinc Device Host (ensure the computer is attached to your network). You only need to install drivers once on each machine to which devices are connected.

Repeat these steps for all devices. USB-connected devices are recognized automatically in viewLinc, or can be discovered manually.

More Information

‣ Discovering Networked Devices (page 47)
‣ Adding Devices Manually (page 48)

1.4.6 Using Serial Ports

Connect Vaisala DL series data loggers or Modbus RTU devices directly to viewLinc Device Host servers using a Vaisala serial-to-logger cable connected to a serial COM port.

1. Connect the Vaisala device to a Vaisala serial-to-logger cable.
2. Connect the Vaisala serial-to-logger cable to your viewLinc Device Host server (ensure the computer is attached to your network).

Repeat these steps for all devices. Serial-connected devices are recognized automatically in viewLinc, or can be discovered manually.

More Information

‣ Discovering Networked Devices (page 47)
‣ Adding Devices Manually (page 48)

1.5 Version Information

This document provides information for installing, configuring, and operating the Vaisala viewLinc Enterprise Server software. This document is intended for both viewLinc administrators and users.
• Administrators: Learn how to install and configure viewLinc Enterprise Server software and its associated components, and support users with ongoing system administration tasks.
• Users: Learn how to complete common viewLinc tasks, such as viewing and monitoring device readings across your network.

Table 12  Document Versions

<table>
<thead>
<tr>
<th>Document Code</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M212315EN-A</td>
<td>October 2019</td>
<td>First version</td>
</tr>
</tbody>
</table>

1.6  Related Manuals

Table 13  Related Manuals

<table>
<thead>
<tr>
<th>Document Code</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>M212316EN</td>
<td>Vaisala viewLinc Monitoring System Setup Guide</td>
</tr>
<tr>
<td>B211832EN</td>
<td>Vaisala viewLinc Enterprise Server Software Datasheet</td>
</tr>
<tr>
<td>M211700EN</td>
<td>Vaisala vNet PoE Network Interface User Guide</td>
</tr>
<tr>
<td>M211821EN</td>
<td>Vaisala VaiNet Access Point API10 Quick Guide</td>
</tr>
<tr>
<td>M211822EN</td>
<td>Vaisala VaiNet Wireless Data Logger RFL100 Quick Guide</td>
</tr>
<tr>
<td>M211860EN</td>
<td>Vaisala VaiNet Access Point API10 User Guide</td>
</tr>
<tr>
<td>M211861EN</td>
<td>Vaisala VaiNet Wireless Data Logger RFL100 User Guide</td>
</tr>
<tr>
<td>M212325EN</td>
<td>Vaisala OPC UA Server User Guide</td>
</tr>
</tbody>
</table>

1.7  Documentation Conventions

This document uses the following conventions:

• Menu options, items you select, and the names of tabs, windows, and buttons are shown in **bold**.
• A sequence of menu item selections is indicated by a list separated by an arrow. For example: “In viewLinc, select Help > Tours”
• Keys on the keyboard are shown in **CAPS**.
• Vaisala data loggers, device hosts and access points are all devices.

⚠️ The lock icon indicates the rights required to perform a viewLinc task.
1.8 Trademarks

Vaisala® is a registered trademark of Vaisala Oyj.

Android™ is a trademark of Google LLC.

Apple® and iPhone® are trademarks of Apple Inc., registered in the U.S. and other countries.

Chrome™ is a trademark of Google Inc.

Microsoft®, Windows®, Internet Explorer®, Excel®, and Edge™ are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other product or company names that may be mentioned in this publication are trade names, trademarks, or registered trademarks of their respective owners.

1.9 Training

For new users of viewLinc, or those who might need to refresh their knowledge, Vaisala provides both remote or onsite training, and access to a series of eLearning videos you can view at your convenience.

For customers with active support plans, see www.vaisala.com/viewLinc-eLearning.

To learn more about Vaisala Services, contact Vaisala Technical Support at helpdesk@vaisala.com.
2. Setup and Installation

Each viewLinc monitoring system installation is unique. Use the setup checklist to identify your specific site requirements and ensure an efficient and successful installation of the viewLinc monitoring system components.

2.1 Setup Roadmap

1. Setup checklist
2. Install viewLinc Enterprise Server
3. Install devices
   - Install access points
   - Install data loggers
   - Install other devices
   - Discover and accept devices
4. Configure viewLinc Enterprise Server
   - Create zones and locations
   - Add groups and users
   - Define alarm templates
   - Set system preferences
5. Test system

Setup complete

If you require assistance with the setup of your system, the Vaisala Technical Support team is ready to assist you, free of charge at helpdesk@vaisala.com.
2.2 Setup Checklist

<table>
<thead>
<tr>
<th>viewLinc Enterprise Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐ A system administrator is available to help me with network and server configuration.</td>
</tr>
<tr>
<td>☐ A dedicated network server is allocated to run viewLinc Enterprise Server 24x7. I know its IP address and hostname, and it meets minimum installation requirements.</td>
</tr>
<tr>
<td>☐ The server’s network connection is to a secure network, and the network type has been appropriately set on the server (Private or Domain, not Public).</td>
</tr>
<tr>
<td>☐ I know the address of the Network Time Protocol (NTP) server in the network.</td>
</tr>
<tr>
<td>☐ My laptop or workstation meets minimum client requirements.</td>
</tr>
<tr>
<td>☐ I know where the program files and viewLinc database should be stored. A backup system is in place to make sure the files are recoverable in case of server failure.</td>
</tr>
<tr>
<td>☐ I have the required security certificate and key files, or have the information needed to generate a security certificate and key during installation.</td>
</tr>
<tr>
<td>☐ I have the USB drive that contains the viewLinc setup files and license key.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐ I have a plan that lists device serial numbers, mounting and installation information.</td>
</tr>
<tr>
<td>☐ IP addresses are allocated for my HMT330 series transmitters and data loggers’ network connections (DHCP address reservations or static IPs).</td>
</tr>
<tr>
<td>☐ Planned locations of wired devices are within 180 cm (6 feet) distance of power outlets.</td>
</tr>
<tr>
<td>☐ I know if drilling or door access is required for probes (for example, freezer installation).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Network</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐ Ethernet network drops with RJ45 jacks are installed and tested at each location where a wired network connection is needed.</td>
</tr>
<tr>
<td>☐ A Power over Ethernet (PoE) injector or switch provides operating power at network drops where a PoE powered device will be installed.</td>
</tr>
<tr>
<td>☐ (Optional) I have installed a supported modem for SMS notifications.</td>
</tr>
<tr>
<td>☐ (Optional) I have an account set up with a voice/SMS web notification service provider (Twilio), and an internet-accessible port available.</td>
</tr>
</tbody>
</table>

1) *Software product purchase entitles you to basic support, which is limited to hardware and software installation assistance. Comprehensive support is available through the purchase of a support plan.*
Optional License Keys

I have the license key(s) required to enable one or more of the following features:

- [ ] Voice web service
- [ ] SMS web service
- [ ] Modbus devices (non-Vaisala)
- [ ] Vaisala OPC UA Server
- [ ] Web API

2.3 Installation

All viewLinc monitoring systems require the installation of viewLinc Enterprise Server software on a local or remote dedicated server. If you are setting up a medium or large monitoring system using several devices, it is recommended that you install viewLinc Device Host software on additional dedicated servers for greater network stability and flexibility.

- **viewLinc Enterprise Server software**: This installation software is required on the dedicated Windows server, to monitor and administer all devices connected to it, wired and wireless. It defines the system language, data storage paths, and monitoring conditions.
- **viewLinc Device Host software**: This installation software can be installed on additional, dedicated servers. It allows automatic communication with the viewLinc Enterprise Server computer while offering protection from bandwidth and network communication issues. It provides you with greater flexibility when managing device configuration across a large network.

Refer to the Device Host and Enterprise Server requirements for different installation sizes, to determine if your system is better suited to one or both software installations.

During viewLinc Enterprise Server software installation you are required to either upload your company’s existing security certificate and key files, or generate viewLinc-signed files.

More Information

- Hardware Requirements (page 11)
- Server Requirements (page 11)
- Installed System Size (page 13)
- Security Requirements (page 10)

2.3.1 Installing viewLinc Enterprise Server Software

If you have a previous version of viewLinc software installed, see Installing viewLinc - Upgrade an Existing Server (page 32) or Installing viewLinc - Upgrade on a New Server (page 34).

1. Ensure you have completed the Setup Checklist and have recorded the serial number from your viewLinc USB.
2. On the dedicated viewLinc Enterprise Server, insert the viewLinc USB and run `viewLincInstall.exe`, if it does not start automatically.

To install viewLinc software on a remote server (and not the local computer), copy `viewLincInstall.exe` from the USB drive to the destination server.

3. Select the installation language. This language setting is used in the wizard and is used as the viewLinc browser, report and notification default language. The default language can be changed after installation is complete.

Users can change the browser language at log in. The language used in their reports and notifications is set in each user’s profile.

4. Start the installation wizard.

5. Enter your license key.

6. Select the installation package. All viewLinc monitoring systems require Vaisala viewLinc Enterprise Server. If your system will support a large installation with several devices, rerun the install wizard to install viewLinc Device Host software on additional dedicated servers.

7. Accept the Vaisala General License Conditions and BerkleyDB License Agreement.

8. Accept the default installation path for the viewLinc software, or specify a new destination folder (location must have at least 2 GB of free disk space).

9. Accept the default installation path for viewLinc data, or specify a new destination folder (location must have at least 10 GB of free disk space).

10. Choose your certificate and security key files:

    **Upload a purchased certificate and key (trusted)**
    Choose this option if you already have the files and they are available on your network.

    **Generate a certificate and key (viewLinc-signed)**
    Enter your site and company details (if you plan to use a trusted certificate, the Hostname must be a fully qualified domain name, such as `viewLincESname.yourcompanyname.com`). The installation wizard automatically generates a viewLinc-signed certificate and key file. These files are installed on the server the first time the admin user logs into viewLinc. You can replace the generated files with trusted files at any time.

11. Select **Install** to complete the installation wizard.

When installation is complete you can set up your devices or begin viewLinc configuration (see *Vaisala viewLinc Monitoring System Setup Guide*).

If you are ready to start viewLinc configuration, double-click the viewLinc shortcut icon on your desktop.
2.3.2 Installing viewLinc on a Device Host Server

You can also set up additional computers as Device Hosts. This option allows for greater flexibility when managing devices, reduces the bandwidth required to communicate from server to device, and reduces the chance of network interference.

You may need to adjust your firewall settings to specify public/private domain exceptions. Contact Vaisala customer support if you require assistance.

1. Insert the viewLinc USB and run viewLincInstall.exe.
2. Select the installation language.
3. Start the installation wizard.
4. Accept the Vaisala and BerkleyDB license agreements.
5. Enter the license key number, found on the USB package.
6. Choose a destination for the viewLinc program files.
7. Select Device Host.
8. Select Install.
9. When the application is finished installing, select Finish.

With all necessary viewLinc components installed, you can now use any machine on the network to log in to viewLinc to monitor conditions.

All users can access viewLinc from their own PC or mobile device, without having to install any software; however, their PC must be running a supported Internet browser, they require the IP address where viewLinc is installed, and must be set up as a user in viewLinc.

2.3.3 Installing viewLinc - Upgrade an Existing Server

To ensure a successful upgrade of your viewLinc software on an existing server, make sure your system meets the viewLinc system requirements, and review the new features and functional changes introduced in viewLinc. See What’s New for Upgrade Users (page 16).
Before you start the viewLinc software upgrade, export a copy of your event log. After upgrade, export the event log again to become familiar with messaging improvements in viewLinc 5.

1. Ensure you have completed the Setup Checklist and have recorded the license key that is included with the viewLinc USB drive.
2. Verify that the current installation of viewLinc is version 3.6.1 or higher.
3. Back up your current application data directory.
   - viewLinc 3.6x default directory: `...\Program Files\Veriteq Instruments\viewLinc`
   - viewLinc 4.x default directory: `...\Public Documents\Vaisala\Vaisala Veriteq viewLinc` (exclude the `debug` folder and any files named `log`)
4. If your backup application does not support open database backup, stop viewLinc Watchdog and viewLinc Enterprise Server services:
   a. On your Windows server, select `Start > Control Panel > Administrative Tools > Services` (this path may vary depending on your Windows version and settings).
   b. Right-click on the service (viewLinc Enterprise Server, viewLinc Watchdog), then select `Stop`.
5. On the existing viewLinc server, open the `viewLinc.cfg` file (found in the `\config` subfolder) and set the level entry to debug (in the `[logging]` section), `level = debug`.

   **CAUTION!** Modifying the `.cfg` file should only be performed by qualified system administrators.

6. On the existing viewLinc server, insert the viewLinc USB drive and run `viewLincInstall.exe`, if it does not run automatically.
7. Select the installation language. This language setting is used in the wizard and is used as the viewLinc browser, report and notification default language. The default language can be changed after installation is complete.
8. Accept the Vaisala and BerkleyDB license agreements.
9. Enter the viewLinc license key.
10. Select your security certificate and key files. You can choose to keep the currently installed certificate and key files, upload new certificate and key files, or automatically generate viewLinc-signed certificate and key files.
11. Review the install settings and click **Install**.
12. Click **Finish**.
13. Wait 20 minutes to an hour for viewLinc to upgrade the database. viewLinc will not be available during this time. There will be a gap in the Events log reflecting the duration of the upgrade.

14. If your network includes viewLinc Device Hosts, run the install wizard to install viewLinc 5 Device Host software on each device host server.

15. On the viewLinc Enterprise Server, double-click the desktop icon to start viewLinc in a supported browser. It may take a few minutes to start. If a security warning appears, click OK to proceed. For more information about certificates see Security Requirements (page 10).

16. Log in with your administrator credentials, such as admin/admin.

17. Open Sites Manager to verify your Location data is available.

18. In System Preferences on the General tab, set System log to Basic.

There will be a gap in the events log reflecting the duration of the upgrade.

More Information

‣ Hardware Requirements (page 11)
‣ What’s New for Upgrade Users (page 16)
‣ Installation Tips (page 221)

2.3.4 Installing viewLinc - Upgrade on a New Server

If you are upgrading viewLinc on an existing server, see Installing viewLinc - Upgrade an Existing Server (page 32).

1. Ensure you have completed the Setup Checklist and have recorded the license key that is included with the viewLinc USB drive.

2. Verify that the current installation of viewLinc is version 3.6.1 or higher.

3. Make a copy of the application data directory on the old server and store it in a secure network location.
   • viewLinc 3.6x default directory: ...\Program files\Veriteq Instruments \viewLinc\  
   • viewLinc 4.x default directory: ...\Public Documents\Vaisala\Vaisala Veriteq viewLinc\ (exclude the \debug folder and any files named log \watchdog*.*

4. On the new viewLinc server, insert the viewLinc USB drive and run viewLincInstall.exe.

5. Select the installation language. This language setting is used in the wizard and is used as the viewLinc browser, report and notification default language. The default language can be changed after installation is complete.

6. Accept the Vaisala and BerkleyDB license agreements.
7. Enter the viewLinc license key.

8. Select your security certificate and key files. You can choose to keep the currently installed certificate and key files, upload new certificate and key files, or automatically generate new certificate and key files. To learn more about security and certificate files, see Frequently Asked Questions (page 221).

9. Review the install settings and click Install.

10. Click Finish.

11. If your network includes viewLinc Device Hosts, run the install wizard to install viewLinc 5 Device Host software on each device host server.

12. On the new viewLinc Enterprise Server, double-click the desktop icon to start viewLinc in a supported browser. It may take a few minutes to start. If a security warning appears, click OK to proceed.

13. Log in with viewLinc 5 administrator credentials, admin/viewL!ncAdm1n.


15. On the viewLinc Enterprise Server, stop all viewLinc services (select Start > Control Panel > Administrative Tools > Services. This path may vary depending on your Windows version and settings); right-click on each service, then select Stop).

16. From the stored network location, copy the backup \db and \log folders and replace the \db and \log folders in:C:\Users\Public Documents\Vaisala\Vaisala\viewLinc\.

17. On the viewLinc Enterprise Server, restart viewLinc services, then wait 20 minutes to an hour for viewLinc to upgrade the database. viewLinc will not be available during this time. Do not stop or restart services during this period. There will be a gap in the Events log reflecting the duration of the upgrade.

18. Open Sites Manager to verify your Location data is available.


2.4 Install Devices

See device-specific documentation for detailed instructions.

If you are upgrading an existing system without adding new devices, you can skip this section.

Create a device installation plan to keep track of data logger serial numbers and installation locations.
2.4.1 Install Access Points

Set up your VaiNet access points so that:

- They are able to connect to the Ethernet network
- They have the IP address or hostname of at least one NTP server they can access
- Their VaiNet channel number is set
- They have the IP address or hostname of viewLinc Enterprise Server
- They are in installation mode so that they can connect new VaiNet data loggers to the system

If you have new WLAN access points, configure their network and wireless settings.

When your wireless access points are set up, install them at their planned locations.

2.4.2 Install Data Loggers and Transmitters

Set up your data loggers and transmitters so that they are ready for installation.

If you have Vaisala vNet PoE Data Logger Interfaces for your wired data loggers, follow vNet documentation to connect and configure them.

Mount the data loggers and transmitters at their planned locations.

You can install many other types of devices to a viewLinc Monitoring System. See viewLinc User Guide for instructions on how to make use of these devices:

- viewLinc device hosts for connecting devices on a remote location
- Measurement devices with Modbus RTU or Modbus TCP/IP output
- Signal towers for visual and audible alarm status recognition
- Remote display terminals for viewing data

2.5 Log in to viewLinc

You can log in to viewLinc from any PC with a supported Internet browser.

1. Double-click the desktop icon or type the server’s IP address and port in a web browser address field. Your administrator provides the correct IP address. For example, https://comptername: [portnumber]. If no port number is specified, 443 is used by default.

Save this address to your browser favorites list or set it up as your homepage to easily access viewLinc from your browser.
2. On the viewLinc login screen, select the language you want to use for viewLinc display. When a new language is selected, the page will automatically refresh and update accordingly.

To save your display language setting, ensure that your browser is not set to automatically delete cookies upon exit. To set a default language for reports and notifications that are sent to you, set your preferred language in your user profile.

3. Type your username and password.
   • The first time the viewLinc system administrator logs in, type the default administrator username and password, admin/viewL!ncAdm1n.

   For security purposes, it is important to change the default admin user password as soon as possible.

   • If you are a member of the Administrators group and this is the first time you are logging in to viewLinc, a brief setup tour starts automatically. Complete the tour to familiarize yourself with the main setup requirements.
   • If you are not an Administrators group member and this is the first time you are logging in to viewLinc, watch the Welcome tour, Using viewLinc, to familiarize yourself with viewLinc.

After you complete or exit a tour, the viewLinc Overview window displays the Getting Started page.

More Information
   • Adding Users (page 76)
   • Groups and Users (page 195)

2.6 Discover and Accept Devices

Data loggers must be accepted or added to the system before their data can be collected and used.

1. Open the viewLinc Enterprise Server user interface by double-clicking the desktop icon or by entering the server’s IP address and port in a web browser’s address field.
2. Log in to viewLinc Enterprise Server as the default administrator user (username, admin, password, viewLincAdmin).

It is recommended that you change the default administrator password immediately after logging in to ensure site security. Remember to record the new password in a safe location.

3. If this is the first time logging in as the admin user, a brief setup tour starts automatically. Complete the tour to familiarize yourself with system setup.

4. When viewLinc detects new devices, New Devices text appears at the top of the screen. Click it to open the New Devices window.

5. Compare the list of new devices to your device installation plan to verify that all your devices have been found. In the Accept column, select each device you want to add.

6. Select Save to register the selected devices with your viewLinc Enterprise Server.

7. Open the Sites Manager window and select the Hosts and Devices tab. On the Hosts and Devices tree, verify that all of your devices are now listed.

- If none of your devices are listed, check that network traffic to ports used by viewLinc (for example, 12600, 771, and 6767) is not blocked by a firewall.
- If some devices are missing, make sure they are configured, powered on, and connected to the network. Refer to the device-specific documentation for troubleshooting assistance.
- If the automatic discovery is not finding all of the devices, refer to the viewLinc User Guide for instructions on how to add or discover devices manually.

2.7 Configuring viewLinc Enterprise Server

After installing, accepting or adding devices, you are ready to configure the viewLinc Enterprise Server to meet site-specific monitoring needs. Several interactive tours are available from the viewLinc desktop Help > Tours menu:
1. **viewLinc Enterprise Server configuration**
   - Create Zones and Locations
   - Add groups and users
   - Add and apply alarm templates
   - Set system preferences

   **Use the Planning Worksheet to define:**
   - Names for your monitored sites (Zones and Locations)
   - Users, their assigned groups, rights and permissions
   - Alarm thresholds required for different Locations
   - Alarm notification delivery methods (email/SMS/command/voice), and notification escalation paths

2. **Optional setup tasks**
   - Assign permissions to groups
   - Set up schedules for alarms and notification periods, and report generation
   - Create predefined comments
   - Define views
   - Add signal towers or remote displays
   - Set up voice and/or SMS web services
   - Connect to Vaisala OPC UA Server

3. **Optional installation verification tasks:**
   - System test
   - Validate system

Online tours are available for each configuration step (see Help > Tours).

### 2.7.1 viewLinc Planning Worksheet

Taking the time to evaluate and define your company's monitoring needs will provide you and your team with a more secure and easy to maintain monitoring system. Review this worksheet to make sure you have the information required to configure viewLinc, then complete the viewLinc Enterprise Server setup steps.

<table>
<thead>
<tr>
<th>Zones and Locations (Sites Manager)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define a naming convention for each area being monitored with one device channel. (1 device channel = 1 Location)</td>
</tr>
<tr>
<td>1.</td>
</tr>
<tr>
<td>2.</td>
</tr>
<tr>
<td>3.</td>
</tr>
<tr>
<td>4.</td>
</tr>
</tbody>
</table>
## Zones and Locations (Sites Manager)

- Create Zones to organize areas with many Locations (optional).
  - 1.
  - 2.

## Groups and Users

- Name your groups, and identify the rights to be assigned to each group.
  - Group name/rights:
  - Group name/rights:

- List your users and the group(s) to which they will be assigned.
  - Users in the default Administrators group (all rights):
  - Users in the default Everyone group (Manage Events right):
  - Users in __________________ group:
  - Users in __________________ group:

- (Optional) For Vaisala OPC UA Server, name of dedicated user and a dedicated group:

## Threshold Alarm Settings (Alarm Templates)

- Record the threshold settings needed for each Location. (High-High, High, Low, Low-Low, Rate of Change, Alarm Off Margin).
  - Location 1:
  - Location 2:
  - Location 3:

## Alarm Notification Settings (Alarm Templates)

- Identify the users or groups to be notified in the event of a threshold alarm, when the notification should be issued, how it will be delivered (email, SMS, command, or voice call).
  - Name:
  - Delay:
  - 1st notice sent via:
## Alarm Notification Settings (Alarm Templates)

<table>
<thead>
<tr>
<th>2nd notice sent via:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repeat?</td>
</tr>
<tr>
<td>Frequency:</td>
</tr>
</tbody>
</table>

(Optional) Voice call tree:

1. Username: ___________________________________________________________________
2. Username: ___________________________________________________________________
3. Username: ___________________________________________________________________
4. Username: ___________________________________________________________________

## General Settings (System Preferences)

- Select remote alarm acknowledgment method(s): email, SMS (web service or modem), and/or voice call acknowledgments. Requires set up of settings for enabled acknowledgement method(s).

- Enable and then create schedules if Location monitoring/alarm acknowledgement is required for certain time periods, or if different groups will receive different alarm notifications.

- Enable audible alarming for browsers. User profiles must be set to allow audible alarms when they are logged in.

- Define display of temperature units and value for MKT.

- Determine whether to use device and channel descriptions in viewLinc, or create longer descriptions (aliases) in viewLinc.

- Select the default calibration duration (default 12 months). Reminder notifications are sent based on this value.

- Determine DL data logger lock settings (automatic or disabled) to add another layer of security.

- Enable and then create pre-configured comments for your users to add when responding to alarm conditions.

- If you are using vNets, save connection time with viewLinc Aware functionality.

- For multilingual companies, determine the language to use for system notifications.

## Email Settings (System Preferences)

- Required: Your IT network manager’s email address to receive all system alarm email notifications.
### Email Settings (System Preferences)

- An available email address that will be used to send viewLinc notifications.
- SMTP server address, port number, account username, and password.
- POP3 server address, port number, account username, and password (optional).

### (Optional) SMS Settings (System Preferences)

- Select method of SMS delivery, via modem or with a web service (Twilio).
- If using an SMS Modem:
  - Configure modem to network
  - Specify modem settings: port/baud rate/SIM card PIN number (if required)
- If using an SMS web service:
  - Set up Twilio account
  - Specify account settings: account SID, authentication token, phone number, and viewLinc URL

### (Optional) Voice Settings (System Preferences)

- Set up Twilio account (www.twilio.com)
- Specify web service account settings (received from Twilio):
  - account SID
  - authentication token
  - phone number
  - viewLinc URL

### System Alarms (System Preferences)

- Mobile number and email address for your designated IT network manager.
- Additional information for system-generated validation alarms: priority, delay, message, comments.

## 2.8 System Test

After all viewLinc configuration and device setup activities are complete, follow these simple steps to ensure your system is running smoothly and securely:

- Verify notification functionality (email/SMS/voice).
- Ensure all devices are calibrated.
- Generate a Location History report to verify that linked Locations are reporting data.
- Review the **Events** window to verify that changes to the system generate an event in viewLinc.
If you are running viewLinc in a GxP environment, you may require validation testing.

More Information

- Device Calibration (page 214)
- Tracking Events (page 162)
- Creating Location History Reports (page 179)

2.9 Validate your System

viewLinc is ideal for GxP/FDA-regulated applications and environments that contain high-value products. If you are required to maintain bullet-proof environmental monitoring methods and documentation, a viewLinc validation can ensure you receive a stamp of approval during the most stringent audits and inspections.

A GxP-compliant Installation Qualification and Operation Qualification protocol document (IQOQ) is available for purchase from Vaisala. It is used to ensure your system is installed correctly, and performs as expected. IQOQ testing must be performed by a qualified technician or Vaisala Field Services. Learn more at www.vaisala.com/contact-us.
3. Device Management

Data is collected from Vaisala monitoring devices connected directly to your network - wired or wireless data loggers and transmitters. Additional devices may be connected to your network, such as Vaisala or non-Vaisala Modbus-enabled environmental monitoring equipment, or signal towers.

Your viewLinc license defines the number of monitoring devices (data loggers/transmitters/Vaisala Modbus devices) that can be added. An additional Modbus license is required to add non-Vaisala Modbus devices. See Help > About to view your current licensed options.

Different types of devices are added to viewLinc in a variety of methods:

- RFL100-series wireless data loggers: Automatically identified, manually accepted.
- vNet devices: Automatically identified and automatically added (if on the same subnet), or added manually.
- DL data loggers: Automatically identified and added automatically or manually.
- HMT140-series data loggers: Automatically identified and added automatically or manually.
- 300-series transmitters: Added manually.
- Modbus devices: Added manually.
- Signal towers: Added manually.

Devices and hosts can be managed by users assigned Manage Devices right. Some configuration tasks can only be performed by members of the Administrators group.
3.1 Device Hosts

For larger viewLinc system installations, viewLinc provides the option of adding multiple servers to act as device hosts. Connecting groups of devices to device hosts provides you with greater control over specific devices (group management for devices connected to a single host), and ensures greater network stability. AP10 access points are the device hosts which manage your RFL100-series data loggers. Additional third-party access points can be added to support groups of 300-series transmitters or HMT140 data loggers.

For example, you may want to monitor devices in multiple offices. Rather than connecting all devices at each office location to the Vaisala viewLinc Enterprise Server machine, set up additional device hosts at each office to support local devices.

This setup allows you to:

- Manage devices more effectively. You may find it easier to pause alarming on all devices connected to a host, rather than trying to pause alarming on specific devices.
- Ensure even distribution of network traffic. Device hosts help manage the flow of device data to the Vaisala viewLinc Enterprise Server.

3.1.1 Adding Device Hosts

Add additional servers as device hosts to help manage groups of devices.

1. On the viewLinc Enterprise Server, open Sites Manager and select the Hosts and Devices tab.
2. In the Hosts and Devices tree, select Configure > Add Host.
3. Type the hostname or IP address.
4. Select OK.
   The viewLinc Enterprise Server automatically discovers the new host and all devices connected to it. Discovery of all devices on the new host may take a few seconds to several minutes to complete. You can continue with other activities during the discovery process. You are notified when the process is complete.
5. Select Yes when prompted to refresh.

More Information

- Installing viewLinc on a Device Host Server (page 32)
3.1.2 Adding Access Point Hosts

Manage Devices

Add additional access points as device hosts to help manage groups of wireless devices. Once connected, access points are automatically recognized in viewLinc.

1. Make sure the access point is configured and connected to your network (refer to the AP10 User Guide for instructions).
2. In Sites Manager select the Hosts and Devices tab and then select Refresh.
3. If the new access point does not appear automatically in the Hosts and Devices tree, add the AP manually.
   a. Select Configure > Add Host.
   b. Type the hostname or IP address.
   c. Select Save.
   d. Select Yes if prompted to refresh viewLinc.

viewLinc automatically accepts the access point, but it may take a few seconds to several minutes to connect all of its RFL data loggers. You can continue with other activities until you receive notification the process is complete. If RFL data loggers are connected to the access point, the New Devices prompt appears at the top of the viewLinc desktop.

More Information

- Accepting Wireless Devices (page 47)

3.2 Ways to Add Devices

As your network monitoring needs increase, it's easy to expand your monitoring capabilities with the addition of new devices.

Depending on the type of devices you are adding to the viewLinc network, the following options are available to you:

- Automatic detection of new RFL100-series or HMT140-series devices (Accept Devices).
- Automatic detection of new DL devices connected via vNet, USB or multi-port Ethernet device (Discover Devices).
- Manual addition, when you want to add several devices of various types at one time, you want to add 300-series transmitters (Add Device), or Modbus devices.

A license key is required for the addition of third-party Modbus devices, and IT Administrator support.
3.2.1 Discovering Networked Devices

**Manage Devices**

Use the Discover Devices feature to identify DL data loggers using USB or serial connection cable, or a non-Vaisala single or multi-port Ethernet device connector. Device discovery can also be used if any DL devices connected using vNet devices are not detected by the viewLinc Aware function. Wireless devices (RFL100 series data loggers or HMT140 series transmitters) are detected automatically.

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. On the **Hosts and Devices** tree, select the host machine to which the device is connected, then select **Configure > Discover Devices** (or right-click and select **Discover Devices**).

This process may take several minutes, depending on the number of devices and/or components in your network.

**More Information**

- Adding Devices Manually (page 48)
- Enabling or Disabling viewLinc Aware (page 113)

3.2.2 Accepting Wireless Devices

**Manage Devices**

When a new RFL100-series data logger is added to your network, it is identified by the nearest access point. When the access point is paired to an RFL100-series data logger it sends a message to viewLinc that a new device is available. HMT140-series data loggers are also automatically identified by viewLinc. Both RFL100-series and HMT140-series data loggers are added to viewLinc using the **New Devices** window.

Once a data logger is accepted by your viewLinc system, it is visible in **Sites Manager** in the **Hosts and Devices** tree.

Refer to the device user guides for more information about setting up data loggers and access points in your facility.

1. Open **Sites Manager**.
2. If viewLinc detects new RFL100-series or HMT140-series devices, New Devices text appears at the top of the Sites Manager window. Select the New Devices prompt.

![Information icon] If the New Devices prompt does not appear, you can add the device manually.

3. In the New Devices window in the Accept column, select the devices you want to add to your viewLinc system. You can accept a device later (select Leave Pending), or flag a device as available for acceptance by another access point host or viewLinc device host (select Reject).

Rejecting a device prevents it from connecting to the selected host. When a device is rejected it becomes available to connect with another host. A rejected device continues to appear in the New Devices window until it connects with the correct host and is accepted in viewLinc.

4. Select Accept.

5. Select Save.

6. Open Sites Manager to verify that all accepted devices are available in viewLinc:
   a. Select the Hosts and Devices tab.
   b. Locate new devices on the Hosts and Devices tree.

### 3.2.3 Adding Devices Manually

**Manage Devices**

You may need to add a device manually to your system if:

- Discovering DL devices is taking too long.
- Wireless devices are not being recognized automatically.
- You are adding a 300-series transmitter.
- You want to add a variety of device types at one time.

![Information icon] Before adding new devices, make sure your viewLinc license has room available to support the number of new devices you want to add. Your current device license status is available from Help > About.

**More Information**

- Adding Modbus Devices (page 210)

#### 3.2.3.1 Adding Vaisala DL Data Loggers

**Manage Devices**

1. In Sites Manager select the Hosts and Devices tab.
2. On the **Hosts and Devices** tree select the Vaisala viewLinc Enterprise Server or a device host, then select **Configure > Add Device > DL Data Logger**.

3. In the **Add Device** window, in the **Port** field, type the COM Port number (to view available COM port numbers, go to the Windows start menu and open Device Manager).

4. Select **Save**.

### 3.2.3.2 Adding 300 Series Transmitters

**Manage Devices**

1. Ensure no other users are logged on to the transmitter you want to add (from a command prompt on the connected PC, type `telnet <IP address>`).

2. In **Sites Manager** select the **Hosts and Devices** tab.

3. On the **Hosts and Devices** tree, select the Vaisala viewLinc Enterprise Server or a device host, then select **Configure > Add Device**.

4. In the **Add Device** window, in the **Device Class** list, select **300 Series Transmitter**.

5. Complete the following:
   - **Timeout**
     To ensure continuous monitoring, do not change (default 30 seconds).
   - **Connection Type**
     If the transmitter has a LAN or WLAN module, select Network. If you use an external single or multi-port Ethernet device, choose COM Port.
   - **IP Address**
     Type the IP address.
   - **Sample Rate**
     Choose 90 (recommended, but you can modify the rate if you need more or less recorded data).

6. Select **Save**.

### 3.2.3.3 Adding HMT140 Series Data Loggers

**Manage Devices**

1. Ensure no users are logged on to the HMT140 you want to add.

2. In **Sites Manager** select the **Hosts and Devices** tab.

3. On the **Hosts and Devices** tree select the Vaisala viewLinc Enterprise Server or a device host, then select **Configure > Add Device**.

4. In the **Add Device** window, in the **Device Class** field, select **HMT140**.
5. Complete the following:

   **Timeout**
   To ensure continuous monitoring, do not change (default 30 seconds).

   **Serial number**
   Type the HMT140 serial number.

   **UDP port**
   Can be modified if required.

   **Max blocks per beacon**
   Accept the default number of data blocks (64) transferred between viewLinc and the device to maximize network efficiency, or modify as required (256 max).

   ![Info](Do not change the **Max blocks per beacon** value for HMT140 data loggers without first consulting your technical support department. Changes to this setting may adversely impact battery life.)

6. Select **Save**.

### 3.2.4 Adding Multiple Device Types

**Manage Devices**

To save time, you can add several types of devices to viewLinc at one time using a definitions file.

1. Create a `.txt` definitions file that identifies the device class and device properties.
2. In **Sites Manager** select the **Hosts and Devices** tab.
3. On the **Hosts and Devices** tree, select a host, then select **Configure > Add Device > Upload Definitions File**.
4. In the **Add New Device** window, in the **Device Class** row, browse to select the correct file.
5. Select **Save**.

### 3.3 Configure Hosts and Devices

After devices are connected to your network and visible in viewLinc (**Sites Manager > Hosts and Devices**), you are ready to configure your devices to work with your viewLinc monitoring system.

Configuration activities you can complete in viewLinc for most devices include:

- Modify device description or add an alias
- Set sample intervals
- Enable or disable channels
- Modify device and channel descriptions
- Designate file storage location for historical data backup
If you were using DL data loggers prior to installing viewLinc 5, you may have set them up on your system with vLog software. You can continue to use vLog or use viewLinc for new configuration activities.

More Information

- Editing Host Properties (page 53)
- Editing Device Properties (page 55)
- Editing Channel Properties (page 57)
- Locking or Unlocking DL Data Loggers (page 216)

### 3.3.1 Viewing Host and Device Properties

In Sites Manager select the Hosts and Devices tab to view device or host properties. Select the top viewLinc folder in the Hosts and Devices tree to include all devices in the Properties grid.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>System Preference in use - description or alias.</td>
</tr>
<tr>
<td>Description in Device</td>
<td>Description preconfigured in device or modified in viewLinc.</td>
</tr>
<tr>
<td>Device Alias</td>
<td>Long description configured in viewLinc.</td>
</tr>
<tr>
<td>Device ID</td>
<td>ID assigned by viewLinc when device was added.</td>
</tr>
<tr>
<td>Device Status</td>
<td>Connection status with viewLinc.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>Serial number associated with the device.</td>
</tr>
<tr>
<td>Probe Serial Number</td>
<td>Displays the serial number of the probe if one is connected to the channel.</td>
</tr>
<tr>
<td>Sample Interval</td>
<td>Interval between samples taken from device.</td>
</tr>
<tr>
<td>Log Capacity</td>
<td>Estimated time remaining for data collection.</td>
</tr>
<tr>
<td>Device Address</td>
<td>Address of device recognized in viewLinc.</td>
</tr>
<tr>
<td>Device IP Address</td>
<td>The IP address of the device.</td>
</tr>
<tr>
<td>MAC Address</td>
<td>MAC address of the channel's device, if available.</td>
</tr>
<tr>
<td>Security Status</td>
<td>Only DL data loggers will display as Not secure. If a DL data logger indicates Tampered.</td>
</tr>
<tr>
<td>Next Calibration Date</td>
<td>Displays next calibration date, if one is set in the device.</td>
</tr>
<tr>
<td>Calibrated By</td>
<td>Company which completed most recent calibration service. 300-series and SP data logger calibration information can only be found on the calibration certificate shipped with the device.</td>
</tr>
<tr>
<td>Properties</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Channels</td>
<td>Number of available channels for the selected device.</td>
</tr>
<tr>
<td>Device Alarming</td>
<td>Indicates whether device alarming is paused.</td>
</tr>
<tr>
<td>Hardware Model</td>
<td>Hardware model information for the channel's device.</td>
</tr>
<tr>
<td>Hardware Revision</td>
<td>Latest hardware revision number for the channel's device.</td>
</tr>
<tr>
<td>Firmware Version</td>
<td>Latest revision number of the firmware in the channel's device.</td>
</tr>
<tr>
<td>Transmit Period</td>
<td>Time between each transmission.</td>
</tr>
<tr>
<td>Battery Level</td>
<td>Estimated battery life remaining.</td>
</tr>
<tr>
<td>RSSI (Signal Strength)</td>
<td>For wireless devices, displays the device signal strength (dBm)</td>
</tr>
<tr>
<td>Signal Quality</td>
<td>For wireless devices, displays current signal quality.</td>
</tr>
<tr>
<td>SNR</td>
<td>Signal to Noise ratio for wireless devices (dB).</td>
</tr>
<tr>
<td>Lock Status</td>
<td>DL data loggers are either locked to viewLinc (Locked) and cannot be modified outside of viewLinc, are locked to vLog or another instance of viewLinc (Remote Lock), or are not yet locked to any software (Unlocked).</td>
</tr>
<tr>
<td>Realtime Only</td>
<td>Yes indicates that the data logger only sends real-time data to viewLinc. It does not store data history.</td>
</tr>
<tr>
<td>Communication Alarm Template</td>
<td>Name of alarm template in use for channel's device.</td>
</tr>
<tr>
<td>Configuration Alarm Template</td>
<td>Name of alarm template in use for channel's device.</td>
</tr>
<tr>
<td>Validation Alarm Template</td>
<td>Name of alarm template in use for channel's device.</td>
</tr>
<tr>
<td>Calibration Alarm Template</td>
<td>Name of alarm template in use for channel's device.</td>
</tr>
<tr>
<td>Channel Index</td>
<td>Index number that the channel has assigned on its device.</td>
</tr>
<tr>
<td>Channel Description</td>
<td>System Preference in use - description or alias.</td>
</tr>
<tr>
<td>Channel Description in Device</td>
<td>Description provided with the device. Refer to the Location name.</td>
</tr>
<tr>
<td>Channel Alias</td>
<td>Displays the alias, if one has been created in viewLinc.</td>
</tr>
<tr>
<td>Channel Alarming</td>
<td>Indicates whether device alarming is paused.</td>
</tr>
<tr>
<td>Channel ID</td>
<td>Unique channel identifier.</td>
</tr>
<tr>
<td>Device Units</td>
<td>Units measured (such as RH, C, mA, mV).</td>
</tr>
<tr>
<td>Editable</td>
<td>Indicates whether the device has properties that can be modified in viewLinc.</td>
</tr>
<tr>
<td>Location</td>
<td>Displays the Location name linked to the channel (if linked).</td>
</tr>
</tbody>
</table>
### Table 15  Host Properties - Columns

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hostname</td>
<td>Displays the host name for the selected device or channel.</td>
</tr>
<tr>
<td>Resolved Name</td>
<td>For administrative purposes.</td>
</tr>
<tr>
<td>Description</td>
<td>System Preference in use - description or alias.</td>
</tr>
<tr>
<td>Status</td>
<td>Connection status with viewLinc.</td>
</tr>
<tr>
<td>Host IP Address</td>
<td>Host IP address.</td>
</tr>
<tr>
<td>Host Type</td>
<td>Indicates whether the selected host is the Vaisala viewLinc machine.</td>
</tr>
<tr>
<td>Number of Devices</td>
<td>The number of devices connected to the host.</td>
</tr>
<tr>
<td>Version</td>
<td>viewLinc version running on the host.</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates whether the host is currently connected to the viewLinc monitoring system.</td>
</tr>
<tr>
<td>viewLinc Aware</td>
<td>Indicates whether the viewLinc Aware Service is enabled on the host.</td>
</tr>
<tr>
<td>Host Alarming</td>
<td>Indicates that host alarms are currently enabled.</td>
</tr>
<tr>
<td>Installation Mode</td>
<td>If host is a VaiNet access point, indicates whether status is enabled or disabled.</td>
</tr>
<tr>
<td>VaiNet Channel</td>
<td>Indicates the channel being used for the VaiNet access point, if applicable.</td>
</tr>
<tr>
<td>Host ID</td>
<td>Unique host identifier.</td>
</tr>
</tbody>
</table>

### 3.3.2 Editing Host Properties

**Manage Devices**

Depending on the type of host you use, various properties can be modified:

- On the viewLinc ES server all properties are editable.
- On an access point host you can modify the description, and enable or disable installation mode when pairing new RFL data loggers.
- On a device host server you can modify the description, and enable or disable automatic recognition of vNet devices (viewLinc Aware).

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. On the **Hosts and Devices** tree, select a host.
3. Select **Configure > Edit Properties.**
4. In the **Edit Host Properties** window, edit available properties for viewLinc Enterprise Server host (go to step 5 for Access Point host properties).

   **Alternate viewLinc server name**
   If the viewLinc ES is behind a firewall, add a server name to ensure that device hosts are recognized, even if the IP address of the viewLinc ES changes.

   **viewLinc Enterprise Server port**
   This is the port that device hosts use when connecting to the viewLinc ES (refer to your IT port policy to determine if it needs to change).

   **viewLinc Aware**
   Disable this function if you have another viewLinc ES or device host running on the same subnet (to ensure vNets connect to the correct viewLinc ES or device host).

   **viewLinc system ID (64-bits)**
   The auto-generated system ID is used by devices to recognize the viewLinc ES. If you need to change this number, contact Vaisala Technical Support for assistance.

5. In the **Edit Host Properties** window, edit available properties for an Access Point host.

   **Description**
   Add a description (up to 64 alpha-numeric characters) to help identify this host. On the **Hosts and Devices** tree the host name appears in addition to the description. For example, *My Host (AP10-X###)*.

   **Installation mode**
   Enable this function to pair new RFL data loggers with the access point.

   **VaiNet channel (1-8)**
   If your viewLinc system supports several access points on the same wireless frequency, each access point requires a unique channel number to ensure uninterrupted wireless communication.

   **AP display**
   Set the panel display on or off.

   **AP display brightness**
   Select the panel display brightness level.

   **AP LED**
   Set the device signal light on or off.

   **AP LED brightness**
   Select the device signal light brightness level.

6. Save your changes.
3.3.3 Editing Device Properties

Manage Devices

You can view and edit device properties, such as the description, alias, timeout seconds, UDP port, password, and data transfer parameters.

Depending on the devices you have installed, you can modify most properties in viewLinc. If you have a DL device already linked to a vLog audit trail, you can either edit the device properties with your vLog software, or first disable the link to the audit trail to modify properties in viewLinc.

**CAUTION!** Editing DL data logger properties automatically clears data history (sample interval, sample warmup time, enable/disable channels, calibration settings). To ensure all device data is up-to-date in viewLinc, view the linked Location trend graph to see the timestamp of the last data transfer.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select the device you want to edit.
4. Edit RFL data logger properties in the Edit Device Properties window:
   - **Device alias**
     Optional. Type a longer, more detailed device description (up to 64 alpha-numeric ASCII characters, less if using UNICODE characters). The alias is displayed in viewLinc and in reports instead of the description, if the option to use aliases is set up in System Preferences.
   - **Device description**
     Type a short device description (up to 16 alpha-numeric characters) to help identify this device. On the Hosts and Devices tree the device description appears in addition to the product-supplied name. For example, *My Device (van10-X###)*.
   - **RFL LED**
     Set the device signal light on or off.
   - **RFL display panel**
     Set the device panel display on or off.
   - **RFL units**
     Display metric or standard units.
5. Edit DL data logger properties in the **Edit Device Properties** window:

**Device alias**
Optional. Type a longer, more detailed device description (up to 64 alpha-numeric ASCII characters, less if using UNICODE characters). The alias is displayed in viewLinc and in reports instead of the description, if the option to use aliases is set up in **System Preferences**.

**Device description**
Type a short device description (up to 16 alpha-numeric characters) to help identify this device. On the **Hosts and Devices** tree the device description appears in addition to the product-supplied name. For example, *My Device (van10-X###)*.

It is recommended that you use the device description field to identify the model and serial number of the device.

**COM Port**
Modify if a new COM Port is required.

**Sample interval**
Select the frequency of data sample collection. Depending on the sample interval selected, the **Log Capacity** field will update the estimated log time available before overwriting historical data on the device (all data history continues to be stored in viewLinc).

**Sample warm up time**
Set the time required to prepare for collection of data (option available if function supported by the data logger).

**Channel [#]**
Allow a channel to start collecting data (Enabled), or prevent a channel from collecting data (Disabled).

6. Edit 300-series data logger properties in the **Edit Device Properties** window:

**Device alias**
Optional. Type a longer, more detailed device description (up to 64 alpha-numeric ASCII characters, less if using UNICODE characters). The alias is displayed in viewLinc and in reports instead of the description, if the option to use aliases is set up in **System Preferences**.

**Timeout (s)**
Specify the number of seconds to wait for data before canceling a transmission.

**IP Address**
If using DHCP, type a new IP address.

**TCP port**
Modify if the selected TCP port number is already in use.

**Sample interval**
Adjust the sample rate depending on how frequently data samples are required from the monitored Location.
7. Edit HMT140 data logger properties in the **Edit Device Properties** window:

**Device alias**
Optional. Type a longer, more detailed device description (up to 64 alpha-numeric ASCII characters, less if using UNICODE characters). The alias is displayed in viewLinc and in reports instead of the description, if the option to use aliases is set up in **System Preferences**.

**Device description**
Type a short device description (up to 16 alpha-numeric characters) to help identify this device. On the **Hosts and Devices** tree the device description appears in addition to the product-supplied name. For example, **My Device (van10-X###)**.

**Timeout (s)**
Specify the number of seconds to wait for data before canceling a transmission.

**UDP port**
Auto-generated, can be modified if required.

**Password**
Type the device password, if this device is password-protected. The password is not saved.

**Max blocks per beacon**
Set the maximum size permitted for historical data retrieval. Entering a lower number helps to conserve battery life.

- **Do not change the Max blocks per beacon value for HMT140 devices without first consulting your technical support department. Changes to this setting may adversely impact battery life.**

**Retry count**
Specify the number of times data transmission is attempted by the device if it fails to receive an acknowledgement.

**Transmit period (min)**
Set the frequency of data transmissions, in minutes.

**Sample interval (min)**
Set the frequency that data samples are saved to the device, in minutes.

8. Save your changes.

**More Information**
- Editing Device or Probe Calibration Properties (page 215)
- Editing Channel Calibration Properties (page 214)

### 3.3.4 Editing Channel Properties

**Manage Devices**
To easily identify a specific channel in viewLinc, you can edit a channel’s description, alias, and preferred temperature units, if applicable.

Depending on the device you use, different properties can be modified in viewLinc. Refer to the specific device user’s guide for more information.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select a device channel to edit.
3. Select Manage > Edit Properties.
4. In the Edit Channel Properties window, modify the fields as required.
   - **Channel alias**
     Optional. Type a longer, more detailed channel description (up to 64 alphanumeric ASCII characters, less if using UNICODE characters). The alias is displayed in viewLinc and in reports instead of the description, if the option to use channel aliases is set up in System Preferences.
   - **Channel description**
     (DL and HMT140 series data loggers) Type a short channel description (up to 16 alpha-numeric characters) to help identify this channel in the Hosts and Devices tree. For example, Temperature.

   Use the channel description to identify what is being measured, such as temperature, humidity, voltage, or pressure, and use the linked Location name to identify what is being monitored, such as a refrigerator reference code or laboratory name.

5. To edit Vaisala DL data loggers with specific channel types:
   - **Voltage or current channel properties:**
     - **First/Second input value**
       To convert data input, set the first and second input range scaling values.
     - **First/Second output value**
       To convert data output, set the first and second output range scaling values.
     - **Output units**
       Specify the type of units to display converted input values in viewLinc.
   - **Boolean channel properties:**
     - **Value when closed**
       Set the value to display in viewLinc.
     - **Output units**
       Editable when the channel is not linked to a Location. Specify the channel units to display in viewLinc.
6. To edit Vaisala HMT140 Series Wi-Fi Data Loggers using probes:

HMP110 probe properties:

Password
If passwords are enabled on an HMT140 device (using the HMT140 Utility software) type the password to ensure changes to HMT140 properties are updated on the device.

Decimal Places
Set the number of decimal places to display on the device.

High/Low Alarm Value
High and low range alarm values that initiate a data transmission. I High/Low Alarm Time: High and low alarm time specifies the number of seconds the probe is in alarm state before transmitting a beacon. The default setting, 255, disables the transmission.

Presentation Scale/Offset
Editable based on channel type. Refer to the Vaisala HMT140 Wi-Fi Data Logger User’s Guide.

Engineering Scale/Offset
Editable based on channel type. Refer to the Vaisala HMT140 Wi-Fi Data Logger User’s Guide.

Calibration Scale/Offset
The primary calibration scaling \( x = \text{Scale} \times V + \text{Offset} \). If the calibration scale or offset are modified, device calibration dates appear. Before you can save the new calibration scale or offset values, update the device calibration settings.

7. Save your changes.

More Information

- Editing Device or Probe Calibration Properties (page 215)
- Editing Channel Calibration Properties (page 214)
4. Sites Management

The areas you monitor with devices are identified in viewLinc as Locations, and several Locations can be organized into Zones. Members of the Administrators group or other groups assigned the right, Manage Sites, can create and modify Zones and Locations in the Sites Manager window.

Locations are created independent of the device being used to collect data to ensure that each Location retains its assigned threshold and permission settings no matter which device is used being used to monitor conditions. If you swap a device out for calibration, or pause device alarming during a maintenance cycle, the Location retains the assigned threshold and permission settings.

4.1 Zones and Locations

When creating new Zones, first think about the areas you want to monitor (your buildings, floors, storage rooms, testing labs), then identify all the specific Locations within those areas where your devices are installed and channels record data (cabinets, refrigerators, storage racks).

For organizations with several devices installed, Zones help you identify the areas where data is collected from multiple devices or device channels. You can also create sub-zones if you monitor several areas at multiple sites.

By identifying Locations in Zones you can also:

- Swap a device easily from one Zone to another (perhaps when sending a data logger out for calibration).
• Ensure that reporting is consistent for a specific Zone, regardless of the data logger used to monitor that Location.

A fully configured viewLinc desktop provides you with an online representation of your monitored areas.

4.2 Create Zones and Locations

**Sites Manager** is where you set up the areas you monitor as Locations, organize them into Zones, link Locations to device channels, apply threshold alarm templates, set group access permissions, and assign schedules.

viewLinc provides you with one top-level Zone automatically, viewLinc. It can be renamed at any time, perhaps with your company name, or the name of one of the buildings you monitor. Additional Zones and sub-zones can be set up to help identify monitored floors, rooms, warehouses, cooling or warming facilities). You can easily create Locations from device channels and add them to Zones.

For a demonstration of how to create a Zone or a Location, tours are available on the Help menu.

For more information about connecting devices and enabling or disabling channels, refer to your device-specific user’s guides.

### 4.2.1 Creating Zones

**Manage Sites**

Create Zones to help organize groups of Locations.

1. In **Sites Manager** on the **Zones and Locations** tree, select the top-level folder. You can also select an existing Zone to create a sub-zone.

2. Select **Manage > Create Zone**, or right-click a Zone folder and select **Create Zone**.

3. On the **Create Zone** window, type a unique name for the Zone, then specify:
   - **Dashboard icon**
     Select an icon you want used to represent the type of Zone when displaying on the dashboard.
   - **Description**
     For additional clarification, you can type a description of this Zone (optional).

4. Select **Create**.

5. Select **Save**, or **Undo** to cancel.

If a Zone was added to an incorrect tree position, you can use your mouse to drag it to a new tree position.
4.2.2 Creating Locations

Create Locations to monitor device data in viewLinc. After Locations are created, link Locations to device channels. You require Manage Devices right to link Locations to your device channels.

Use your mouse to drag a device channel from the Hosts and Devices tree to a Zone, automatically creating a new linked Location.

1. In Sites Manager navigate the Zones and Locations tree to select a Zone or Location.
2. Select Manage > Create Location, or right-click a Zone folder and select Create Location.
3. On the Create Location window, type a name for the Location. Use the Location name to describe the area being monitored. If a device is swapped out or re-located, the Location description is retained.
4. Add Location properties:
   - **Measurement type**: Select the value being measured. If the type is Temperature, select the preferred temperature unit to display in browser windows (°C or °F, or the system default, set in the System Preferences window).
   - **Decimal places**: Specify the number of decimal places to display.
   - **Description**: For additional clarification, you can type a description of this Location (optional).
5. Select Create.
6. Select Save, or Undo to cancel.

To enable data reporting and alarm monitoring in viewLinc, link this Location to a device channel.

More Information
- Creating Linked Locations Automatically (page 64)

4.3 Link Device Channels to Locations

Link device channels to Locations to monitor recorded device data in viewLinc. Linking a device channel to a Location also allows you to maintain consistent data and alarm history for a monitored area, even if the devices used for monitoring change (a device may be swapped out to monitor another area, or sent for calibration or repair).
Only device channels linked to Locations can generate alarms.

- Workstation 1
  - Humidity: linked
  - Temperature: unlinked

When data monitoring for a specific area is no longer required, you can easily unlink a device channel and link it to a different Location.

For audit trail security, you cannot delete a Location that was linked to a device channel; however, unused Locations can be unlinked and hidden from view.

More Information
- Unlinking or Relinking Locations and Channels (page 199)
- Deactivating Locations (page 203)

4.3.1 Linking Channels to Locations

Manage Sites

Before you can start monitoring conditions with viewLinc, device channels must be linked to viewLinc Locations.

- Full Control permission is required for all Locations being linked.

1. In Sites Manager on the Zones and Locations tree, select an unlinked Location (displayed in italicized text).
2. Select the Hosts and Devices tab.
3. In the Hosts and Devices tree, select an unlinked channel (displayed in italicized text) with a matching measurement type.
4. Select Configure > Link Channel
5. In the **Link Channel to Location** window, choose when you want this new Location to start monitoring data.
   - **Start now**
     Data is recorded starting from the next available sample time.
   - **Start from earliest available link time**
     Include all channel data history recorded by the device. This option is useful if the channel has been in use but unlinked for a period of time.
   - **Start from a specified time**
     Set a specific time to start recording data history. You may want to use this option to delay the start of recorded history.

6. Select **Link**.
7. Select **Save**.

### 4.3.2 Creating Linked Locations Automatically

**Manage Sites**

Use the drag and drop feature to create new Locations that are automatically linked to device channels.

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. In the **Hosts and Devices** tree, select the new device.
3. Select an unlinked device channel, then drag it over to the Zone where the new Location will be created. The icon changes to + when the position is valid.

4. In the **Link Channel to Location** window, choose when you want this new Location to start monitoring data:
   - **Start now**
     Data is recorded starting from the next available sample time.
   - **Start from earliest available link time**
     Include all channel data history recorded by the device. This option is useful if the channel has been in use but unlinked for a period of time.
   - **Start from a specified time**
     Set a specific time to start recording data history. You may want to use this option when you want to delay the start of recorded history.

5. Select **Link**.

6. To define a unique Location name, select the new Location and right-click to select **Edit Properties**.

7. Select **Update**, then select **Save**.

### 4.3.3 Viewing Channel Link History

**Manage Devices**

You must have **View** permission to see specific **Zones and Locations** in **Sites Manager**.

1. In **Sites Manager**, navigate the **Zones and Locations** tree to select a linked Location.
2. On the **Location Properties** tab select the Location on the grid.
3. Select the channel history tool bar button, 🔄.
4. Review historical details the **Linked Channel History** window:

**Link Start**
- Unlimited indicates this channel has remained linked and has continuously monitored data at the linked Location since the channel started monitoring data.

**Link End**
- Unlimited indicates this channel is still linked to the Location and is monitoring data continuously.

More Information

- Applying Group Permission to Zones (page 126)

### 4.3.4 Finding a Channel’s Linked Location (Sites Manager)

**Manage Sites**

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. Navigate to a channel in the **Hosts and Devices** tree.
3. Select **Configure > Find Linked Location** or right-click and select **Find Linked Location**. A yellow highlight bar appears temporarily in the Zones and Locations tree to indicate the linked Location.

![Sites Manager](image)

### 4.3.5 Finding a Location’s Linked Channel (Sites Manager)

**Manage Sites**

If you have a large installation with many devices and channels, try viewLinc’s Find in Tree feature. You require **View** permission for all linked Locations.

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. Navigate to a Location in the **Zones and Locations** tree.

3. Select **Configure** or right-click and select **Find Linked Channel**. A yellow highlight bar appears temporarily in the **Hosts and Devices** tree to indicate the linked channel.

### 4.3.6 Finding a Location’s Linked Channel (Sites)

1. In **Sites** navigate to a Zone in the **Zones and Locations** tree.

2. On the **Status** tab select a Location.

3. Select the **Find in Tree** toolbar button, or right-click on the Location and select **Find in Tree**. A yellow highlight bar appears temporarily in the Zones and Locations tree to indicate the corresponding Location.

### 4.4 Build Dashboards

Create a dashboard to help your team become familiar with the physical location of data points (viewLinc Locations). A dashboard can be a facility map, a drawing, photo, or other image file (.png or .jpg) representing a specific area.

![Dashboard Image](image.png)

After you add an image, select and place sub-zones or individual Locations on the dashboard. You can create dashboards to display Location data without a background image, for larger, more remote screen displays.
After you add an image, select and place sub-zones or individual Locations on the dashboard. You can create dashboards to display Location data without a background image, for larger, more remote screen displays.

4.4.1 Building Dashboards

Manage Sites

Upload a dashboard image file from any desktop or network location, in .png or .jpg format.

You can add a dashboard image to a Zone or a Location, or to a view (a view you created or are permitted to edit).

You require Full Control permission to add a Zone or Location dashboard image, or to add dashboard images to views created by others.

4.4.1.1 Adding Dashboard Image

Manage Sites or Manage Views

1. In Sites Manager on the Zones and Locations tree, select a Zone or a Location (or in Views Manager on the Views tree, select a view).
2. Select the Dashboard tab, then select Add Dashboard Image.
3. Browse to find an image, then select Add. The image automatically resizes to fit the screen. If it is necessary to resize the image, adjust the borders with your mouse, starting from the bottom right corner.
4. Select Save.

4.4.1.2 Adding Zones and/or Location Data Points

Manage Sites or Manage Views

Only sub-zones and child Locations of a Zone can be added as data points on the dashboard image.

1. In Sites Manager on the Zones and Locations tree, or in Views Manager on the Views tree, select a Zone or Location you want to display on the dashboard.
2. Click and drag the Zone or Location to the dashboard. When you drag the Zone or Location, an icon appears to indicate when it can be added to the dashboard.

- When a sub-zone is added to the dashboard, it displays with its assigned dashboard icon, or, if one was not assigned, the default folder icon. Double-click the icon to view Location data.
- When a Location is added to the dashboard, it displays the current numeric data reading, with the icon color indicating current condition severity (as set in the threshold alarm template).

3. Select **Save**.

### 4.4.2 Changing Dashboard Display Settings

**Manage Sites** or **Manage Views**

Modify the contents of the dashboard and the appearance of Zone and Location data points.

You require **Full Control** permission to modify the dashboard display for a selected Zone, Location, or view.

#### 4.4.2.1 Changing Dashboard Image

**Manage Sites** or **Manage Views**

Changing the dashboard image does not delete your data points (but you may need to adjust their position on the new image).

1. In **Sites Manager** on the **Zones and Locations** tree, select the Zone or Location you want to modify (or in **Views Manager** select a view).
2. Select the **Dashboard** tab, then select **Add Dashboard Image**.
3. Type the file location or use the **Browse...** button to navigate to the image you wish to use, then select **Add**.
4. Save your changes.

#### 4.4.2.2 Changing Font Size for All Zones

**Manage Sites** or **Manage Views**

You may want to apply the same settings to all Zones on a dashboard, or modify settings for specific Locations that are important to you.

Change the font size for all Zones on the selected dashboard:

1. In **Sites Manager** on the **Zones and Locations** tree, select a Zone.
2. On the **Dashboard** tab, select **Settings > Dashboard Zone Settings**.
3. In the **Dashboard Zone Settings** window, select the font size in the **Value** column.
4. Save your changes.
4.4.2.3 Changing Font Size for Individual Zones

**Manage Sites** or **Manage Views**

1. In **Sites Manager** on the **Dashboard** tab, right-click on a Zone and select **Edit Display Settings**.
2. In the **Edit Zone Display Settings** window, choose a font size from the drop-down list, or select **Set to Default** to change it to use dashboard preferences.
3. Save your changes.

4.4.2.4 Changing Preferences for All Locations

You may want to apply the same settings to all Locations on a dashboard, or modify settings for specific Locations that are important to you.

To set Location preferences for all Locations on the selected dashboard:

1. In **Sites Manager** on the **Zones and Locations** tree, select a Zone with Locations set on a dashboard.
2. On the **Dashboard** tab, select the **Settings > Dashboard Location Settings**.
3. In the **Dashboard Location Settings** window, select a property to modify. Select a row in the **Value** column to see available options.
4. Save your changes.

4.4.2.5 Changing Preferences for Individual Location

To set Location preferences for an individual Dashboard Location:

1. In **Sites Manager** on the **Dashboard** tab, right-click on a Location to modify, and select **Edit Display Preferences**.
2. In the **Edit Location Display Preferences** window, select a property to modify. Select a row in the **Value** column to see available options.
3. Save your changes.

4.4.2.6 Changing Description Display Options for All Locations

To set Location description display options for all Locations on the dashboard:

1. In **Sites Manager** on the **Dashboard** tab, select **Settings > Dashboard Location Settings**.
2. In the **Dashboard Location Settings** window, modify the description display options:
   - **Description**
     Choose to display the Location description (as specified in Location Properties) above, below, or beside the data reading.
   - **Description format**
     **Description format**
3. Save your changes
4.4.2.7 Changing Description Display Options for Individual Location

To set Location Description display options for an individual Location on the dashboard:

1. In Sites Manager on the Dashboard tab, right-click on a Location to modify, and select Edit Display Settings.
2. In the Edit Location Display Settings window, modify the description display options
   - Description
     Choose to display the Location description (as specified in Location Properties) above, below, or beside the data reading.
   - Description format
     Display only the Location description or Location and Zone descriptions.
   - Set to Default
     Select to accept all globally-set dashboard preferences.
3. Save your changes.

4.4.2.8 Setting up Dashboard for Wall-mounted Monitors

1. In Sites Manager on the Dashboard tab, select Settings.
2. Choose to display Location data in 1-, 2-, 3-, or 4-columns of tiles. A greater number of Locations may require a greater number of columns. Test each option to determine which display option suits your needs most effectively.

   When a column tiling option is selected, the uploaded dashboard image fades into the background.

3. Save your changes.

4.4.3 Deleting Dashboard Images or Data Points

Manage Sites or Manage Views

You can keep dashboards up-to-date with changes to the number of facilities monitored or the addition of more monitored areas. Any user can modify the dashboard images they add in Views Manager, or for the views they are permitted to edit.

Users belonging to groups with Manage Sites right and Full Control permission can modify dashboards in Sites Manager. Users belonging to groups with Manage Views right and Full Control permission can modify dashboards in Views Manager.

4.4.3.1 Deleting Single Dashboard Data Point

1. In Sites Manager on the Zones and Locations tree (or in Views Manager on the Views tree), select the Zone or Location dashboard you want to modify.
2. On the **Dashboard** tab, right-click a dashboard data point then select **Delete**.
3. At the prompt, select **Delete**.
4. Save the change, or select **Undo** to cancel.

### 4.4.3.2 Deleting Dashboard Image and/or All Dashboard Data Points

1. In **Sites Manager** on the **Zones and Locations** tree (or in **Views Manager** on the **Views** tree), select the dashboard you want to delete.
2. On the **Dashboard** tab select **Clear Dashboard**.
3. Choose to delete either the Zones and Locations or the dashboard image, or both, then select **Clear**.
4. Save the change, or select **Undo** to cancel.
5. Groups and Users

All viewLinc users must be assigned to one or more groups. Each group is assigned rights that define the viewLinc windows the users in the group can access.

Users can belong to more than one group. To help get you started, there are two default groups available:

- Administrators: A user added to the viewLinc Administrators group has all rights assigned. They can access all windows and perform any function within viewLinc.
- Everyone: All new users are automatically assigned to the Everyone group. This group has access to the Overview, Sites, Reports, Alarms, Views Manager, and Events windows. The Zones and Locations users are permitted to view and/or modify within a window are set with permission levels.

Members of the Administrators group are automatically granted Full Control permission to all Zones and Locations. They can also perform system-level changes, such as restart viewLinc Enterprise Server or a device host, acknowledge system alarms, acknowledge all inactive alarms, permanently delete Zones or Locations, and fix the validation status or remote lock on DL data loggers.

To learn more watch these tours: Rights and Permissions, Add a Group, and Add a User, available on the Help menu.
5.1 Rights

Rights are assigned to groups, and give all users in a group access to functional areas in viewLinc. Groups can be given one or more rights, and users can be members of one or more groups. By default all new users are automatically assigned to the Everyone group with the right, Manage Events.

Users created in an earlier version of viewLinc retain any rights that were assigned in the earlier version. To manage access to different functional areas of viewLinc more effectively, remove legacy user rights and assign the user to a group with the same rights.

Once removed, legacy user rights cannot be reapplied.

Users assigned to the viewLinc Administrators group are automatically granted these additional system-level functions:

- Undo remote-lock on DL data loggers
- Restart viewLinc
- Test network communications
- Acknowledge all inactive alarms
- Acknowledge system alarms
- Correct security status
- Pause host alarms
- Add users to the Administrators group
- Edit user profiles of Administrators group members

<table>
<thead>
<tr>
<th>Table 16 Rights Definitions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>------------------------------</td>
</tr>
<tr>
<td>Manage Alarm Templates</td>
</tr>
<tr>
<td>Manage Devices</td>
</tr>
</tbody>
</table>
### Group Rights

Group rights are refined by permissions. While rights allow groups to complete specific tasks in viewLinc windows, permissions control the Zones and/or Locations a group can view, configure or manage.

### More Information

- Permissions (page 124)

## 5.2 Adding Groups

### Manage System

Assigning users to groups helps define which areas of viewLinc you want specific users to access.

1. In the **Users and Groups** window, select the **Groups** tab, then select **Add**.
2. In the **Add Group** window on the **Properties** tab, type a name for the group. You can use the **Description** field to describe the rights you will assign to the group, or the primary job function of the group.
3. Select the Rights tab, then select the rights you want to assign to the group

If you are creating a group for use with Vaisala OPC UA Server, no rights are required. The group does require View permission to access data in Zones and/or Locations.

4. To add users to this group, select the Members tab then select users to add the group.

5. Select Save.

5.3 Adding Users

Manage System

Before you add users to your system, determine which rights the user will need. Users are given rights through the group or groups to which they are assigned.

Only members of the Administrators group can add new users to the Administrators group.

1. In the Users and Groups window select the Users tab.

2. To avoid adding a duplicate user account, check that the user does not already exist
   a. In the Search field, type the username or full name, then select the search icon.
   b. Select the × to clear the field and display the full list of users.

3. Select Add.

4. On the Properties tab, add user details:
   User name and Full name
   Type a username to use on the login page, and a full name, for internal reference (your company may use abbreviated names for login credentials). If this user will log in with Windows authentication, type their Windows username then select Windows as the Authentication method.

   Email, Mobile number
   Add the user’s contact details to receive reports and alarm notifications, and send alarm acknowledgements. Type a mobile number which includes the ‘+’ sign, the country code and area code. For example, +44 604 273 6850 (dashes, spaces or periods can be included, but are not required).
5. If schedules functionality is enabled, choose a schedule from the **Send alarm notifications** field to define when to send alarm notifications to this user:

   **Always**
   - This user will receive notifications at any time of day or night.

   **According to schedule**
   - If this user is a member of a group set up to receive alarm notifications, select the schedule which defines when this user should receive notifications.

   **Never**
   - This user will not receive alarm notifications, even if they are assigned to a group set up to receive alarm notifications.

6. Specify notification details:

   **viewLinc PIN**
   - Enter a unique 4 to 5 digit number between 1000 and 99999. This number is required when the user acknowledges an email or SMS alarm notification on their mobile device.

   **Preferred language**
   - Choose the language to use when user generates a report or viewLinc sends this user reports and alarm notifications. If no language selected, the system default language is used. Users can select any language.

     The language selected when logging in to viewLinc applies to the viewLinc display only.

   **Audible alarm notification**
   - Choose to enable audible alarms on the user's device (desktop PC) when logged in to viewLinc. Audible alarms must be enabled in **System Preferences**.

     Only the most recently generated alarm initiates a sound. The user can turn off an audible alarm in the main viewLinc window by clicking the audible alarm icon 🔊.
7. Choose the method of Authentication:
   - **viewLinc**
     Select this option to add a unique viewLinc password, then type a password in the Password and Confirm new password fields.
   - **Windows**
     Select this option to allow user to log into viewLinc with their current Windows password. Check that the Windows user name is added in the User name field (see the previous step), and then specify the Domain.

![Tip](image)
You can require that users re-confirm their identity (re-enter their username and password) whenever a change is made in viewLinc, or after a set number of minutes.

8. On the Groups tab, assign the user to a group. In the Selected column check all the groups you want the user to belong to. Review the Rights column to ensure you are giving this user the rights they need.

![Note](image)
If you are creating a dedicated user for Vaisala OPC UA Server, add this user to the dedicated Vaisala OPC UA Server group.

9. Select Save.

More Information
- Enabling or Disabling Audible Alarms (page 110)
- Setting Authentication Requirement (page 114)
6. Alarm Templates

Alarm templates are used to define the alarm condition and notification requirements for Locations and devices.

Create **threshold alarm templates** to specify the conditions that should trigger an alarm, then apply the template to one or more Locations.

Default **device alarm templates** are provided and assigned to each new device connected to your viewLinc system. They specify how and when you want to be notified of device status. The default templates can be modified, or you can create new device alarm templates.

Create **alarm notification templates** to define who should be notified in the event of a threshold or device alarm, the information that should be distributed in email, SMS, or voice messages, or whether to initiate a command to activate visual or auditory alarms, and whether the notified individual must acknowledge an alarm. Alarm notification templates are applied to Locations using threshold alarm templates.

Default **email, SMS and voice templates** are provided. They contain standard information issued from viewLinc about different alarm conditions in your network. The default content can be modified. Note that SMS functionality requires a supported modem, and voice/SMS services via web require a Twilio account.

(Optional) Create **schedules** to define when Location thresholds should be monitored, and when you want alarm notifications sent. You can set up a day schedule and an evening schedule to send notifications to different teams, or set schedules to prevent users on holiday from receiving alarms. Schedules functionality must be enabled.

Alarm templates can be added/modified by users assigned to groups with **Manage Alarm Templates** right.

More Information

- Setting Up Voice or SMS Web Services (page 139)
- Enabling or Disabling Schedules (page 110)
- Setting System Alarm Preferences (page 121)

6.1 Types of Alarms

Alarms indicate issues that may require immediate resolution, provide notification about interruptions in communication between devices or hosts and the viewLinc Enterprise Server, updates about system status or configuration changes, and reminders about upcoming maintenance requirements.
Alarms are viewable in the **Alarms** window (device and system alarms and threshold alarms for Locations you have permission to view), the **Sites** window (device and threshold alarms for the Locations you have permission to view), or in the **Overview** window (device and threshold alarms for the Locations assigned to your views).

All alarm events are recorded in the event log, to ensure a secure audit trail.

<table>
<thead>
<tr>
<th>Alarm Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System</strong></td>
<td>Event log validation alarms indicate whether changes have been made to the event log from outside the viewLinc system.</td>
</tr>
<tr>
<td></td>
<td>Database validation alarms indicate database corruption or configuration changes made to the historical database originating outside viewLinc.</td>
</tr>
<tr>
<td></td>
<td>System alarm settings are configured in <strong>System Preferences</strong>.</td>
</tr>
<tr>
<td><strong>Threshold</strong></td>
<td>Threshold alarms indicate excessive condition changes in a monitored environment.</td>
</tr>
<tr>
<td></td>
<td>Threshold alarm settings are defined in threshold alarm templates and are then applied to Locations.</td>
</tr>
<tr>
<td><strong>Device</strong></td>
<td>Device configuration alarms indicate interruptions collecting device data.</td>
</tr>
<tr>
<td></td>
<td>Host configuration alarms indicate synchronization errors between a device host or access point and the viewLinc Enterprise Server.</td>
</tr>
<tr>
<td></td>
<td>Device validation alarms indicate corruption in the device memory.</td>
</tr>
<tr>
<td></td>
<td>Device calibration alarms indicate upcoming calibration service requirements.</td>
</tr>
<tr>
<td></td>
<td>Host communication alarms occur when a device host or access point loses connection with the viewLinc Enterprise Server.</td>
</tr>
<tr>
<td></td>
<td>Device communication alarms indicate a communication error between a host computer, access point or viewLinc Enterprise Server, and its connected devices.</td>
</tr>
<tr>
<td></td>
<td>Device alarm settings are defined in templates.</td>
</tr>
</tbody>
</table>

### 6.2 System Alarms

System alarms occur automatically when viewLinc detects changes made outside standard desktop operation. It is issued to warn of possible database tampering.

If you receive a system alarm notification (email or SMS), investigate possible causes, acknowledge the alarm notification, and, if required, follow your company’s standard operating procedures (SOPs) to resolve the issue.
Critical system errors and warnings are automatically sent to the IT Network manager, and you have the option of sending additional email or SMS system alarm notifications to members of the default Administrators group.

You can modify the content of system alarm email and SMS messages.

Types of System Alarms

- Database Validation: This alarm indicates device tampering such as a change to the configuration database, data modifications (a possible external script), or data corruption.
- Event Log Validation: This alarm indicates database security interruptions, such as a change made to the event log from outside the viewLinc system.

More Information

- Setting System Alarm Preferences (page 121)

6.3 Threshold Alarms

Thresholds define the accepted condition limits required to preserve the quality of your inventory or production environment. Threshold condition limits are saved as threshold alarm templates, and can be applied to one or more Locations. If condition limits are exceeded, viewLinc can activate an alarm, and, optionally, send one or more alarm notifications.

Threshold alarm templates define:

- Values associated with one or more conditions (Low-Low, Low, High, High-High, RoC, Alarm off margin).
- Color codes to reflect condition severity.
- One or more threshold alarm activation delays.
- Whether the alarm needs to be acknowledged.

You can apply one or more threshold templates to a Location, depending on how often you need to change threshold values, or how frequently you want to know about changing conditions.

You can also specify the alarm off margin so viewLinc will ignore condition changes within a specified temperature range and persist sending alarm notifications while conditions remain in this range.

Up to 5 threshold settings can be saved as a single template and then assigned to one or more Locations. If the settings are modified, the new settings apply to all Locations to which they have been assigned.

Example

If you have a monitored area that should remain between 10°C and 12°C, you could set up one or all of these levels:

- Low threshold set at 10.5 °C to warn when the temperature is close to the Low-Low threshold.
• Low-Low threshold set at 10 °C lasting for more than 1 minute to trigger specific alarm settings for the breach of the lower threshold.
• High threshold set at 11.5 °C to warn when the temperature is close to the High-High threshold.
• High-High threshold set at 12 °C lasting for more than 5 minutes to trigger specific alarm settings when upper threshold exceeded.
• Rate of Change set to 0.25 °C/min to warn when temperature increases or decreases rapidly.

More Information

• Creating Threshold Alarm Templates (page 82)
• Alarm Notifications (page 96)

6.3.1 Creating Threshold Alarm Templates

Manage Alarm Templates

Threshold settings (high and low condition limits) are stored in reusable templates which can be applied to one or more Locations. These threshold settings define the conditions that you want to trigger alarms at a specific Location.

1. In the Alarm Templates window select the Threshold Alarms tab.
2. Select **Add > Add Threshold Alarm Template**. To copy settings from an existing template, select the template, then **Add > Copy Selected Threshold Alarm Template**.

3. In the **Add Threshold Alarm Template** window, add a unique name for the new template and then set the template details:

   **Measurement type**
   Select the type of measurement monitored at selected Location(s).

   **Unit**
   Choose the units you want used to record the measurement type.

   **Alarm off margin**
   Specify an active alarm range. If an alarm condition fluctuates within the active alarm range, the alarm does not turn off. For example, if the high threshold is 10 °C, and the alarm off margin is 1 °C, the alarm will not turn off until the temperature falls to or below 9 °C.

   **Permissions**
   Select the groups authorized to modify or apply this template to Locations.

   **Description**
   (optional) Provide more details about the threshold template settings.
4. Enable one or more threshold levels:
   - **Select**
     Select the threshold levels you want to activate.
   - **Level**
     Five threshold levels are available, but you only set values for the levels that are selected.
   - **Threshold**
     Set a numerical value manually or with the up/down arrows.
   - **Priority**
     Set the response priority for the threshold value. Priority value provides users a visual clue about the severity of conditions in the Alarms window.
   - **Report Category**
     This setting defines whether alarms triggered by the threshold level appear on reports as Alarms or Warnings. You can set report options to include or exclude these categories, depending on your reporting requirements.
   - **Alarm Delay**
     Set a delay if you want to prevent a threshold alarm from triggering immediately after threshold is exceeded. You may want to set a delay if you want an alarm triggered only if the condition persists beyond a delay period.

5. Select **Save**.

### 6.3.2 Applying Threshold Alarm Templates to Locations

**Manage Alarm Templates**

After creating threshold alarm templates, you can apply the templates to Zones or to specific Locations. You can apply and enable up to six threshold alarm templates on one Location, to accommodate different monitoring needs at different times.

To apply a threshold alarm template to a Location, you require **Configure Alarms** permission or higher for the selected Location.

1. In **Sites Manager** on the **Zones and Locations** tree, select a Zone or a Location (hold the **CTRL** key to select multiple Zones/Locations).

Threshold alarm levels are ignored if they fall outside the Location's linked device measurement range.
2. Select **Manage > Add Threshold Alarms**. Complete the fields in the **Add Threshold Alarm** window:

**Location**
Verify that you are adding a threshold alarm template to the correct Location(s). If you selected a Zone, the threshold alarm template is applied to all Locations in the Zone.

**Status**
Set status to **Enabled** to actively monitor thresholds on selected Location(s). If you do not want the threshold alarm settings activated on this Location until a later time (you may have more configuring to do), set as **Disabled**.

**Send to device**
Choose whether to send threshold level information to an RFL100-series or HMT140-series data logger. Select the threshold levels to display using the checkboxes in the **Alarm on Device** column. Only two levels can display on an HMT140 device (1 high and 1 low).

**Device password**
If the selected Location is linked to an HMT140 device with password functionality enabled, type the password to apply threshold settings.

**Measurement type**
Select the type of conditions being measured at this Location.

**Threshold alarm template**
Select an available threshold alarm template. The threshold template details appear in the grid.

3. For each alarm level, update threshold alarm settings:

**Alarm on Device**
For RFL100 and HMT140 series data loggers. Choose which threshold level(s) to display (an HMT140 can accept 2 levels, one high and one low; RFL can accept 4 levels). For areas with several devices, you may want to display only the most critical threshold levels. If the device is moved, threshold levels remain enabled on the device.

The **Send to device** option must be enabled to allow threshold levels to alarm on a device.

**Alarm Notification Template**
Select an alarm notification template to use if this threshold is exceeded. Alarm notification templates define who is notified and when.

**Message or Comment**
All threshold alarm notifications use content specified in viewLinc's default notification content templates. Use this field to insert custom text in place of the [AlarmMessage] and [Comment] macros embedded in the content templates. For example, you may want to add a description of an action required to resolve a common issue, "This pump tends to cause this alarm, make sure to reset it before acknowledging."
4. Select **Save**.

To copy a threshold template to other Locations using the same measurement type:

1. On the **Threshold Alarm Settings** tab, select a threshold.
2. Select **Copy selected threshold alarm settings**.
3. On the **Zones and Locations** tree, select a Zone or Location.
4. On the **Threshold Alarm Settings** tab, select **Paste to the selected Zone or Location**.

**More Information**

- Alarm Notifications (page 96)
- Notification Content (page 104)

### 6.3.3 Editing Threshold Alarm Templates

**Manage Alarm Templates**

Adjust threshold levels for all Locations using the same threshold alarm template.

#### CAUTION!

Changes to a threshold alarm template affect all Locations using the template.

1. In **Alarm Templates** select the **Threshold Alarms** tab.
2. Select the template you want to modify, then select **Edit**.
3. Select **View Locations** to verify that changes can be applied to all Locations currently using the template.
4. Modify the editable settings.
5. Select **Save**.

### 6.3.4 Editing Location Threshold Alarm Settings

**Manage Alarm Templates**

Modify threshold alarming status, threshold alarm template or alarm notification template used for individual or multiple Locations.

To modify threshold alarm settings you require **Configure Alarms** permission or higher for the selected Location(s).
1. In Sites Manager in the Zones and Locations tree, select the Zone or Location you want to modify (CTRL+click to select multiple Zones and Locations).

2. Select the Threshold Alarm Settings tab, and then select one or more threshold alarm rows.


   **CAUTION!** If modifying settings for multiple Locations with different settings applied, indicated with the icon, 🕵️, it is recommended that you leave mixed settings unchanged.

4. Select Save.

### 6.3.5 Deactivating Threshold Alarms

**Manage Alarm Templates**

Threshold alarm settings cannot be deleted, but they can be deactivated. Once deactivated, the threshold alarm settings row is hidden from view. Deactivated threshold alarm settings can be reactivated on the Location at any time.

To prevent a Location from using applied threshold alarm settings temporarily (useful if you need to store more than six threshold alarm settings with a Location), simply disable a threshold alarm setting.

1. In Sites Manager select a Location in the Zones and Locations tree.
2. On the Threshold Alarm Settings tab, select the threshold you want to deactivate.
3. Select Deactivate.
4. At the prompt, select Deactivate

   To view a deactivated threshold, select View > Include Deactivated Threshold Settings.

**More Information**

- [Enabling or Disabling Threshold Alarm Settings](#) (page 205)

### 6.3.6 Reactivating Threshold Alarms

**Manage Alarm Templates**

You can reactivate a deactivated threshold alarm settings on the Location at any time.

1. In Sites Manager select a Location in the Zones and Locations tree.
2. On the **Threshold Alarm Settings** tab select **View > Include Deactivated Threshold Settings**.

3. From the list of threshold alarm templates that appear, highlight the threshold you want to reactivate, then select **Activate**.

4. At the prompt, select **Activate**.

### 6.4 Device Alarms

Communication between devices and the viewLinc Enterprise Server is essential for continuous monitoring of conditions. To ensure you are notified of any issues that require attention, configure the default host and device alarm templates according to your company’s notification requirements.

In **Sites Manager**, the **Device Alarms** tab displays a list of the device alarm templates applied to your devices. You can modify the default device alarm templates, or create new device alarm templates in the **Alarm Templates** window.

#### 6.4.1 Types of Device Alarms

Four (4) device alarm templates are automatically applied to each monitoring device connected to the viewLinc Enterprise Server (data loggers and transmitters). Two alarm templates are applied to hosts (Device Host computers and access points).

Device alarm templates contain default (and modifiable) settings which define:

- Alarm priority
- Alarm notification delay
- Acknowledgement requirements
- Group authorized to modify device alarm settings

The default device alarm templates assigned to devices can be modified. You can also create new device alarm templates with unique settings for specific Locations.

- ![Device Calibration Reminder](image)
- ![Device Communication Alarm](image)
- ![Device Configuration Alarm](image)
- ![Device Validation Alarm](image)

### Device or Host Communication Alarms

Device communication alarms occur when communication is interrupted between a host computer, access point or viewLinc Enterprise Server, and its connected devices.

Host Communication Alarms occur when a device host or access point loses its connection to the viewLinc Enterprise Server. Communication alarms are like a system health test, alerting you if there is a problem that might disrupt viewLinc monitoring and alarming.

By default, there is one communication alarm template preconfigured for each host and each device. Communication alarm templates control:
• How alarm notification displays
• Who is notified
• When alarm notification is initiated
• Whether alarm acknowledgement is required

If a device host computer or access point host goes offline, only a host communication alarm is generated. Connected devices do not generate device communication alarms.

Device or Host Configuration Alarms

If you receive a device configuration alarm, this indicates that your device is configured incorrectly or has stopped recording data history. Host configuration alarms are triggered when there is a synchronization error between a host and its connected devices.

Here are a few examples:

• An internal device error is preventing data history from recording.
• viewLinc detects a device's stop mode is not set to Wrap when full (DL data loggers).
• viewLinc cannot retrieve historical samples because a device is configured with a delayed data recording start (DL data loggers).
• viewLinc detects a device that is locked to another system.
• A device may have a disabled channel that is linked to Location.
• IR sensor sending too many transmissions which may drain battery.

The default delay before viewLinc sends a device configuration alarm notification is 60 seconds. You can adjust the notification delay and other device configuration settings in viewLinc.

Device Validation Alarms

If the validation memory in a device is corrupted or has been modified, this alarm notification will advise that you contact your Vaisala technical support representative for assistance.

Device Calibration Alarms

A device calibration alarm is an intermittent notification sent when a Vaisala data logger or probe is due for calibration.

By default, you receive notifications at the following intervals: 3 months and 1 month before the calibration due date, then again on the scheduled recalibration date (auto-generated for 1 year from last calibration date). This alarm remains active, even after acknowledgement, until the device is recalibrated (for more information contact Vaisala Calibration Service Center).

You can set the default calibration duration for all data loggers in System Preferences, or, if you have Manage Devices right, modify the calibration duration for a specific data logger or probe in Sites Manager.
6.4.2 Editing Host Communication Alarm Settings

Manage Alarm Templates

By default, viewLinc assigns a host communication alarm template to all new hosts added to the viewLinc monitoring system. Host communication alarm settings can be modified, and an alarm notification template can be added. Together, these templates define when a host communication alarm is activated, who is notified, and what alarm priority should be assigned (for reporting purposes).

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree select one or more hosts.
3. Select Configure > Host Communication Alarm Settings.

![Edit Host Communication Alarm Settings](image)

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree select one or more hosts.
3. Select Configure > Host Communication Alarm Settings.
4. Set properties:

**Status**
Host communication alarms can only be generated when status is enabled.

**Device alarm template**
Accept the default template, Default Communication Alarm, or select a custom template from the drop-down list. Template selection applies to all selected hosts.

**Alarm notification template**
Select a custom template from the drop-down list. Notifications are not sent if no alarm notification selected (alarms are always indicated on the Location Alarms tab in Sites or Overview, or in the Alarms window).

**Alarm message**
(Optional) Add a descriptive message to include in alarm notifications. This text is used in place of the [AlarmMessage] macro in the related default email templates, or can be added to a custom email/SMS/voice template.

**Alarm comment**
(Optional) Select from the list of available predefined comments, or enter a custom comment to include in alarm notifications. This text is used in place of the [Comments] macro in the related default email templates, or can be added to a custom email/SMS/voice template.

5. Save your changes.

More Information

- Editing Device Alarm Templates (page 95)

### 6.4.3 Editing Host Configuration Alarm Settings

**Manage Alarm Templates**

By default, viewLinc assigns a host configuration alarm template to all new hosts added to the viewLinc monitoring system. Host configuration alarm settings can be modified, and an alarm notification template can be added. Together, these templates define when a host configuration alarm is activated, who is notified, and what alarm priority should be assigned (for reporting purposes).

1. In Sites Manager select the **Hosts and Devices** tab.

2. On the **Hosts and Devices** tree select one or more hosts.

3. Select **Configure > Host Configuration Alarm Settings**.
4. Set properties:
   **Status**
   Host configuration alarms can only be generated when status is enabled.

   **Device alarm template**
   Accept the default device alarm template, Default Host Configuration Alarm, or select a custom template from the drop-down list. Template selection applies to all selected hosts.

   **Alarm notification template**
   Select a template from the drop-down list. Notifications are not sent if no alarm notification selected (alarms are always indicated on the Location Alarms tab in Sites or Overview, or in the Alarms window).

   **Alarm message**
   (Optional) Add a descriptive message to include in alarm notifications. This text is used in place of the [AlarmMessage] macro in the related default email templates, or can be added to a custom email/SMS/voice template.

   **Alarm comment**
   (Optional) Select from the list of available predefined comments, or add a custom comment to include in alarm notifications. This text is used in place of the [Comments] macro in the related default email templates, or can be added to a custom email/SMS/voice template.

5. Save your changes.

More Information
- Editing Device Alarm Templates (page 95)

### 6.4.4 Creating Device Alarm Templates

**Manage Alarm Templates**

Create a copy of a device alarm template when you want to replicate most template properties, or create a new template when you want to define all new properties.

1. In **Alarm Templates** select the **Device Alarms** tab.
2. Select Add > Add Device Alarm Template. To copy settings, select an existing template, then select Add > Copy Selected Device Alarm Template.

3. In the Add Device Alarm Template window, type a unique name for the new template and then set the template properties:
   - **Priority**
     The priority level is used as a visual indication of issue severity, to help you determine how quickly to respond to the issue.
   - **Alarm delay**
     When viewLinc identifies a device alarm condition, the delay is the time period starting from the moment an issue is detected and when the device alarm is triggered. It is recommended that you set the delay according to the priority.
   - **Acknowledgement**
     Indicate whether user acknowledgement of this device alarm is required. When an alarm is acknowledged, the action is tracked in the event log.
   - **Permissions**
     Select the groups permitted to modify or apply this template. The group requires Configure Alarms permission to apply the template to Locations.
   - **Description**
     (optional) Provide more details about the device alarm template.

4. Select Save.

You can now apply this device alarm template to a Location.

When you apply a device alarm template to a Location, it remains in effect on the Location, even if the Location is linked to a different device.
6.4.5 Applying Device Alarm Templates

Manage Alarm Templates

Default device alarm templates are automatically applied to linked Locations and template settings can be modified. You can also create and apply custom device alarm templates.

To apply a custom device alarm template to a Location, you require **Configure Alarms** permission or higher for the selected Location.

1. In *Sites Manager* navigate the **Zones and Locations** tree to select a Zone or a Location.
2. Select the **Device Alarm Settings** tab.
3. Select the row for each device alarm type you want to modify, then select **Edit** (or use the right-click menu). Sort the **Alarm Type** column in ascending or descending order to select a group of the same device alarm types.
4. On the **Edit Device Alarm Settings** window, verify you have selected the correct Location(s).
5. Edit device alarm settings:
   **Status**
   Device alarms are only generated when status is enabled.

   **Device alarm template**
   Select the template to use for the alarm type. If multiple templates are in use, it is recommended not to change the current template selections.

   **Alarm notification template**
   Select an available alarm notification template to use for device alarms at selected Location. If multiple templates are in use, it is recommended not to change the current template selections.

   **Alarm message** or **Alarm comment**
   All device alarm notifications use content specified in viewLinc’s default notification templates. Use these fields to insert custom text in place of the [AlarmMessage] and [Comment] macros embedded in the content templates.

6. Select **Save**.

**More Information**

- Notification Content (page 104)

**6.4.6 Editing Device Alarm Templates**

**Manage Alarm Templates**

Modify device alarm template settings for all Locations using a default viewLinc device alarm template.

1. In **Alarm Templates** select the **Device Alarms** tab.
2. Select the template you want to modify, then select **Edit**.
3. Select **View Locations** to verify that changes can be applied to all Locations currently using the template.
4. Modify editable settings.
5. Select **Save**.

**6.4.7 Editing Location Device Alarm Settings**

**Manage Alarm Templates**

Device alarm settings can be set for individual devices, or applied to several devices at one time.

To modify device alarm settings you require **Configure Alarms** permission or higher for the selected Location(s).
1. In **Sites Manager** in the **Zones and Locations** tree, select the Zone or Location you want to modify (CTRL+click to select multiple Zones and Locations).

2. Select the **Device Alarm Settings** tab, and then select one or more device alarm rows in the grid.

3. Select **Edit device alarm settings**, then adjust settings in the **Edit Device Alarm Settings** window:
   - **Affected Locations**
     Verify that all Locations linked to this device can be updated with new device alarm settings. If a device has multiple Locations linked to its channels, make sure that new alarm template settings are applicable to all affected Locations.
   - **Status**
     If the status is disabled, viewLinc will not initiate the specified device alarm or device notifications.
   - **Device alarm template**
     Select a device alarm template or accept the default option provided. Device alarm templates set the priority level for the device alarm condition, when it is issued, and if it needs to be acknowledged. If multiple device alarms selected, it is recommended not to change the current template selections.
   - **Alarm notification template**
     Select an alarm notification template or accept the default option provided. Alarm notification templates specify who is notified, when and how. If multiple device alarms selected, it is recommended not to change the current template selections.
   - **Alarm message**
     (Optional) Add a descriptive message to include in notification messages. This text is used in place of the [AlarmMessage] macro in the related default email templates, or can be added to a custom email/SMS/voice template.
   - **Alarm comment**
     (Optional) Select from the list of available predefined comments, or type a custom comment to include in notification messages. This text is used in place of the [Comments] macro in the related default email templates, or can be added to a custom email/SMS/voice template.

4. Select **Save**.

### 6.5 Alarm Notifications

An integral feature of the Vaisala viewLinc Monitoring System is the ability to configure multiple alarming functions to ensure that you are notified as soon as conditions exceed set parameters. Alarm events are immediately visible on a user’s desktop or a remote display, and viewLinc can also be configured to initiate audible browser alarms, deliver email, send SMS messages (via modem or web service provider), or issue voice calls to individuals on a call tree.

Activation of web-enabled SMS and voice messaging services requires purchase of feature license keys and a service provider account.
Alarm notification templates define:

- When to send an alarm notification.
- Who should receive a notification.
- How the notification is delivered (email, SMS, voice call).
- If a visual external alarm command is initiated.
- If a notification delay is required after an alarm is triggered, and if the notification will repeat at timed intervals to the same or different recipient(s).

The content of an alarm notification is defined by the messaging template associated with the alarm.

Audible browser alarms are enabled in System Preferences on the General tab, and the user receiving an alarm must have their PC set up to receive audible alarms.

Alarm notification templates can be assigned to Locations using a threshold alarm template, to a linked Location’s device alarm templates, or can be assigned to system alarms (see System Preferences > System Alarms).

Example

If you want a notification sent to an on-site supervisor, you could create an email notification with a short delay period, perhaps 1 minute, and an SMS notification to be issued at 20 minutes.

You may also want a voice call notification delivered to someone else with a different delay period, for example 20 minutes. If the first notification is not acknowledged within 20 minutes, the second notification is automatically sent.

More Information

- System Preferences (page 107)
- Notification Content (page 104)

6.5.1 Web Service for SMS and Voice Alarm Notifications

Web-enabled voice and SMS notifications allows web delivery of voice or SMS alarm notifications. Message recipients are able to acknowledge web-delivered voice and SMS alarm notifications remotely with their mobile device and assigned PIN. Additionally, you can set up voice call trees to ensure there is a response from someone on your team.
For more information see Setting Up Voice or SMS Web Services (page 139).

6.5.2 Creating Alarm Notification Templates

Manage Alarm Templates

An alarm notification template defines who should be notified in the event of a threshold, device, or system alarm. You can set up an email, SMS, a local visual notification (command), voice call, or an escalation path using a combination of notification types, recipients, and delivery times.

Command notifications do not initiate for system alarms.

The content generated for alarm notifications is provided in over 40 default email/SMS/voice templates. Message content can also be customized to send specific information to select groups.

1. In Alarm Templates, select the Alarm Notifications tab.
2. Select Add > Add Alarm Notification Template. To copy settings, select an existing template, then select Add > Copy Selected Alarm Notification Template.

Permissions
Select the groups authorized to modify or apply this template to Locations.

Description
(optional) Provide more details about the alarm notification template.
3. In the **Notification Escalation Path** area, select **Add** to choose an alarm notification format.

![NotificationEscalationPath](image)

4. To create an email or SMS notification, complete the fields in the **Email Notification Settings** pane:
   - **Name**: Type a unique name for each notification. You may want to indicate whether it is an initial or followup notification, or identify the group it goes to.
   - **Notification delay**: Specify a delay in hours and/or minutes from when an alarm is triggered and you want an alarm notification message sent. Alarm activation delays can also be added to threshold alarms.

   > If you set a time delay before a notification message is sent, ensure the combined threshold alarm activation delay and alarm notification delay meets your alarm notification requirements.

   **Send to**: Select a user or select a group containing all the users you want notified. All users in the group will receive an alarm notification message (the content varies based on the type of alarm).

   **Send recurring notifications**: Turn this option on to send the a repeat notification at set intervals while the alarm condition exists, or after a specific number of notification messages are sent.

   **When the alarm is acknowledged**: Specify whether to stop or continue sending notifications after an alarm is acknowledged, and whether to send an acknowledgement notification message and/or an alarm off notification message.
5. To create a voice notification, complete the fields in the **Voice Notification Settings** pane:

**Name**
Type a unique name for this notification. You may want to indicate whether it is an initial or followup notification, or identify the users it goes to.

**Notification delay**
 Specify a delay in hours and/or minutes from when an alarm is triggered and you want an alarm notification message sent. Alarm activation delays can also be added to threshold alarms.

If you set a time delay before a notification message is sent, ensure the combined threshold alarm activation delay and alarm notification delay meets your alarm notification requirements.

**Call order list**
To add recipients to a call list, select **Edit call list**. Select a group which contains the user(s) you want to add, then select users in the order you want them called (you can reset the order with the Order arrows (right column). You can choose more groups to select additional users. Save the list.

Only users with mobile phone numbers assigned in viewLinc display on the list.

**Send recurring notifications**
Turn this option on to send a repeat voice call at set intervals (every 15 minutes to 24 hours) while the alarm condition exists, or after all call tree notifications are sent. Each user who receives a call has the option to acknowledge the notification and stop the call tree or, if the system preference for voice acknowledgement is not enabled, to confirm receipt of the call, or to verify that the alarm is no longer active (all options require the user to have a mobile phone number and PIN recognized in viewLinc.

**When the alarm is acknowledged**
Specify whether to stop or continue calling recipients after an alarm is acknowledged, and whether to send an acknowledgement notification message and/or an alarm off notification message.
6. To create a command notification, complete the following fields in the Command Notification Settings window:

**Name**
Type a unique name to describe the command.

**Notification delay**
Specify a delay in hours and/or minutes from when an alarm is triggered and you want the command to run. Alarm activation delays can also be added to threshold alarms.

If you set a time delay before a command runs, ensure the combined threshold alarm activation delay and command run delay meets your alarm notification requirements.

**Main command to run**
Type the first command you want to run when an alarm is triggered. Additional commands can be set to run in the recurring command area. Here is an example of a Python script specific to a digital relay I/O device. Different parameters apply to different commands or scripts:

```bash
C:\Program Files\Vaisala\viewLinc\python\python" -m viewLinc.scripts.SwitchBbRelay [COM port number]
```

**Run recurring commands**
Choose to send the same or different command at repeating intervals while the condition still exists; specify whether you want the commands to stop running after the alarm is acknowledged, or after a specific number of commands are run.

**When the alarm is acknowledged**
Choose to continue or block recurring commands.

**Run command when alarm acknowledged/when alarm turns off**
Choose a different command to run when an alarm is acknowledged or when the alarm turns off.

7. Select **Save**. You can now apply this alarm notification template to one or more Locations (Sites Manager > Manage), or assign it for use with system alarms (System Preferences > System Alarms).

More Information
- Notification Content (page 104)

### 6.5.3 Applying Alarm Notification Templates

**Manage Alarm Templates**

After creating alarm notification templates, apply the template to Locations currently using enabled threshold alarm templates, add them to specific device alarm templates, or assign them for use with system alarms.
To apply an alarm notification template, you require **Configure Alarms** permission or higher for the selected Location.

### 6.5.3.1 Applying Alarm Notification Template to Location Threshold Alarm

1. In **Sites Manager** on the **Zones and Locations** tree, select a Location.
2. Select the **Threshold Alarm Settings** tab.
3. Select a threshold alarm settings row on the grid, then select **Edit Threshold Alarm Settings**. If no templates are available, you must add a threshold template to the Location (**Manage > Add Threshold Alarms**).
4. On the **Edit Threshold Alarm Settings** window, select an enabled threshold level.
5. In the **Alarm Notification Template** column, use the drop-down list to select an available alarm notification template.
6. Select **Save**.

### 6.5.3.2 Applying Alarm Notification Template to Multiple Location Threshold Alarms

1. In **Sites Manager** navigate the **Zones and Locations** tree to select a Zone or several Locations (**CTRL + click**).
2. On the **Threshold Alarm Settings** tab, select one or more threshold setting rows.
3. Select **Edit threshold alarm settings**.
4. On the Edit Threshold Alarm Settings window in the Alarm notification template column, select a template for one or more enabled threshold levels.

5. Select Save.

6.5.3.3 Applying Alarm Notification Template to Location Device Alarm

1. In Sites Manager navigate the Zones and Locations tree to select a Location.
2. Select the Device Alarm Settings tab.
3. Select the device alarm type from the list, then select Edit Device Alarm Settings.
4. On the Edit Device Alarm Settings window, in the Alarm notification template field, select an alarm notification template.
5. Select Save.

6.5.3.4 Applying Alarm Notification Template to Multiple Location Device Alarms

1. In Sites Manager navigate the Zones and Locations tree to select a Zone or multiple Locations (CTRL + click).
2. Select the Device Alarm Settings tab.
3. Select the same device alarm types (use the Alarm Type column header to sort the grid in ascending or descending order), then select Edit device alarm settings.
4. On the Edit Device Alarm Settings window, in the Alarm notification template field, select an alarm notification template.
5. Select Save.

6.5.3.5 Applying Alarm Notification Templates for System Alarms

1. In System Preferences select the System Alarms tab.
2. Select an alarm notification template for Database Validation Alarms and/or Event Log Validation alarms.
3. Select Save.
6.5.4 Editing Alarm Notification Templates

Manage Alarm Templates

Before making changes to an alarm notification template, check which Locations and system alarms are using the template.

1. In Alarm Templates select the Alarm Notifications tab.
2. Select the template you want to modify, then select Edit.
3. Modify the editable settings.
4. Select Save.

6.6 Notification Content

Location threshold, device and system alarm notifications contain default message content to inform your team about alarm conditions occurring on your network.

viewLinc provides more than 40 default message templates, in all supported languages. Message templates are provided for all stages of the notification cycle: initial notification of an alarm condition, recurring notifications, notification that an alarm condition is no longer present, and notification of an acknowledged alarm.

To view and edit messages in other languages, log into viewLinc using the required language.

Additional alarm messages and/or comments can be included in the content of standard threshold, device, and system alarm notifications.

More Information

- Applying Threshold Alarm Templates to Locations (page 84)
- Editing Location Device Alarm Settings (page 95)
- Setting System Alarm Preferences (page 121)

6.6.1 Creating Custom Message Content

Manage Alarm Templates

You can modify email, SMS and voice message content issued from viewLinc. Type specific text or add a macro to insert system-generated content, such as a timestamp or a predefined alarm comment. For a complete list of macro definitions, see Predefined Settings (page 226).
When adding macros to SMS or voice messages, make sure the expected content will not generate unnecessarily long messages.

1. In **Alarm Templates** select the **Notification Content** tab.

2. Select a template to modify, then select **Edit**. In the window, default content is displayed but it cannot be modified.

![Edit Notification Content](image)

3. To modify email message content:
   a. Select the **Email Message** tab, then select **Custom Email Content**.
   b. Add new content in the active custom text areas, **Email subject**, **Email text**.
   c. To insert system-generated content, such as a timestamp or a predefined alarm comment, move the cursor where you want to add the content, then select an option from the **Add [macro]** dropdown. For a complete list of macro definitions, see Table 28 (page 227).

4. To modify SMS message content:
   a. Select the **SMS Message** tab, then select **Custom SMS Content**.
   b. Add new content in the **SMS text** field. Note: SMS modem messages are limited to 70 characters in length; SMS web service messages are split after 160 characters. SMS modem message length can increase if your network supports longer SMS messages.

5. If your system is licensed for voice web service and you have selected a template with a voice message option:
   a. Select the **Voice Message** tab, then select **Custom Voice content**.
   b. Add new content in the **Voice text** field. Note: Make sure to write a message that is understandable as a spoken message. Make use of colons, commas and periods to create pauses in the verbal message and insert applicable macros.
6. Save your changes.

If you have a voice notification that uses macros, such as: "This is a repeat notification for a communication alarm recorded on [AlarmTimestamp]. On Device Host: [DeviceHostName]", and the notification is sent at 13:54 for hostname VANHOST-AP10E-1001, your recipient will hear the macro information read out as: "This is a repeat notification for a communication alarm recorded on UTC-7 thirteen fifty-four on v-a-n-h-o-s-t-dash-a-p-one-zero-e-dash-one-zero-zero-one."

If a zone or location name is included in a message, Twilio will read out the names if they are identified as proper nouns; otherwise, the letters will be read out. To help Twilio recite zone or location names clearly, add a space between characters and letters. For example,

Zone A = "zone a"
ZoneA = "z-o-n-e-a"

More Information
- Applying Threshold Alarm Templates to Locations (page 84)
- Editing Location Device Alarm Settings (page 95)
7. System Preferences

viewLinc defines system options that affect the behavior and display of your data and devices. System preferences can be modified by users who are assigned to groups with Manage System right.

### 7.1 Modifying General System Settings

**Manage System**

1. In System Preferences on the General tab, set General options:
   - **Add License**
     - To increase the number of supported devices, enter the corresponding license key (manually type the number in the fields or copy/paste). New license keys are added to increase the number of supported devices, or when you are adding new licensed features. Your current license information is available in the About window. To learn more, see Entering New License Key (page 114).
   - **System language**
     - Set the default system language for reports and notifications. You can also enable additional languages to allow users to set preferred language output for reports, notifications and their viewLinc desktop display.
     - To learn more, see Setting System Language (page 115).
   - **Email alarm acknowledgement, SMS alarm acknowledgement, Voice alarm acknowledgement**
     - Allow users to acknowledge alarms by responding to notifications sent via email, SMS, or voice call.
     - To learn more, see Allowing Remote Acknowledgement (page 109).
   - **Scheduling**
     - Enable this option to control when users receive notifications, and when Location alarming should be active. After enabling this option, create schedules.
     - To learn more, see Creating Schedules (page 129).
   - **Audible alarm notification**
     - Enable audible alarm notification in a browser, then set up each user’s account profile to receive audible alarming.
     - To learn more, see Enabling or Disabling Audible Alarms (page 110).
   - **Audible alarm sound**
     - Choose the sound for audible browser alarms. Select the ⏯ to start/stop a sound test.
2. Set default units and values. These values are used wherever units display (trend graphs, reports). These values can be modified for specific Locations.

**Default temperature units**
By default, all devices monitoring temperature display in Celsius.
To learn more, see Setting Temperature Measurement Units (page 111).

**Default value for MKT activation energy**
Set the MKT value according to your GxP requirements.
To learn more, see Setting MKT Activation Energy Value (page 111).

3. Specify device options:

**Device description**
Choose to display the device alias (a longer description) in viewLinc.
To learn more, see Setting Device or Channel Alias Preferences (page 112).

**Channel description**
Choose to display the channel alias (a longer description) in viewLinc.
To learn more, see Setting Device or Channel Alias Preferences (page 112).

**Default calibration duration**
Set default data logger and probe calibration cycle length in months.
To learn more, see Setting System-Wide Default Calibration Duration (page 112).

**Automatically lock DL data loggers**
Enable auto-locking to ensure all newly connected DL data loggers can only be modified by viewLinc.
To learn more, see Locking or Unlocking DL Data Loggers (page 216).

**DL data logger timebase synchronization**
When the logger timebase synchronization feature is enabled, the time clock in a logger is continuously compared with the viewLinc clock and adjusted, if required.
To learn more, see Enabling or Disabling Timebase Synchronization (page 113).

**viewLinc Aware functionality**
Enable viewLinc Aware to ensure faster setup for vNet devices.
To learn more, see Enabling or Disabling viewLinc Aware (page 113).

4. Set security options:

**Comments on changes**
Indicate whether comments are required when users acknowledge alarms or modify the system.
To learn more, see Adding Predefined Comments (page 123).

**Confirm identity on changes**
Require user authentication when making system changes.
To learn more, see Setting Authentication Requirement (page 114).
5. Adjust technical support log settings (optional).

**System log**
Record different amounts of system activity.

**Device driver log**
Record different amounts of device activity.

**Log maximum age**
Specify how long to store technical support files. Once the limit is reached, old log files are deleted.
To learn more, see Changing Technical Support Log Settings (page 115).

> It is recommended that you change support log settings only when directed by Vaisala Technical Support.

6. Save your changes.

### 7.2 Allowing Remote Acknowledgement

**Manage System**

viewLinc must be configured to allow users to acknowledge alarm notifications remotely, via email, SMS, or voice call.

> Each user who is permitted to acknowledge SMS alarm notifications remotely must include a mobile number and unique PIN on their user account profile.

1. In **System Preferences** on the **General** tab, enable the acknowledgement option(s) you want:

**Email alarm acknowledgement**
To allow email acknowledgement, make sure your email server is set up to receive email acknowledgements.

**SMS alarm acknowledgement**
To allow SMS acknowledgement, make sure each user has a mobile phone number and unique PIN entered in their user account profile. Also make sure your SMS modem is set up to receive SMS acknowledgements, or you have set up an SMS web service account and SMS web settings configured.

**Voice alarm acknowledgement**
Acknowledgment by voice call requires a voice web service account and voice settings configured.

2. Select **Save**.
7.3 Enabling or Disabling Schedules

Manage System

Set specific times of day or days of the week when you want a user or group to be notified of alarm conditions. Schedules can also be used to specify the times when you want Location threshold alarming active. By default, this option is disabled.

1. In System Preferences on the General tab, select the Scheduling Functionality row.
2. Enable or disable scheduling.
3. Save your changes.

More Information

• Schedules (page 128)

7.4 Enabling or Disabling Audible Alarms

Manage System

Audible alarming activates a sound on a user’s computer in the event of an alarm condition. An audible alarm icon displays on the viewLinc desktop UI, Alarms (21).

• To hear an audible alarm, the user must be logged into viewLinc on their computer and have audible alarms enabled on their user profile.
• To turn off an active audible alarm, the user can click the alarm icon.

CAUTION! Audible alarms are not heard if the user is not logged in, or is using a browser with audio turned off.

1. In System Preferences select the General tab.
2. On the Audible alarm notification row, select Enabled or Disabled.
3. If audible alarms are enabled, use the Audible alarm sound row to select a sound. Select the to start/stop a sound test.
4. Select Save.
7.5 Setting Temperature Measurement Units

Manage System

When viewLinc is first installed, temperature values are set to display in degrees Celsius. You can configure viewLinc to show temperatures in either Celsius or Fahrenheit, a setting that is applied globally.

This setting does not alter how a device measures temperature, it simply alters the units in which temperature is displayed (except for channels which already have preferred unit settings assigned).

You can set measurement units on individual device channels.

1. In System Preferences, on the General tab, select the Default temperature units row.
2. Set the value.
3. Select Save.

More Information

• Editing Device Properties (page 55)

7.6 Setting MKT Activation Energy Value

Manage System

The default value for MKT Activation Energy is used when generating reports and trends.

Mean Kinetic Temperature (MKT) is considered useful for understanding temperature excursions in GDP-compliant applications. See MKT Application Note.

1. In System Preferences on the General tab, select the Default value for MKT activation energy row.
2. Set the value.
3. Select Save.
7.7 Setting Device or Channel Alias Preferences

**Manage System**

Vaisala devices have descriptions stored inside them that have a maximum length of 16 alpha-numeric characters (300-series transmitters do not store descriptions). These descriptions can be defined and modified using viewLinc or device configuration software (vLog or HMT140 Utility).

For easier reference, you can configure viewLinc to display a longer, more informative description for a device or a channel, up to 64 alpha-numeric characters. This longer description is called an alias. Events, Alarms, Reports windows, and email messages all use the selected description for channels and devices.

1. In System Preferences on the General tab, select the Channel description or Device description row.
2. Set to Use [ ] alias.
3. Select Save.

7.8 Setting System-Wide Default Calibration Duration

**Manage System**

A device calibration alarm is an intermittent notification sent when a Vaisala data logger or probe is due for calibration.

By default, you receive notifications at the following intervals: 3 months and 1 month before the calibration due date, then again on the scheduled recalibration date (auto-generated for 1 year from last calibration date). This alarm remains active, even after acknowledgement, until the device is recalibrated (for more information contact Vaisala Calibration Service Center).

You can set the default calibration duration for all data loggers in System Preferences, or, if you have Manage Devices right, modify the duration for a specific data logger or probe in Sites Manager (Hosts and Devices > Configure > Edit Properties).

1. In System Preferences select the row, Default calibration duration.
2. Choose a time period in months.
3. Select Save.
7.9 Enabling or Disabling Timebase Synchronization

Manage System

Synchronized data collection timing between viewLinc and your DL data loggers ensures more accurate data collection by automatically correcting time drift. When the DL data logger timebase synchronization feature is enabled, the time clock in a DL data logger is continuously compared with the viewLinc clock and adjusted, if required.

Minor time drift is expected over long data monitoring periods, and can be a result of the impact of temperature on a device collecting data (such as a data logger in a cold area) and where the data is sent (computer in a controlled server room).

Enable DL data logger timebase synchronization only on one viewLinc Enterprise Server. Timebase synchronization only corrects time drift up to 15 minutes. If the drift is greater than 15 minutes, clear data logger history.

1. In System Preferences on the General tab, select the DL data logger timebase synchronization row.
2. Set to Enabled or Disabled.
3. Select Save.

More Information

- Clearing Historical Samples in DL Data Loggers (page 217)

7.10 Enabling or Disabling viewLinc Aware

Manage System

This function automatically permits viewLinc to search for and communicate with vNet devices on your network or subnet. The latest Firmware must be installed on each vNet device (v1.4 or higher).

Only enable this option on one viewLinc Enterprise Server installation per subnet.

1. In System Preferences select the General tab.
2. Select the viewLinc Aware functionality row, then select Enabled or Disabled.

3. Select Save.
   New devices are automatically discovered in viewLinc within five minutes. If the autodiscovery process is taking too long, you can force discovery.

More Information

• Discovering Networked Devices (page 47)

7.11 Entering New License Key

Manage System

The viewLinc license key entered during installation specifies how many devices can be managed by viewLinc, it does not monitor how many users can access the system (unlimited). Add new license keys to increase the number of devices you can monitor with viewLinc, or to enable additional licensed features (to support third-party Modbus devices, integration with OPC UA Server, Voice web services, SMS web services, and/or Web API).

Your current license information is displayed in the About window (Help > About).

1. In System Preferences, select the General tab.
2. Select Add License and enter the new viewLinc or feature license key number (or copy and paste).
3. Select Add.

7.12 Setting Authentication Requirement

Manage System

To ensure more robust system security, you can require that users reenter their password to make changes in viewLinc. This setting is applied universally to all viewLinc users.

1. In System Preferences select the General tab.
2. Select **Confirm identity on changes**, then choose an authentication option:

**Never**
Logged-in users are not required to confirm their identity when making changes.

**Always**
Logged-in users are required to enter their password each time they try to make a change.

**After 1 - 30 minutes/After 1 hour**
Logged-in users are required to re-enter their password if the selected time period has passed since their last authenticated change.

3. Select **Save**.

### 7.13 Changing Technical Support Log Settings

**Manage System**

If you require viewLinc technical support, your Vaisala Technical Support representative may ask you to change the technical support log settings temporarily, to help them better understand the issue you may be encountering.

These options specify the amount of information detail included in the support log file, for viewLinc and for data logger drivers, and for how long data will be stored before it is deleted (your technical support representative will advise which settings should be applied).

1. In **System Preferences** select the **General** tab.

2. In the **System log**, **Device driver log**, and **Log maximum age** rows, set the amount of technical detail required, as directed by Vaisala Technical Support.

3. Select **Save**.

Vaisala Technical Support will remind you to reset default values after completing their analysis.

### 7.14 Setting System Language

**Manage System**

The system language setting is used for reports and notifications. By default it is the language selected during viewLinc Enterprise Server installation. If your company operates in countries where other languages are spoken, you may want to provide users the option to receive notifications and reports, and display the viewLinc desktop, in their native language.

Enable support for additional languages on the **System Preferences > Languages** tab, and then set the user language preference on each users’ profile.

Important notes about system language setting and user language preference:
Quick reports: When a user generates a Quick Report, the content is generated according to the user's logged in language, even if it is different from their language preference.

Scheduled reports: Sent to recipients according to their language preference.
  • If no user language preference is specified, report content is generated in the report language.
  • If no user language preference or report language specified, the content is generated according to the default system language.

User-generated reports: Report content is generated in the system language.

Languages supported:

- English (EN)
- Chinese (Simplified - ZH)
- French (FR)
- German (DE)
- Japanese (JA)
- Swedish (SV)
- Spanish (International - ES)
- Portuguese (Brazilian - PT)

1. In **System Preferences** select the **General** tab.
2. In the **System language** row, select the system language.
3. Select **Save**.

**More Information**

- [Adding Users](page 76)

### 7.14.1 Making Additional Languages Available

1. In **System Preferences** select the **Languages** tab.
2. Enable the language choices you want displayed when users log in.
3. Select **Save**.

### 7.15 Setting Measurement Unit Display Preferences

**Manage System**

Channel measurement units are preset in your devices. However, you can display device measurement units differently in viewLinc. For example, if a channel tracks voltage in MilliAmps, you could change the viewLinc display text to, mA.

1. In **System Preferences** select the **Units** tab.
2. Select a unit type row, then select **Edit**.
3. Update the unit properties:
   **Name**
   For non-viewLinc default unit types, you can modify the name of the unit type.
   **Device Units**
   Type a maximum of 6 CAPITAL letters per unit of measurement. Use a comma (,) to separate unit types.
   **Display Text**
   Type the format to display for each unit. For example, if a temperature unit is C, you may want to display Celsius.
   **Min**
   Set the minimum value permitted for this unit.
   **Max**
   Set the maximum value permitted for this unit.

4. To add new device units, select **Add**. In the **New Unit** window make sure you type the unit properties as they are set in your device.

   See your device user’s guide to determine current unit properties and min/max values.

5. Select **Save**.

You can delete any unit types that were manually added and are not currently used by a Location or threshold alarm template.

7.16 Configuring Email/SMS/Voice Notification Preferences

Alarm notifications are issued via email, via SMS modem or SMS web service, and/or via voice web service (web services require purchase of a Twilio account). An IT administrator can help define the notification connection settings for the issuing and receiving server(s).

More Information
- Setting Up Voice or SMS Web Services (page 139)

7.16.1 Configuring Email Settings

Manage System

Define your company’s outgoing email account information used for sending system alarm email notifications, and incoming email server requirements used to receive system alarm email acknowledgements (if remote acknowledgment is permitted).

1. In **System Preferences** select the **Email Settings** tab.
2. In the **Outgoing Server** area, type a valid send from address (email notifications from viewLinc are sent from this address, so the email address must exist within your company), then complete the following:
   
   **SMTP server**
   Type the mail server address. For example, smtp.company.com.
   
   **Port**
   Type the outgoing mail server port number (between 1-65535, default is 25). Your IT network administrator has this information.
   
   **SMTP authentication**
   Select if your outgoing mail server requires authentication, and then type the username or email address, and password required to send email.

   - ViewLinc automatically uses secure SMTP if it is supported by the SMTP server.

3. Select **Send Test Email** to verify the test email is sent successfully.

4. In the **Incoming Server** area, configure the required mail server settings for your connection type:
   
   **Connection type: POP3**
   - **POP3 server**
     Type the incoming POP3 mail server name (for example, pop.company.com).
   
   **Port**
   Type the incoming mail server port number (default is 110).
   
   **User name and Password**
   Type the username (or address) and password for a valid POP3 account, required to receive email.
   
   **Connection type: IMAP**
   - **IMAP server**
     Type the incoming IMAP mail server name (for example, imap.company.com).
   
   **Port**
   Type the incoming IMAP mail server port number (default is 143).
   
   **User name and Password**
   Type the username (or address) and password for a valid IMAP account, required to receive email.

5. Select **Save**.

### 7.16.2 Configuring SMS Settings

- **Manage System**
If you want viewLinc to send alarm notifications and receive acknowledgements via SMS, you can choose to set up and configure an SMS modem, or configure viewLinc to use an SMS web service. Activation of the SMS web service requires a feature license, an account with a service provider, and an internet-accessible port. For more information, see Setting Up Voice or SMS Web Services (page 139)

1. In System Preferences select the SMS Settings tab.

2. To configure an SMS modem, select SMS modem and then complete the SMS modem settings:
   - **SMS COM port**
     Type your SMS modem COM port number. If you are setting up an SMS web service, this port must allow access to the internet.
   - **Baud rate**
     Select the rate which is best supported by your modem.
   - **SIM Card PIN number**
     Type the PIN number required to receive incoming messages.

   SMS modem messages are limited to 70 characters in length. Message length can increase if your network supports longer SMS messages.

3. To configure the Twilio SMS web service, select the SMS sender option, Web service, and enter your Twilio account details:
   - **Account SID**
     Type the security identifier number provided by your SMS service provider. The SID is used to identify your account like a username.
   - **Authentication token**
     Type the token number provided by your SMS service provider. The token identifies your account like a password.
   - **Phone number**
     Type the country code followed by the full phone number provided by the web service provider.
   - **viewLinc URL**
     Type the viewLinc Enterprise Server hostname or IP address used to access viewLinc through the Internet

   SMS web messages are limited to 160 characters in length. If a message contains more characters, it is separated and sent as an additional message.
4. To complete SMS configuration, select the **Test** button.
   a. Type a recognized viewLinc user’s mobile phone number to receive the test message. 
      If the SMS test message is not sent (it may take a minute before delivery), adjust the 
      settings until the test message is sent successfully.
   b. If you are testing an SMS web service configuration, on the receiving mobile phone, 
      type a reply to the message, **test**. This action will verify that viewLinc can receive 
      SMS acknowledgements sent via the web service.

5. **Save** the settings.

**More Information**

- Setting Up Voice or SMS Web Services (page 139)

### 7.16.3 Configuring Voice Call Web Service

**Manage System**

Before you start, make sure you have added the voice call feature license, you have your Twilio 
account details available, and a valid internet-accessible URL is available. For more 
information, see Setting Up Voice or SMS Web Services (page 139).

1. In **System Preferences** select the **Voice Settings** tab.
2. Add your Twilio voice account settings:
   - **Account SID**
     Type the security identification number provided by your voice messaging service 
     provider. The SID is used to identify your account (like a username).
   - **Authentication token**
     Type the token number provided by your voice messaging service provider. The 
     token allows messages to be sent from your Twilio account (like a password).
   - **Phone number**
     Add your Twilio phone number. This number is used to send notifications to your 
     users.
   - **viewLinc URL**
     Type the viewLinc Enterprise Server hostname or IP address used to access 
     viewLinc through the Internet.
3. Send a test message:
   a. Type a recognized viewLinc user's mobile phone number to receive the test message. 
      Note that calls cannot be sent if viewLinc is not accessible through the Internet.
   b. If the voice test message is not delivered (it may take a minute before delivery), 
      adjust the settings until the test message is sent successfully.
4. **Save** the settings.

**More Information**

- Setting Up Voice or SMS Web Services (page 139)
7.17 Setting System Alarm Preferences

Manage System

System alarms are generated automatically to indicate general system issues, database history integrity, and event log tampering. They are always high priority, are issued immediately, and always require acknowledgement. Acknowledgement of system alarms can be performed in viewLinc or remotely via email/SMS/voice.

To issue voice call notifications for system database or event log validation alarms, create an alarm notification template that includes a voice call tree.

1. In System Preferences select the System Alarms tab.
2. In the IT Network Manager area, type the mobile number and email address you want to receive viewLinc system notifications. You can also choose whether to send copies of system alarm notifications to members of the Administrators group.
3. In the Database Validation Alarm area, the Priority, Alarm delay and Acknowledgement options cannot be modified. You can modify the following options:

   **Alarm notification template**
   
   Choose an alarm notification template to use with the system alarm notification. The alarm notification template defines whether a notification is issued, in what format, how soon after the alarm is triggered the notification is sent, and how often it is repeated.

   Commands are not initiated for system alarms.

   **Alarm message**
   
   Alarm message text replaces the [AlarmMessage] macro in database validation alarm notifications, email messages only.

   **Alarm comment**
   
   Choose to include a predefined comment (if available), or type a custom comment. Comments text replaces the [Comments] macro in database validation alarm notifications, email messages only.
4. In the **Event Log Validation Alarm** area, the **Priority**, **Alarm delay** and **Acknowledgement** options cannot be modified. You can modify the following options:

**Alarm notification template**
Choose an alarm notification template to use with the system alarm message. The alarm notification template defines whether an email, SMS or command notification is issued, how soon after the alarm is triggered the notification is sent, and how often it is repeated.

**Alarm message**
Alarm message text replaces the `[AlarmMessage]` macro in event log validation alarm notifications, email messages only.

**Alarm comment**
Choose to include a predefined comment (if available), or type a custom comment. Comments text the `[Comments]` macro in event log validation notifications, email messages only.

5. Select **Save**.

**More Information**
- Creating Alarm Notification Templates (page 98)
- Notification Content (page 104)

### 7.18 Setting Comments Preferences

**Manage System**

User-entered comments can provide valuable reference information about changes made to your system, or in response to network events.

You can specify whether users are required to enter comments manually, or if they should select a predefined comment. Comments can be used in several places: added to events, included in reports and email notification templates, or added during acknowledgement of alarm notifications.

1. In **System Preferences** select the **General** tab.

2. In the **Comments on changes** row, select an option:
   - **Not required**
     Users will not be prompted to enter a comment when system changes are made.

   - **Optional**
     The comments window will appear for system changes, and users have the option to enter a comment or select a predefined comment.

   - **Required**
     The comments window will appear and users must enter a comment or select a predefined comment.

   - **Only predefined comments required**
     The comments window will appear with a list of available predefined comments. This option requires predefined comments to be available.
3. Select **Save**.

### 7.19 Adding Predefined Comments

**Manage System**

Predefined comments are a quick way for users to describe standard, repeatable actions taken when responding to alarms, or to provide common rationale for system changes.

The viewLinc administrator may want to include a predefined comment in outgoing system or threshold alarm notifications to provide guidance on actions required. To save time, users can add a predefined comment when responding to alarm notifications to describe a common action performed. Predefined comments can also be used to describe events in the event log.

1. In **System Preferences** select the **Comments** tab.
2. Select **Add**.
3. Type a new comment (up to 300 characters).
4. Select **Save**.

If you require that your users add a comment for all system changes/additions/deletions, set the comment preference in **System Preferences > General**.

You can add predefined comments to:

- System alarms.
- Location threshold alarm settings
- Alarm acknowledgements
- Events

**More Information**

- Applying Alarm Notification Templates (page 101)
- Setting System Alarm Preferences (page 121)
- Acknowledging Alarms in the Alarms Window (page 156)
- Adding Comments to Events (page 163)
8. Additional Setup Tasks

After all primary viewLinc configuration tasks are complete, you can take advantage of more viewLinc features:

- Add group permissions to Zones and Locations. Permissions are used to control the groups which can view, configure or manage different viewLinc Zones and associated Locations.
- Create schedules to define active periods for alarming and notifications. Schedules can ensure users who are not on shift do not receive notifications, or prevent unnecessary alarming during maintenance periods.
- Build views to help users more easily identify Locations of importance. For larger installations, views can help organize different categories of Locations.
- Connect a signal tower for wide-area visual and/or audible alarming.
- Set up a remote display to broadcast live conditions on a large monitor in a warehouse.
- Set up a Twilio account and configure viewLinc to support web-enabled voice and/or SMS message services.
- Configure viewLinc to connect with Vaisala OPC UA Server.

8.1 Permissions

Four levels of permission define the Zones and Locations group members can view and access, and, depending on the permission level granted, which functions a user can perform. Even if a group has Manage Sites right, members of the group can only modify settings for the linked Locations their group is permitted to access.
Permission levels are applied to Zones and can include or exclude sub-zones and Locations. By default, all users in the viewLinc **Everyone** group have **View** permission to view the top system Zone, viewLinc, but must be given **View** permission to see Zones or Locations that are added. Members of the viewLinc **Administrators** group have the highest permission level, **Full Control**, and can see and manage all new Zones and Locations that are added.

To manage permissions most effectively, apply group permission levels to specific Zones, and allow the permission to be inherited all sub-zones.

**Important Notes about Permissions**

- Permissions granted to a Zone apply to all sub-zones and Locations (inherited).
- An individual user’s permission is based on the highest group permission available for the Zone.
- If you upgraded from version 4.3.x or earlier version of viewLinc, permissions assigned to users are preserved; however, if you remove a user’s permission it cannot be reapplied.

**Before assigning permissions to groups, make sure each group has the rights required to complete tasks associated with the Zone or Location.**

**Example**

Francis is responsible for generating and distributing alarm reports created by the teams working in Zone: Laboratory A and Zone: Warehouse X. Francis is also responsible for acknowledging threshold alarms on all Locations in the sub-zone Workstation 1. Francis does not need to see the sub-zone Workstation 2, or the Zones Laboratory B or Laboratory C.

1. Add Francis to a group with **Manage Reports** right.
2. Assign the group **View** permission to Warehouse X, and make the permission inheritable to all sub-zones and Locations.
3. Assign the group **Acknowledge Alarms** permission to Laboratory A and make the permission inheritable to all sub-zones and Locations.

**More Information**

- Rights (page 74)
8.1.1 Permission Levels

The most basic permission level, View, allows a group to see a Zone and its Locations in various viewLinc windows. Higher permission levels allow a group to perform different actions on the Zone and the Locations in the Zone.

<table>
<thead>
<tr>
<th>Name</th>
<th>Actions Allowed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Control</td>
<td>View, acknowledge alarms, configure alarm templates, apply alarm schedules, and assign permissions for all Locations in a Zone.</td>
</tr>
<tr>
<td>Configure Alarms</td>
<td>View, acknowledge alarms, and apply or modify threshold alarm templates for all Locations in a Zone.</td>
</tr>
<tr>
<td>Acknowledge Alarms</td>
<td>View and acknowledge alarms for all Locations in a Zone.</td>
</tr>
<tr>
<td>View</td>
<td>View all Locations in a Zone.</td>
</tr>
</tbody>
</table>

8.1.2 Applying Group Permission to Zones

Manage Sites

Before groups can view any Zones or Locations in viewLinc, groups must be granted View permission or higher to specific Zones

Full Control permission is required to grant other groups permission to the selected Zone.

8.1.2.1 Adding Permissions

Manage Sites

1. In Sites Manager navigate the Zones and Locations tree to select a Zone or sub-zone.
2. To check currently applied permissions, select the Permissions tab and open the Permissions Viewer.
3. Select Manage > Edit Permissions.

To see which users are included in a group, select Properties.
4. Add permissions in the **Edit Permissions** window:
   - To apply the same group permissions for the selected Zone to all sub-zones and Locations, select the group then select **Inherit from**.
   - To change the group permission level, de-select **Inherit from** then choose a permission level in the **Permissions** columns.
   - To ensure a group has a permission level passed on to all current and future sub-zones and Locations in the selected Zone, ensure the **Inheritable** option is selected.

5. Select **Save**.

More Information
- **Using Permissions Viewer (page 128)**

8.1.2.2 Editing Permissions

**Manage Sites**

For a group with inherited permissions, you can remove inherited permission to a specific sub-zone.

You cannot modify a user’s inherited permissions granted from an earlier version of viewLinc. User permissions can only be removed.

1. In **Sites Manager** on the **Zones and Locations** tree, select a Zone.
2. Select **Manage > Edit Permissions**.
3. In the **Edit Permissions** window, de-select the group’s **Inherit from** checkbox, then choose a new permission level in the **Permissions** columns. If all permission levels are deselected, sub-zones are not visible (on the **Permissions** tab the column grid displays **Hide** in the **Permission** column).
4. Select **Save**.

8.1.2.3 Deleting Permissions

**Manage Sites**

Before permission can be deleted, inherited permission must be removed.

**CAUTION!** Deleting group permission may disable the group’s permission levels applied to subzones.

1. In **Sites Manager** on the **Zones and Locations** tree, select a Zone.
2. Select **Manage > Edit Permissions**.
3. In the **Edit Permissions** window, select the group.
4. Select **Delete**. If the **Delete** button is not active, you first need to disable inherited permissions.

5. Select **Save**.

**More Information**

- **Editing Permissions (page 127)**

### 8.1.3 Using Permissions Viewer

**Manage Sites**

For large organizations with multiple Zones or Locations and specific access control requirements, the **Permissions Viewer** provides you with a quick way to view currently applied group permissions.

1. In **Sites Manager** select a Zone on the **Zones and Locations** tree.

2. Select the **Permissions** tab. The highest available permission level assigned to groups or upgraded users appears in the **Permission** column. If no group permissions are available on a Zone, the group permission level is **Hide**.

3. To view all permissions for a specific group or user, select the **Permissions Viewer** button.

4. In the **Permissions Viewer** window, choose to **Show groups** or **Show users**.

5. Select a group or user to view all assigned permissions.

**More Information**

- **Editing Permissions (page 127)**

### 8.2 Schedules

By default, Location threshold alarming is always active and alarm notifications are always sent. Schedules are used to help manage network traffic when a Zone or Location does not require monitoring or when specific users are not required to receive alarm notifications. For example, you could set up a schedule for notifications to be sent to users on day shift, between 6 am and 4 pm, another schedule for users on night shift, 4 pm to 2 am, and a threshold alarm schedule for active alarming between 6 am to 2 am.

You can temporarily turn off all threshold alarming and prevent notifications from being sent, perhaps during a system maintenance period.

**More Information**

- **Pausing Threshold Alarming (page 159)**
8.2.1 Creating Schedules

**Manage System**

Schedules define a specific period of time when a user can receive alarm notifications, or to restrict the time frame when threshold alarms can be triggered for a Location.

Before you can apply schedules to users or Locations, make sure scheduling functionality is enabled.

1. In **Alarm Templates** select **Schedules > Add**.

![Add Schedule](image)
2. On the **Add Schedule** window define the schedule settings:

   **Schedule**
   You can create a schedule before setting it to **Enabled**. Once the schedule is applied to users or Locations, you can quickly enable or disable it here. If a schedule is disabled, thresholds are always monitored and notifications always sent for threshold excursions.

   **Name**
   Type a unique name for the schedule.

   **Time zone**
   Select the time zone you want the schedule to use. If your company monitors conditions in multiple time zones, you may want to create schedules for each time zone.

   **Start date**
   Choose a start date by typing in the text box or choosing a date from the calendar. This date defines the day of the week to start the schedule.

   **Repeat schedule every**
   To set the schedule for a standard work week that repeats every 7 days, type 7 and do not create an active time period for non-work days. For a continuous week (no days off), type 9. The maximum value is 99 days.

   **Define active time periods**
   Specify the time period for each day in the cycle, in 24-hour time. Use the following format (xx:xx is the start time and yy:yy is the end time):

   \[ xx:xx-yy:yy \]

   This time period specifies when threshold alarming is active and alarm notifications will be issued.

3. Select **Save**.

You can now apply this schedule to Locations and/or users.

**More Information**
- Enabling or Disabling Schedules (page 110)
- Adding User Schedules (page 131)

### 8.2.2 Setting Threshold Alarm Schedules

**Manage Sites**

Apply a schedule to a Zone or a Location to define when threshold excursions should trigger an alarm notification. Schedules are created in the **Alarm Templates** window.

Before applying a schedule to a Location, make sure you have enabled the scheduling function in **System Preferences** and created a schedule in **Alarm Templates**.
Configure Alarms permission is required to the selected Locations or Zones.

1. In Sites Manager in the Zones and Locations tree, select a Location.
2. Select Manage > Set Threshold Alarm Schedule.
3. In the Set Threshold Alarm Schedule window, select According to schedule and select a schedule from the dropdown list.

**CAUTION!** viewLinc does not monitor threshold limits outside scheduled times (no threshold alarms are activated and notifications are not sent). Choose Always to ensure alarm monitoring continues 24x7.

4. Select Save.

More Information

- Enabling or Disabling Schedules (page 110)
- Creating Schedules (page 129)

### 8.2.3 Adding User Schedules

**Manage System**

Apply a schedule to a user to define when they should receive alarm notifications. Schedules are created in the Alarm Templates window.

**Important**

Before adding a schedule, make sure you have enabled the scheduling function in System Preferences and created a schedule in Alarm Templates.

1. In the Users and Groups window select the Edit toolbar button.
2. On the Edit User window in the Send alarm notifications:
   - **Always**
     - Select to indicate that this user should always receive an alarm notification 24x7. This is the default setting.
   - **According to schedule**
     - Select and then choose a schedule from the dropdown list.
   - **Never**
     - Select to make sure this user never receives alarm notifications. This is a useful option when a user is away on holiday.
3. Select Save.
More Information

- Enabling or Disabling Schedules (page 110)
- Creating Schedules (page 129)

8.3 Views

Views are an easy way for users to monitor important Locations, or group Location data according to job function.

Views can be set up to display Location status on a new dashboard image, or to display a trend graph for select Locations (useful when presenting a view on a remote display terminal).

Create new views in Views Manager and access them in the Overview window.

8.3.1 Your Views

Each time you log in to viewLinc, the Overview window displays your views. Views are your custom collections of Locations created in Views Manager. You may also see views created by others that you are permitted to access.

Use views to:

- Monitor current conditions at the Locations in a view (Status tab).
- Display a dashboard representing a view (Dashboard tab).
- Respond to alarms or generate alarm reports for all Locations in a view (Location Alarms tab).
- Create a trend based on data collected at all Locations in a view (Trend tab).
8.3.2 Creating Views

The Zone and Location tree structure in Sites and Sites Manager can only be modified by a viewLinc Administrator (with Manage Sites right). All other viewLinc users can create views to customize the display of important Locations.

1. In Views Manager select Add > Add View.
2. In the Add View window, type a name for the view.
3. Select Add > Add Locations.
4. Select Locations you want to include in the view:
   • Select all Locations in a Zone (select the Zone checkbox), or select individual Locations in one or more Zones.
   • Only the Locations within a selected Zone are included in a view. You can organize Locations within a view using folders.
5. Select Add.
6. Save the View.

If you are a member of a group with Manage Views right, you can also share your view.

More Information
- Sharing Views (page 133)

8.3.3 Organizing Locations in a View

1. In Views Manager on the Views tree, select a saved view.
2. Select Add > Add Folder.
   The menu is not active if there are unsaved changes in the tree.
3. In the Add Folder window, type a name for the folder.
4. Select an icon to display on a dashboard.
5. Select Add.
6. On the Views tree, drag Locations into the new folder.

8.3.4 Sharing Views

Manage Views

Allow other users to access a view you create. When a user logs in, new shared views display automatically in the Overview window. Sharing views is an easy way to customize a remote display.

Only the Locations the group has permission to view will be visible in the view.
1. In **Views Manager** in the **Views** tree select a view.

2. On the **Permissions** tab select **Add**. The **Add Permissions** window appears.

3. Select one or more groups and then select the permission level you wish to give:
   - **View**
     - Allow group to see this view in their **Overview** window.
   - **Full Control**
     - Allow group to modify the view in **Views Manager**, or share the view with others.

4. Select **Save**.

**More Information**

- Creating Views for Remote Display (page 134)

### 8.3.5 Setting Default View

If you have been assigned views by others or have set up your own views, you can identify one as the default view. The default view opens automatically each time you log in, and displays the current dashboard (if one has been added).

1. In **Overview** on the **Views** tree, select a view.

2. Select **Options > Set as Default View**. A star icon 🌟 appears on your default view.

   To quickly find your default view, click the **Select Default View** toolbar icon, 🌟.

   To change the default view, simply select a new view in the **Views** tree, and select **Options > Set as Default View**.

Each user can specify a different default view.

### 8.3.6 Creating Views for Remote Display

**Manage System, Manage Views**

Create a view to control the content displayed on a stand-alone or wall-mounted display terminal.

1. Create a new view which includes the Zones and/or Locations you want to see on the display terminal.

2. Create a new group with **Acknowledge Alarms** permission for the Zones and/or Locations in the view.

3. Share the view with the group.

4. Make sure that there is at least one user in the group. This user account will be used to log in to the remote display. You can create a remote display-only user and add the user to the new group.

5. Set up the view as the user's default view.
If remote display power is interrupted, the logged in user’s default view automatically reconnects without requiring another log in.

More Information
- Setting Default View (page 134)

8.4 Signal Towers

Integrate your viewLinc system with a Patlite signal tower to ensure wide area visual and audible alarm status recognition (templates for supported Patlite model included in viewLinc). You can use a signal tower to indicate threshold, device or system alarm severity to a widespread audience. Several configuration options are built into viewLinc and include:

- Choose the type(s) of alarms you want to trigger signal tower alarming.
- Select colors to reflect priority status.
- Modify color formats to accommodate tower position (ceiling-, wall- or floor-mounted).
- Choose a sound pattern or turn sound off.

To learn more about your light tower color scheme and sound options, refer to the documentation provided with the device.

8.4.1 Adding Signal Towers

Manage Devices

Connect a signal tower to your network to deliver visual and/or audible notification of an alarm state to a wide area.

1. Connect the signal tower to your network according to the manufacturer’s directions.
2. In Sites Manager on the Signal Towers tab, select Add.
3. Complete the general configuration options:
   a. Description: Type a unique description of the signal tower.
   b. Model: Select the model number.
   c. IP address: Type the numerical IP address assigned to the tower.
   d. Port number: Choose a unique and available port number. The default port number for signal towers is 80.
4. In Alarm Settings, select the alarm types you want to trigger signal tower alarmings.

Use a signal tower to indicate the most critical alarm types, such as threshold and communication alarms.
5. In **Light Settings**, select how to display visual alarms. Only the highest priority alarm condition will display at one time.

   - **All segments**: Use all available color bands to display highest priority alarm (for example, all bands will be red for a High priority alarm)

   ![All segments diagram]

   - **Priority position**: Use two color bands to display a specific priority alarm, lowest priority at the bottom, highest priority at the top of the tower. If there is a High priority alarm, the top two bands display red; if there is only a Medium priority alarm, the two middle bands display orange; if there is only a Low priority alarm, the two bottom bands display yellow.

   ![Priority position diagram]

   - **Priority position - inverted**: It is important to consider the installed position of the signal tower - if it is hanging from the ceiling, the position of alarm colors may need to be top to bottom.

   ![Priority position inverted diagram]

   Priority position bands can help those who are color-blind identify alarm priority.

6. Configure the sound settings:

   - **Sound/When alarms are acknowledged**: Choose to enable tower sound, and whether to stop or continue tower sound signal after an alarm is acknowledged. By default, tower sound turns off only after all alarms are no longer present.

   - **Alarm priorities**: Select all of the alarm priorities that you want to initiate alarm sound on the signal tower. High alarms will always trigger an alarm sound when the sound setting is enabled.

   - **Duration**: Choose the length of time you want the alarm sound to be active, either a continuous loop of the selected sound pattern, or only activate sound for 5 seconds. After 5 seconds the sound will stop, but if the alarm condition still exists during the next system scan, the sound repeats for another 5 seconds.

   - **Sound pattern**: Select a sound pattern. To test the sounds, visit www.patlite.com.
7. **Test** the connection and configuration settings. If the **Test** button remains disabled, check that the IP address and port settings are configured correctly.

Warn your team before testing signal tower performance.

8. To save the new signal tower settings, click **Add**.

9. To connect the signal tower to specific Zones and/or Locations:
   a. On the Signal towers tab select a signal tower, then click the link icon, 
   b. Select the Zones and/or Locations you want to display alarms on the signal tower.

10. Click OK to save the link settings. The linked Locations appear in the Locations column on the Signal Towers grid.

If the signal tower is configured to indicate threshold alarms, make sure that the selected Zones and/or Locations have threshold alarm templates applied.

8.5 **viewLinc** Access through Remote Display or Mobile Device

It is easy to set up **viewLinc** on a remote display terminal, or access the application on a mobile device.

- **Remote Display**: Set up a conveniently located visual display for a specific monitoring environment. A large monitor is best for areas requiring a larger visual display, without having to set up a complete workstation (with tower or keyboard). The remote display screen contains the **Overview** window tabs, with a collapsed **Views** navigation tree. Location information is defined by the default view assigned to the logged in user account.

  If remote display power is interrupted, the logged in user’s default view automatically reconnects without requiring another log in.

- **Mobile Device**: Monitor and acknowledge alarms from your smartphone or tablet.

  **viewLinc** supports Point-of-Sale (POS) terminals. Please contact Vaisala Technical Support for assistance.
8.5.1 Remote Display Requirements

Before setting up a remote display terminal, ensure the following:

- The display hardware meets viewLinc System Requirements.
- The display can connect to a wired keyboard, or has a touchscreen keypad.
- A remote display view is available to the logged in user.

Information

Any viewLinc user can log in to the remote display; however, the displayed data is defined by the view settings available to the logged in user.

More Information

- Hardware Requirements (page 11)
- Creating Views for Remote Display (page 134)

8.5.2 Setting Up Remote Display

Only users assigned to the default viewLinc Administrator group can set up a remote display. Contact your IT network administrator if you require assistance.

1. Set up a remote display view.

2. On the remote display terminal, create a Windows account and set it up for automatic log on (for example, http://support.microsoft.com/kb/324737).

3. In the Windows Startup folder, create a desktop shortcut to open a supported browser. This ensures the browser launches automatically when a user logs in.

4. Disable Windows updates to prevent popups on the display screen.

5. Launch the terminal browser and set the default home page to your viewLinc address, followed by /display (for example, http://viewLinc.com/display).

6. Set the remote terminal browser to work in full screen mode (press F11).

7. Log in to the viewLinc remote display application with the remote user account name and password. The user’s default view opens automatically. These settings are remembered until a user logs out from the display application.

Information

If the display reboots for any reason, the Windows auto logon setting automatically relaunches the browser and logs in as the last user.

More Information

- Creating Views for Remote Display (page 134)
8.5.3 Using viewLinc Mobile

If you have team members working away from your viewLinc network, they can continue to access viewLinc data with viewLinc Mobile. Requires a supported Android browser, or supported iOS Mobile Safari browser.

1. Open a supported Internet browser on your mobile device.
2. Type your viewLinc IP address followed by /mobile. For example, ##.###.##.##/mobile.
3. Select the language you want to display. When changing to a language other than English, the page automatically refreshes to display the new language.
4. Log in with your viewLinc user name and password.
5. Tap Login.

More Information
- Viewing Data with viewLinc Mobile (page 190)

8.6 Setting Up Voice or SMS Web Services

viewLinc Enterprise Server supports voice and/or SMS text messaging via the web service provider, Twilio. With a Twilio account and a network port set up to access the Internet, viewLinc can send default or custom voice calls and/or SMS message notifications to your users, in all supported languages. Your viewLinc users can also acknowledge voice calls and SMS messages received from the web service using their mobile device and PIN.
SMS message delivery is also possible using a modem.

- All voice call/SMS notifications are sent from a single phone number assigned by Twilio.
- Notifications are sent to the phone numbers assigned to your viewLinc users.
- Voice calls or SMS notifications sent to international numbers require additional permissions (see International Voice Dialing Geographic Permissions in Twilio documentation).

Contact a Twilio account representative to make sure the voice and/or web services you require are available in your region.

When and how voice or SMS messages are delivered is determined by the alarm notification template assigned to a Location, a device, or to system alarms.

**Voice Calling Trees**

Multiple users can be called sequentially on a call tree; the order is specified by the corresponding alarm notification template which includes a voice call tree. When a voice notification is triggered by an alarm event, a call initiates and delivers the message to each designated recipient, first to last.

**Setup Steps**

1. Purchase a Vaisala Voice Web Service or Vaisala SMS Web Service feature license (contact www.vaisala.com/contact-us).
2. Add the feature license to viewLinc Enterprise Server.
3. Sign up for a free trial Twilio account (www.twilio.com) to obtain a phone number and configuration information required to enable the voice calling and/or SMS web service feature in viewLinc. Once you determine your messaging volume needs, simply convert your trial account to a paid subscription.
4. Configure voice and/or SMS web services in viewLinc. Contact your IT administrator to ensure your network has an Internet-accessible port available.
5. Create an alarm notification template which includes one or more voice call or SMS web service notification recipients.

**More Information**

- Entering New License Key (page 114)
- Configuring Voice Call Web Service (page 120)
- Configuring SMS Settings (page 118)
- Creating Alarm Notification Templates (page 98)
8.7 Vaisala OPC UA Server

Vaisala OPC UA Server is built on an industry standard tool preconfigured to bring real-time and historical data from viewLinc into your existing systems, such as data historians, manufacturing execution, reporting, or building automation systems. By installing the stand-alone Vaisala OPC UA Server software, you can leverage your viewLinc data without extensive validation or complex programming.

Before installing Vaisala OPC UA Server software, the following setup steps must be completed in viewLinc:

Table 19 Connecting to Vaisala OPC UA Server

<table>
<thead>
<tr>
<th>Setup Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vaisala OPC UA Server license key added to viewLinc. The same license key is entered during Vaisala OPC UA Server installation.</td>
</tr>
<tr>
<td>A dedicated group and user configured in viewLinc. The dedicated group must have View permission to access the required Zone and/or Location data. The user account is used only to transfer data to the Vaisala OPC UA Server so that activity between viewLinc and the Vaisala OPC UA Server can be traced clearly in the Events log.</td>
</tr>
<tr>
<td>viewLinc hostname identified, or IP address (a recognized certificate hostname is required if your network requires certificate authentication).</td>
</tr>
<tr>
<td>viewLinc port number identified (default is 443).</td>
</tr>
<tr>
<td>Vaisala OPC UA server port number identified (default is 55000).</td>
</tr>
</tbody>
</table>

1) Your security policy determines whether you are required to use strict or relaxed certificate authentication. If you choose strict security (recommended), you must install trusted security certificate and key files. If you prefer to use relaxed security, you can have the wizard generate VOPC UA Server-signed certificate and key files during installation.

If you would like to purchase a license for Vaisala OPC UA Server, please contact your local sales representative:

http://www.vaisala.com/contact
More Information

- Entering New License Key (page 114)
- Groups and Users (page 73)
- Security Requirements (page 10)
9. Daily Tasks

To help you become more familiar with the viewLinc workspace, it is recommended that you watch the tour, Using viewLinc (available on the viewLinc toolbar, under the Help menu).

Several tours are available and demonstrate how to perform daily tasks (Help > Tours).

9.1 Desktop Orientation

viewLinc is designed for easy identification of the monitored areas of your company—Zones and Locations. All the Zones and Locations you are permitted to view are visible in the Sites window, on the Zones and Locations navigation tree.

Tabs in the Sites and Overview windows are used to look at data in different ways:
The Zones and Locations tree can be expanded or collapsed to reduce visual clutter, and can be further customized into views. Views can be set up to contain only the Locations that are most important to you.

More Information

• Your Views (page 132)

9.1.1 Icons

Table 20  Home Screen Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>Amount of time that has passed since receiving the last data transmission from any device. When view is regularly updating, icon is green. When view has not been able to update, icon is red.</td>
</tr>
<tr>
<td>🔔</td>
<td>Number of alarms currently active, on Locations user is permitted to view. Click to open the Alarms window and acknowledge alarms.</td>
</tr>
<tr>
<td>🔊</td>
<td>An audible alarm is active. Click to cancel the sound and open the Alarms window.</td>
</tr>
<tr>
<td>🤔</td>
<td>Open online Help or watch a tour.</td>
</tr>
<tr>
<td>⚙️</td>
<td>Log out or open the Users and Groups window to edit your personal details. Requires Manage System right.</td>
</tr>
<tr>
<td>UTC+7</td>
<td>Time zones in viewLinc are expressed in terms of an offset from UTC (Coordinated Universal Time). UTC is the time standard used to synchronize the clocks of computers over the internet.</td>
</tr>
</tbody>
</table>

Table 21  Window Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>⌚️</td>
<td>Refresh - View the most current system modifications or data updates.</td>
</tr>
<tr>
<td>🔎</td>
<td>Find in Tree - Highlight the selected Location in the Zones and Locations navigation tree.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon Description" /></td>
<td>Quick Reports - Generate an Alarm-, Location History-, or System report for the selected Zone or Location.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon Description" /></td>
<td>Measurement type: Temperature</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon Description" /></td>
<td>Measurement type: Humidity</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon Description" /></td>
<td>Measurement type: Other</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon Description" /></td>
<td>Measurement type: Boolean</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon Description" /></td>
<td>An unlinked channel or Location displays in gray, italicized text.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon Description" /></td>
<td>A deactivated Location displays in red, strike-out text.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon Description" /></td>
<td>Vaisala device icon: RFL100-series data logger</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon Description" /></td>
<td>Vaisala device icon: DL data logger</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon Description" /></td>
<td>Vaisala device icon: HMT140-series data logger</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon Description" /></td>
<td>Vaisala device icon: 300-series transmitter</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon Description" /></td>
<td>Vaisala or third-party Modbus device</td>
</tr>
<tr>
<td><img src="image13.png" alt="Icon Description" /></td>
<td>Host icon: Access point</td>
</tr>
<tr>
<td><img src="image14.png" alt="Icon Description" /></td>
<td>Host icon: Device Host server</td>
</tr>
<tr>
<td><img src="image15.png" alt="Icon Description" /></td>
<td>viewLinc Enterprise Server (ES)</td>
</tr>
<tr>
<td><img src="image16.png" alt="Icon Description" /></td>
<td>Alarming paused</td>
</tr>
<tr>
<td><img src="image17.png" alt="Icon Description" /></td>
<td>Group</td>
</tr>
<tr>
<td><img src="image18.png" alt="Icon Description" /></td>
<td>Calibration alarm</td>
</tr>
<tr>
<td><img src="image19.png" alt="Icon Description" /></td>
<td>Communication alarm</td>
</tr>
<tr>
<td><img src="image20.png" alt="Icon Description" /></td>
<td>Configuration alarm</td>
</tr>
<tr>
<td><img src="image21.png" alt="Icon Description" /></td>
<td>Validation alarm</td>
</tr>
</tbody>
</table>

### 9.1.2 Searching for Zones and Locations

If you have a long list of Zones and Locations, finding a specific Location may be time-consuming.

**Full search**

All users have access to the `Search` field at the top of the *Zones and Locations* navigation tree:
• In Sites on the Zones and Locations tree, type your search criteria, then click the magnifying glass icon to activate the search (use the to clear the search field).

Search tips

• To search for a Location containing the word ‘South’, type South (viewLinc searches for Zones or Locations containing the word South, or combination phrases, such as South-West or Fridge: South Corner).
• To search for a Zone starting with the term, ‘Room’, type: Room*.
• To search for a Zone starting with the term, ‘Room’, and all Locations starting with the term, ‘Temp’, type: Room*/Temp*.
• To search for a term with a single character difference, such as ‘temperature’ or ‘température’, type: temp?rature.

9.1.3 Working with Columns

Several viewLinc windows present Location details in tables, with a customizable set of columns.

9.1.3.1 Sorting Column Content

Depending on the column contents, you can automatically sort alphabetically or numerically.

1. Hover your mouse over a column heading, then click the down arrow.
2. On the menu that appears, select Sort Ascending or Sort Descending (you can also click on any column header to sort all the rows alphabetically in ascending or descending order).

9.1.3.2 Changing Column Order

Use your mouse to move columns further left or right.

1. Open a window with movable columns: Overview, Sites, Alarms, Views Manager, Events, Users and Groups, and Sites Manager.
2. Select a column header name and click and hold to drag it right or left.
3. Release the column and drop it when the green drop indicator arrows appear:

If the drop indicator does not appear, the column is in a fixed position and cannot be moved.
9.1.3.3 Showing or Hiding Columns

1. Hover your mouse over a column heading, then click the down arrow, ▼.

2. On the menu that appears, select Columns, then select columns to display or deselect columns to hide.

3. Click outside the column list, or press ESC to close the list.

9.2 Monitoring Conditions

To help you monitor only those Locations which are important to you, open the Sites or Overview window to view active threshold and device alarms. Alarms display only for the Locations or Zones you have permission to view.

You may be required to act upon an alarm in one of several ways:

• Threshold alarms can be acknowledged if you have acknowledge alarms permission on the Location.
• Device alarms can be acknowledged if you have acknowledge alarms permission for at least one Location linked to the device.

All active alarm types, including system alarms, display in the Alarms window. Alarms display only for the Locations or Zones you have permission to view.

More Information

• Types of Alarms (page 79)
9.2.1 Identifying Active Alarms

All active alarm types display in the Alarms window—threshold alarms, device alarms, and system alarms; however, only the alarms for the Locations you are permitted to view are visible. Use the Alarms window to acknowledge alarms, and print or export alarm reports.

You can view and acknowledge threshold and device alarms in the Sites or Overview windows, on the Location Alarms tab.

Active and Inactive Alarms

- Check the Status column to determine if an alarm is in an active alarm state, or was in an alarm state and is now inactive.
- Both active and inactive alarms that require an acknowledgement display in the grid.
- Inactive alarms that do not require acknowledgement do not display in the grid.
- The option to acknowledge all inactive alarms is restricted to members of the default viewLinc Administrator’s group.

Alarm Acknowledgement

- Check the Acknowledgement column to determine if an alarm requires acknowledgement, and if it has been acknowledged.
- Threshold alarms can be acknowledged if you have acknowledge alarms permission for the Location.
- Device alarms can be acknowledged if you have acknowledge alarms permission for at least one Location linked to the device.
- System alarms can only be acknowledged by members of the default viewLinc Administrators group.

9.2.2 Using Status Tab

To review the severity levels of active threshold and device alarms, select the Status tab in the Sites or Overview.

Table 22  Status Tab Columns

<table>
<thead>
<tr>
<th>Column</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Current threshold condition (this column cannot be removed)</td>
</tr>
<tr>
<td>Type</td>
<td>Value being measured (this column cannot be removed)</td>
</tr>
<tr>
<td>Threshold Status</td>
<td>Summary of all active threshold alarms</td>
</tr>
<tr>
<td>Device Status</td>
<td>Connection status with viewLinc</td>
</tr>
<tr>
<td>Value</td>
<td>Current measured value</td>
</tr>
<tr>
<td>Timestamp</td>
<td>Time of most recent recorded value</td>
</tr>
<tr>
<td>Column</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Threshold Summary</td>
<td>Description of threshold measurement criteria</td>
</tr>
<tr>
<td>Location ID</td>
<td>System-generated ID for reference purposes.</td>
</tr>
<tr>
<td>Location Path</td>
<td>Folder</td>
</tr>
<tr>
<td>Location Description</td>
<td>User-defined description</td>
</tr>
<tr>
<td>Device ID</td>
<td>System-generated ID for reference purposes.</td>
</tr>
<tr>
<td>Device Serial Number</td>
<td>Device-specific serial number</td>
</tr>
<tr>
<td>Device Address</td>
<td>Device Host location</td>
</tr>
<tr>
<td>Device Description</td>
<td>User-defined description</td>
</tr>
<tr>
<td>Sample Interval</td>
<td>Device-configured sample timing</td>
</tr>
<tr>
<td>Battery Level</td>
<td>Estimated remaining battery life</td>
</tr>
<tr>
<td>Signal Quality</td>
<td>Wireless reception quality</td>
</tr>
<tr>
<td>Channel ID</td>
<td>Device-configured channel ID</td>
</tr>
<tr>
<td>Channel Number</td>
<td>Device-configured channel number recording data for this Location</td>
</tr>
<tr>
<td>Channel Description</td>
<td>User-defined channel description</td>
</tr>
</tbody>
</table>

### 9.2.3 Triggering Threshold Alarms

When Location conditions (such as temperature and relative humidity) fall outside set threshold limits (specified in a threshold alarm template) a threshold alarm is triggered. When you apply a threshold alarm template to a Location, you can also add an alarm notification template to define who should be notified in the event of an alarm condition.

viewLinc can be configured to issue a notification at the first sign of a problem, sending an alert to a mobile device or computer display, as an SMS text, email or voice call notification. These notifications can also be scheduled for delivery on a specific day, time period, or according to a user’s work schedule.

You can also set up threshold alarm color settings to provide a visual indication in the viewLinc display that an alarm condition is a mild concern or an extreme concern (colors are preset according to low to extreme concern).

### 9.2.4 Responding to Alarms

The alarms icon on the viewLinc header bar indicates the number of active alarms, 📣. To view all active alarms, click the icon to open the **Alarms** window.

If you are set up to receive audible alarms on your desktop, click the active alarm sound icon to turn off, 🎧.
You may receive an alarm notification in a variety of ways, depending on how the system administrator has configured your system:

- **Email/SMS/Voice**: Receive notifications when an alarm condition is present, once or repeatedly, according to the alarm notification template assigned to a Location or a device.
- **Command**: An application may activate an external device or emit an audible alarm. For example, when an alarm condition occurs a command could activate a light or buzzer, or a have a computer page or phone a particular number.
- **Signal tower**: Your system may include a signal tower to indicate an alarm condition across a wide area with light or sound.

More Information

- Creating Alarm Notification Templates (page 98)

### 9.2.5 Viewing Conditions on Dashboards

Dashboard images are added to Zones and/or Locations by users with **Manage Sites** right and **Full Control**permissions. Dashboard images are added to views by users with **Manage Views** right. All users can see site dashboards in the **Sites** window, and see view dashboards in the **Overview** window. Locations on a dashboard may display alarm status with color coded icons or background color.

<table>
<thead>
<tr>
<th>Table 23</th>
<th>Dashboard Alarm Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>No alarm condition detected</td>
<td>Green</td>
</tr>
<tr>
<td>High priority alarm</td>
<td>Red icon, or</td>
</tr>
<tr>
<td></td>
<td>with red background</td>
</tr>
<tr>
<td>Medium priority Alarm</td>
<td>Orange</td>
</tr>
<tr>
<td>Low priority alarm</td>
<td>Yellow</td>
</tr>
<tr>
<td>Information priority alarm</td>
<td>Blue</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 24</th>
<th>Dashboard Navigation Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Refresh/Undo" /></td>
<td><strong>Refresh/Undo</strong>: Update data readings, or if there are unsaved changes to the dashboard, the icon changes to allow you to undo all unsaved changes.</td>
</tr>
<tr>
<td><img src="image" alt="View Trend" /></td>
<td><strong>View Trend</strong>: View a Location’s historical data as a trend in a new browser window.</td>
</tr>
</tbody>
</table>
9.2.6 Viewing Dashboard Location Trends

1. In the Sites window or the Overview window, select a Zone or Location using a dashboard image.
2. On the Dashboard tab, select a current data reading.
3. Select the View Trend toolbar button (or right-click on the data reading and select View Trend). In the open trend window, you can modify the trend start and end times, and the graph contents.

9.2.7 Finding Linked Dashboard Location

On any dashboard tab (Sites, Sites Manager, Overview, Views Manager), you can use the Find Linked Location tool help you identify your dashboard Locations in the Zones and Locations tree, or the Views tree.

1. In Sites select a Zone or Location which is using a dashboard image (or in Views Manager on the Views tree, select a view).
2. On the Dashboard tab, select a current data reading.
3. Select the Find in Tree toolbar button (or right-click on the dashboard data reading). A yellow highlight bar appears temporarily in the Zones and Locations tree (or Views tree) to indicate the corresponding Location.

9.2.8 Printing Current Alarm Data

In the Alarms, Sites or Overview window, you can print current alarm data directly to your printer.

1. To print:
   - In the Alarms window, select Print. Choose your desired print settings and then print.
   - In the Sites or Overview window on the Location Alarms tab, select one or more active alarms, then select Print. Choose your desired print settings and then print.
9.2.9 Exporting Current Alarm Data

In the Alarms, Sites or Overview window, you can export the current alarm data to a spreadsheet (.tsv). In the spreadsheet format, you can modify how you want the information to display, to meet your company’s reporting requirements.

1. To export active data in the Alarms window, select Export to Excel.
   A list of all active alarms export to a .tsv format file in a spreadsheet program (default spreadsheet software is set on user PC).

2. To export active data in the Sites window:
   a. On the Zones and Locations tree, select one or more Locations or Zones with currently active alarm conditions.
   b. On the Location Alarms tab select Export to Excel. A list of all active alarms export to a .tsv format file in a spreadsheet program.

3. To export active data in the Overview window:
   a. On the Views tree, select one or more views containing Locations with currently active alarm conditions.
   b. On the Location Alarms tab select Export to Excel. A list of all active alarms export to a .tsv format file in a spreadsheet program.

4. The file download (.tsv) appears in the status bar at the bottom of the display window. Double-click the file icon to open the activealarms.tsv file in the spreadsheet program of your choice.

5. At the prompt, select Save (the file is saved to your default downloads folder) or Open. If Windows does not recognize the file format, select Excel from your Programs folder to view the file and make changes.

More Information

‣ Creating Alarm Reports (page 185)

9.3 Receiving Alarm Notifications

If you are a member of a group that is responsible for responding to alarms, you may be notified of an alarm condition or event in a number of ways, such as:

| 📧 or 🔗 | Receive an email or SMS notification (SMS from web service provider or modem) |
| 📣 | See a visual indicator in viewLinc |
| 🔊 | Hear an audible area alarm (browser or signal tower) |
| ⚡ | See a visual area alarm (signal tower) |
| 📞 | Receive a voice call |
You can respond to any alarm by acknowledging the alarm in viewLinc (Overview, Sites, or Alarms window). If your system is set up to accept acknowledgments remotely, you can use a mobile device to reply to an email, SMS or voice notification using a recognized phone number and PIN.

### 9.3.1 Acknowledging Alarms

An acknowledgement indicates to the viewLinc system and others that an alarm condition is recognized. Details provided during acknowledgement about the steps taken to correct the alarm condition, and any comments, are tracked as an event in the **Events** window.

If you work remotely, alarms can be acknowledged with a mobile device.

> Only viewLinc users with Acknowledge Alarms permission (or higher) for the Locations where an alarm is occurring can acknowledge alarms.

#### More Information

- Acknowledging an Alarm with viewLinc Mobile (page 193)

#### 9.3.1.1 Acknowledging Alarm Notifications

To allow users to acknowledge alarm notifications received by email, SMS, or voice call, your viewLinc system must allow remote acknowledgement and users must have an assigned phone number and PIN.

1. Open or answer the alarm notification.
   - Email notifications are sent from the viewLinc server administrator account (for example, viewLinc.boulder@companyemail.com).
   - SMS notifications are sent from an SMS modem number or SMS web service provider number.
   - Voice call notifications are sent from the designated web service provider number.
2. To acknowledge an email alarm notification, send a reply which includes the default subject line (with ticket number), and type your PIN in the body of the message.

Sending a reply without a PIN in the email message body area or the ticket number in the subject line does not acknowledge the alarm.

3. To acknowledge an SMS alarm notification, send a reply from your phone which includes the ticket number and your PIN.

Only SMS replies sent from your recognized phone number and PIN will acknowledge an alarm.
4. To acknowledge a voice call notification, follow the prompts:
   • Press 1 to repeat the message.
   • Press 2 to acknowledge the alarm and enter your PIN (this option is available if voice
     acknowledgement is enabled in System Preferences).
   Once a voice call alarm notification is acknowledged, call tree
   notifications stop.

   • Press 3 to confirm receipt of an alarm and enter your PIN (this option is available if
     voice acknowledgment is not enabled in System Preferences, or the alarm was
     already acknowledged using a different method, or if the alarm condition is no longer
     present).
   Alarm acknowledgement in viewLinc does not prevent voice
   notifications from being sent.

   If you enter an incorrect PIN, or enter your PIN using an unrecognized
   phone number, you must log into viewLinc to acknowledge the alarm.

9.3.1.2 Acknowledging Alarms in Sites or Overview

1. In the Sites or Overview window select the Location Alarms tab.
2. Review the list of all active alarms (Status column).
3. Use the Acknowledgement column to identify alarms that require acknowledgement. To
   acknowledge multiple alarms, press the CTRL or SHIFT keys while you select multiple
   alarms.
4. Select Acknowledge (or right-click and select Acknowledge).
5. In the **Acknowledge Alarms** window, add a description of the actions taken to correct the alarm condition and any additional comments. You can select a comment from the predefined comments drop-down list, if there are any available, or add your own comment in the text box. For example, if you receive a high temperature alarm for a refrigeration facility and notice that a refrigerator door has been left open, close the door and describe this action in the **Acknowledge Alarms** window.

6. Select **Acknowledge**. Your comments and actions are added to the event log and the **Acknowledge Alarm** prompt closes. Locations are updated with this change in status, as well as the **Acknowledgement** column in the **Alarms** window.

### 9.3.1.3 Acknowledging Alarms in the Alarms Window

The **Alarms** window displays all alarm types, listed in priority order. Device and system alarms are visible to all users, only alarms for Locations you are permitted to view are visible.

- **Only a member of the default viewLinc **Administrators** group can acknowledge system alarms.**

1. In the **Alarms** window, review the list of all active alarms (**Status** column).
2. Use the **Acknowledgement** column to identify alarms that require acknowledgement. To acknowledge multiple alarms, press the **CTRL** or **SHIFT** keys while you select multiple alarms.
3. Select **Acknowledge** (or right-click to select Acknowledge).
4. In the **Acknowledge Alarms** window, type the actions taken and add a comment. You can select a comment from the predefined comments drop-down list, if available, or type your own comment in the text box.
5. Select **Acknowledge**. Your comments and actions are added to the event log. Locations are updated with this change in status, as well as the **Acknowledgement** column in the **Alarms** window.

### 9.3.1.4 Acknowledging System Alarms

System alarms (database or event log validation alarms) can only be acknowledged in the **Alarms** window. System alarms remain in the **Alarms** window until they are acknowledged.

- **You must be a member of the viewLinc **Administrators** group to use the acknowledge all system alarms function.**

1. In the **Alarms** window on the alarms grid, right-click on a system alarm and select **Acknowledge**.
2. In the **Acknowledges Alarms** window indicate any action taken, select a predefined comment, if available, or type any additional comments about why you are acknowledging an inactive alarm.

3. Select **Acknowledge**.

### 9.3.1.5 Acknowledging All System Alarms

1. In the **Alarms** window select **Acknowledge > Acknowledge All System Alarms**. Multiple Location selection is not required.

2. In the **Acknowledges Alarms** window indicate any action taken, select a predefined comment, if available, or type any additional comments about why you are acknowledging inactive alarms.

3. Select **Acknowledge**.

### 9.3.2 Acknowledging Inactive Alarms

Some companies may require you to acknowledge inactive alarms. Inactive alarms indicate that an alarm was triggered, but the alarm condition is no longer present.

To acknowledge inactive threshold or device alarms, you can use the **Alarms, Sites** or **Overview** windows.

> **i** Only a member of the default viewLinc **Administrators** group can acknowledge all inactive alarms.

#### 9.3.2.1 Acknowledging an Inactive Alarm in Alarms Window

1. In the **Alarms** window on the alarms grid, right-click on an inactive alarm and select **Acknowledge**.

2. In the **Acknowledges Alarms** window indicate any action taken, select a predefined comment, if available, or enter any additional comments about why you are acknowledging an inactive alarm.

3. Select **Acknowledge**.

#### 9.3.2.2 Acknowledging All Inactive Alarms in Alarms Window

1. In the **Alarms** window select **Acknowledge > Acknowledge All Inactive Alarms**. Multiple Location selection is not required.

2. In the **Acknowledges Alarms** window indicate any action taken, select a predefined comment, if available, or type any additional comments about why you are acknowledging inactive alarms.

3. Select **Acknowledge**.
9.3.2.3 Acknowledging an Inactive Alarm in Sites Window

1. In the Sites window on the Zones and Locations tree, select a Zone.
2. On the Location Alarms tab in the alarms grid, right-click on an inactive alarm and select Acknowledge.
3. In the Acknowledge Alarms window indicate any action taken, select a predefined comment, if available, or type any additional comments about why you are acknowledging an inactive alarm.
4. Select Acknowledge.

9.3.2.4 Acknowledging an Inactive Alarm in Overview Window

1. In the Overview window on the Views tree, select a view.
2. On the Location Alarms tab in the alarms grid, right-click on an inactive alarm and select Acknowledge.
3. In the Acknowledge Alarms window indicate any action taken, select a predefined comment, if available, or type any additional comments about why you are acknowledging an inactive alarm.
4. Select Acknowledge.

9.3.3 Responding to Audible Alarms

If your system generates audible alarms, they are only received by users logged in to viewLinc with the audible alarm preference enabled in their user profile. The user PC must have volume turned on.

When an audible alarm is turned off, it is not recognized in viewLinc as an acknowledgement of the alarm. Audible alarm activation and cancellation are not tracked in the events log.

1. To cancel an active audible alarm, select the red audible alarm icon at the top of the viewLinc screen.
2. To cancel an active audible alarm and acknowledge the alarm:
   a. Select the red audible alarm icon at the top of the viewLinc screen. The icon changes to an alarm icon.
   b. Select the alarm icon to open the Alarms window.
   c. Locate the alarm in the alarms table and then select Acknowledge > Acknowledge Alarm.
3. Complete the Acknowledge Alarms window.

More Information

- Adding Signal Towers (page 135)
9.4 Pausing Alarms

To avoid receiving unnecessary threshold or device alarm notifications when moving devices, or if a known situation will result in conditions exceeding set thresholds, you can pause threshold alarming on one or more Locations, or device alarming on a single device or all devices connected to a host.

Paused alarms reactivate automatically after 24 hours, if not resumed manually before that time. Data collection continues during a pause period at all linked Locations.

You require Configure Alarms permission for the Locations you want to pause. Only members of the Administrators group can pause host alarms.

How is this different from disabling an alarm?
Threshold and device alarms remain disabled until manually set back to enabled.

9.4.1 Pausing Threshold Alarming

Pause threshold alarming to avoid triggering unnecessary threshold alarms. For example, if you are moving monitored inventory out of one facility and moving it to another, or are bringing in additional inventory and the activity will impact device readings.

When you pause threshold alarming, viewLinc continues to monitor your Location, but ignores all threshold levels. Data continues to be logged on your devices, and device alarming is still active.

You can pause threshold alarms on one or more Locations in the Sites window, or pause all threshold alarms for Locations assigned to a view in the Overview window. If you work remotely, alarms can be paused from a mobile device.

You require Configure Alarms permission for each Location you want to pause alarming.

More Information
- Pausing or Resuming Alarming with viewLinc Mobile (page 192)

9.4.1.1 Pausing Threshold Alarming on a Location

1. In Sites on the Zones and Locations tree select one or more Locations or Zones (CTRL + click).
2. Select Options > Pause Threshold Alarms (or right-click to selectPause Threshold Alarms).
3. In the **Pause Threshold Alarms** window, specify:
   - **Duration**
     Select the length of time you want alarming paused (1 ... 24 hours).
   - **Add comments**
     If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

4. Select **OK**.
   The active alarms list on the **Location Alarms** tab refreshes automatically.

### 9.4.1.2 Pausing Threshold Alarming in a View

1. In the **Overview** window on the **Views** tree, select one or more views (CTRL+click).
2. Select **OptionsPause Threshold Alarms** (or right-click to select **Pause Threshold Alarms**).
3. In the **Pause Threshold Alarms** window, specify:
   - **Duration**
     Select the length of time you want alarming paused (1 ... 24 hours).
   - **Add comments**
     If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

4. Select **OK**.
   The active alarms list on the **Location Alarms** tab refreshes automatically.

### 9.4.2 Pausing Device or Host Alarming

Pause device or host alarming to avoid unnecessary alarms (for example, if you are renovating a controlled space and need to shut down power temporarily). When you pause alarming, viewLinc continues to monitor your Location(s), but ignores all device and host communication interruptions.

Pausing device or host alarms does not interrupt data collection for any linked Locations. You can pause alarms on one or more Locations in the **Sites** window, or pause all Locations assigned to a view in the **Overview** window.

If you work remotely, alarms can be paused from a mobile device.

You require **Configure Alarms** permission for the Locations you want to pause. Only members of the **Administrators** group can pause host alarms.

**More Information**

- Pausing or Resuming Alarming with viewLinc Mobile (page 192)

### 9.4.2.1 Pausing Device Alarming on a Single Location

1. In the **Sites** window on the **Zones and Locations** tree, select a Location.
2. Select **Options > Pause Device Alarms** (or right-click to select **Pause Device Alarms**).

3. In the **Pause Device Alarms** window, ensure you have selected the correct data logger channel, then select **Yes** to continue.
   - **Duration**
     - Select the length of time you want alarming paused (1 ... 24 hours).
   - **Add comments**
     - If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

4. Select **OK**.

---

### 9.4.2.2 Pausing Device Alarming on Multiple Locations

1. In the **Sites** window on the **Zones and Locations** tree, select multiple Locations or Zones (**CTRL**+click), then select **Options > Pause Device Alarms** (or right-click to select **Pause Device Alarms**).

2. In the **Pause Device Alarms** window, ensure you have selected the correct data logger channel, then select **Yes** to continue.
   - **Duration**
     - Select the length of time you want alarming paused (1 ... 24 hours).
   - **Add comments**
     - If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

3. Select **OK**.

---

### 9.4.2.3 Pausing Device Alarming in a View

1. In the **Overview** window on the **Views** tree, select one or more views (**CTRL**+click).

2. Select **Options > Pause Device Alarms** (or right-click to select **Pause Device Alarms**).

3. In the **Pause Device Alarms** window, select **Yes** to continue.
   - **Duration**
     - Select the length of time you want alarming paused (1 ... 24 hours).
   - **Add comments**
     - If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

4. Select **OK**.

---

### 9.4.2.4 Pausing Host Alarming

1. In the **Sites** window on the **Zones and Locations** tree, use your mouse to select a Location then select **Options > Pause Host Alarms** (or right-click to select **Pause Host Alarms**).
2. In the **Pause Host Alarms** window, select **Yes** to continue.

   **Duration**
   Select the length of time you want alarming paused (1 ... 24 hours).

   **Add comments**
   If required, add a reason for pausing threshold alarms using a predefined comment (if available), or type your own notes in the text box.

3. Select **OK**.

### 9.4.3 Resuming Threshold, Device or Host Alarming

You can resume alarming on one or more Locations in the **Sites** window, or resume alarming for Locations assigned to a view in the **Overview** window.

You require **Configure Alarms** permission for each Location you want to pause alarming.

1. In the **Sites** window on the **Zones and Locations** tree, select the Location or Zone which currently has alarming paused. Or, in the **Overview** window on the **Views** tree, select a view which currently has alarming paused.

2. Select **Options > Resume Threshold Alarms, Resume Device Alarms, or Resume Host Alarms** (or right-click to select **Resume Threshold Alarms, Resume Device Alarms, or Resume Host Alarms**).

### 9.5 Tracking Events

Use the **Events** window to analyze events and determine when and where particular problems occurred, or to diagnose a situation that requires troubleshooting. All viewLinc system activity is treated as an event, and all events are tracked in the events log. Data tracked as an event is different from monitored data logged in a device. Here are some key differences:

- Events occur within the viewLinc system: alarms, alarm acknowledgements, system configuration changes, general system notifications.
- Devices track the changes within the environment being monitored: temperature, relative humidity, air pressure, or voltage.

To ensure viewLinc continuously monitors and stores event log history, event validation alarms notify you if the viewLinc event log has been tampered with externally.

### 9.5.1 Viewing Events

The **Events** window displays the event log, a text-based listing of all event types—alarms, device changes, system updates—occurring with the software or affecting devices on your system.
1. Open the **Events** window.
2. To view events during a specific period, select **Edit Duration**.
3. Specify the time frame.

   ![Edit Duration](image)

   **Show events for/ending at**
   Choose a time frame with an end date.

   **Show events from/to**
   Type a specific date and time, or use the calendar buttons to make your selection.

4. To refine the displayed events, select **Show Advanced Filters**.
5. Select from the available filters.
   - **Category**
     Select one or more types of events to include in the export.
   - **Locations**
     Select the Zones and/or Locations to include.
   - **Groups and Users**
     Show events recorded by selected groups or users.
6. Select **Apply Filters**. To reset filters, select **Clear**.

   ![Lightbulb](image)

   After setting filters, you can use the **Search** field to display only events acknowledged by specific users or groups, or only events occurring at a specific Location.

7. To view additional event information, such as comments and details added to custom events, double-click an event to open the **Event Details** window.

   Event details can be used to review more specific information about why an alarm event occurred, or to see comments entered.

### 9.5.2 Adding Comments to Events

You may want to add comments to an event log entry to provide details about why an event occurred or what was done in response to an event or problem.
1. In the Events window, select an event, then select Add Comment.
2. In the Add Comment window, select from the list of predefined comments (if available), or type your own comment.
3. Select Save.

### 9.5.3 Viewing Comments to Events

1. In the Events window, select a row containing an event (a comment icon appears in the Comments column).
2. Double-click the event row.
3. In the Event Details window, comments appear on the last line of the grid.


### 9.5.4 Adding Custom Events

When you create a custom event (perhaps to indicate a system upgrade), the new event appears at the top of the Events window.

1. In the Events window, select Add Custom Event.
2. Fill in the custom event message and details, then select Save.
   - **Event message**
     Type a short description that will display in the Events window Message column.
   - **Details**
     Type a full description of the custom event (required). This information is included when printing the Event Log report.
3. Save the new event. It appears at the top of the events grid.

### 9.5.5 Printing Event Logs

For record-keeping purposes, you may need to generate a printed record of events. You can generate a standard viewLinc Event Log Report.
1. In the **Events** window, specify parameters for the report:
   a. To choose a preset or custom timeframe select **Edit Duration**: 
      - **Show events for/ending at**
        Choose a timeframe with end date.
      - **Show events from/to**
        Set a specific date and time period, or use the calendar buttons to make your selection.
   b. To refine the report contents, select **Show Advanced Filters**:
      - **Category**
        Check the types of events to include in the report.
      - **Locations**
        Show events occurring at one or more selected Zones and/or Locations.
      - **Groups/Users**
        Show events recorded by selected groups or users.

2. Select **Apply Filters**. To reset filters, select **Clear**.

3. Select **Print**. In a new browser window, a printer-friendly event log report opens.

4. Set your print parameters and print the report (**File > Print**).

### 9.5.6 Exporting Event Logs

You can also export the record details to a spreadsheet (using .tsv format), for custom reporting.
1. In the **Events** window, specify parameters for the report:
   a. To choose a preset or custom timeframe select **Edit Duration**:
      - **Show events for/ending at**
        Choose a timeframe with end date.
      - **Show events from/to**
        Set a specific date and time period, or use the calendar buttons to make your selection.
   b. To refine the report contents, select **Show Advanced Filters**:
      - **Category**
        Check the types of events to include in the report.
      - **Locations**
        Show events occurring at one or more selected Zones and/or Locations.
      - **Groups/Users**
        Show events recorded by selected groups or users.

2. Select **Apply Filters**. To reset filters, select **Clear**.

3. Select **Export**.

4. To open the file, specify the spreadsheet program to use for .tsv files. Exported .tsv files open in read-only mode.

### 9.6 Creating Trends

To better understand condition fluctuations at your Locations, create a trend. Trends display current or historical data readings for one or more Locations in a graphical format.
Table 25  Key Elements in a Trend Graph

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph area</td>
<td>A graphical representation of Location data history.</td>
</tr>
<tr>
<td>Left and right Y-axis</td>
<td>Shows the range of data displayed in the graph. You can modify the scale</td>
</tr>
<tr>
<td>measurement scales</td>
<td>minimum and maximum values.</td>
</tr>
<tr>
<td>X-axis time scale (bottom)</td>
<td>Shows the reporting time frame. Use the forward and back arrows below the</td>
</tr>
<tr>
<td></td>
<td>graph to adjust the reporting timeframe.</td>
</tr>
<tr>
<td>Location lines</td>
<td>Indicate path of historical measurement readings based on a specific date or</td>
</tr>
<tr>
<td></td>
<td>time frame. Move your mouse and hover over a specific point to show the</td>
</tr>
<tr>
<td></td>
<td>specific X- and Y-axis values.</td>
</tr>
<tr>
<td>Threshold lines</td>
<td>Color-coded line (based on threshold setting) to show historical threshold</td>
</tr>
<tr>
<td></td>
<td>values. Move your mouse and hover over a specific point to show the</td>
</tr>
<tr>
<td></td>
<td>specific X- and Y-axis values.</td>
</tr>
<tr>
<td>Locations / Group Statistics</td>
<td>View Location details in separate rows, or group statistics for all</td>
</tr>
<tr>
<td></td>
<td>Locations.</td>
</tr>
</tbody>
</table>

Multi-Location trends can be created in the Sites window or Views Manager window, on the Trend tab. Each trend graph can contain data for up to 16 Locations and up to 4 measurement types.

Use the View Trend toolbar button, available in the Overview window (Status and Dashboard tabs), Sites window (Status tab), and Sites Manager window (Location Properties and Dashboard tabs) for a quick view of a single Location trend.

More Information

- Trend Navigation (page 169)

9.6.1 Building Trends

Compare live data for multiple Locations, and display the data in a graph. You require view permission for all Locations you want to include in the trend graph.

You can build trends in the Sites, Overview or Views Manager windows.
1. In the Sites, Overview or Views Manager window, navigate the Zones and Locations tree and select a Location you want added to the trend. Or, in Views Manager on the Views tree, select a view that contains the Location(s) you want to view as a trend.

2. Select the Trend tab.

3. Use your mouse to drag the selected Location or view to the Trend pane. You can continue to build upon and modify your trend at any time by simply dragging more Locations onto the graph (up to 16 Locations, up to 4 measurement units).

4. To modify the trend start date, select Edit Trend:
   - **Show trend for [time] ending at [date/time]**
     Trends only display data logged up to the current time. You can select a set trend time period up to 1 month prior to the current date/time.
   - **Show trend from [date/time] to [date/time]**
     If you want to see more historical data, select a specific time period to show (you cannot select a future date).
   - **Include real-time samples**
     When checked, this option includes more frequent real-time samples alongside with the logged device data (based on the device sample rate).
   - **Show data markers**
     When checked, this option adds small markers on the trend graph, indicating exactly when the readings took place.
   - **Vertical Axis Scale**
     For each measurement value, you can set the minimum or maximum range you want included in the trend, or choose Auto to include all values.

When you create a trend in Sites or Views Manager window, you can save the trend as a view and share it with team members, or save the graph as a Location history report for future reference.

More Information
- Saving Trends (page 171)

### 9.6.2 Trend Functions

The Trend tab is available in the Overview and Sites windows. Most functions are the same, except where indicated:

- **Refresh**
  Retrieve most recent data readings from server. If Updates on is enabled, the trend graph automatically retrieves data readings every minute.

- **Open trend in new window** (Overview window)
  Opens the trend in a new window.
Save As (Sites window)
Save the current trend graph as a single page Location history report or as a view. To save as a report requires Manage Reports right. To save as a view requires Manage Views right.

Edit Trend
Modify the trend start or end date, set the time duration, select line properties, and specify axis scale values.

Clear Trend (Sites window)
Clear all Location data lines from the trend graph, or clear lines and reset trend graph settings to default.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Use the Locations grid below the trend graph to remove individual Location lines.</td>
</tr>
</tbody>
</table>

Updates on/off
Update real-time data readings, to a maximum trend duration of 7 days.

9.6.3 Trend Navigation
The Trend tab contains navigation controls which allow you to navigate historical data trends and refresh the view as required:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Adjust the trend time frame by increments of 1/4. For example, if you are viewing 6 hours of data, the frame moves forward or back 1.5 hours; if you are viewing 1 month of data, the frame moves forward or back 1 week. The frame can only move forward up to the current time.</td>
</tr>
<tr>
<td></td>
<td>Adjust the trend time frame by a full increment. For example, if you are viewing 6 hours of data, the frame moves forward or back 6 hours; if you are viewing 1 month of data, the frame moves forward or back 1 month. The frame can only move forward up to the current time.</td>
</tr>
<tr>
<td></td>
<td>Show the most recent data (up to current date/time).</td>
</tr>
<tr>
<td></td>
<td>Select this option to continuously update the trend with most current readings (this option has the same effect as pressing the button).</td>
</tr>
</tbody>
</table>
### 9.6.4 Modifying Trends

You can change both the content and the display settings of a trend graph in either the **Sites** window or the **Views Manager** window. You can only modify trend display settings in the **Overview** window.

Trends modified in the **Sites** or **Views Manager** windows can be saved and shared with others.

**More Information**

- Saving Trends (page 171)

#### 9.6.4.1 Showing or Hiding Selected Locations

1. In **Sites** on the **Trend** tab, select **Locations** below the graph.
2. In the **Show** column, select or deselect the Locations to include on the graph. Select **Delete** to remove the Location data from the graph completely.

#### 9.6.4.2 Viewing Trend Max/Min Statistics

1. In **Sites** on the **Trend** tab, select **Group Statistics** below the graph.
2. In the **Group Statistics** tab to see the max/min ranges for all Locations together.
9.6.4.3 Changing Trend Duration/Data/Scale

1. Select **Edit Trend**.
2. To modify trend duration:
   a. Select a preset time range. Graph will display data for the selected time range, prior to the specified end time (default is 6 hours ending at current time).
   b. Select a time period based on specific calendar dates.
3. To modify line properties (by default these options are not selected):
   - **Include real-time samples**
     Update Location trend lines to include both data collected in viewLinc based on viewLinc scan rate, and data reported by a device based on device sample rate.
   - **Show data markers**
     Add points on Location trend lines to indicate when a data sample was recorded.
4. Define the vertical axis scale min/max graph range:
   For each measurement type included in a graph, you can set the minimum and/or maximum value automatically based on actual readings, or set specific min/max values to include in the graph (by default, the min/max settings are automatically generated).

9.6.4.4 Clearing Trend in Sites Window

1. To remove all Location graph lines select **Clear Trend > Delete all Lines**. Trend settings remain intact.
2. To remove all graph lines and return to the default trend settings, select **Clear Trend > Reset to Defaults**.

9.6.4.5 Refreshing Trend Data

1. To refresh trend data:
   - **Show most current data** or **Updates on**
     Select to refresh the graph with most recent data collected by the viewLinc Enterprise Server.
   - **Refresh**
     Select to force retrieval of the most recent data collected by the viewLinc Enterprise Server. If **Updates on** is enabled, the trend graph automatically retrieves real-time data readings every minute.
   - **Updates on/off**
     Select to update trend with real-time data readings, up to a maximum trend duration of 7 days. If the trend duration is set for more than 7 days, the **Updates on** setting is automatically disabled.

9.6.5 Saving Trends

Manage Views, Manage Reports

There are 2 ways to save a trend:
• In the Sites window, save a trend as a view, and share it with other users or groups. Requires Manage Views right.
• In the Sites or Views Manager window, save a trend as a Location History report. Requires Manage Reports right.

### 9.6.5.1 Saving a Trend as a View

1. In the Sites window, create a trend.
2. Select **Save As > View**.
3. Type a name to identify the view, then select **Save**.

Notify your team that the view is available in the Overview window.

### 9.6.5.2 Saving a Trend as a Report

1. In the Sites window or Views Manager, create a trend.
2. Select **Save As > Location History Report**.
3. Type a name to identify the report, then select **Save**.

Notify your team that the report is available in the Reports window.

### 9.7 Viewing Quick Trends

To quickly view Location data in a trend graph use the **View Trend** toolbar button, available in Sites, Sites Manager and Overview windows.

You can view multiple, individual Location trends at once by opening multiple trend view windows.

If you use Internet Explorer, make sure your browser is set up to open new links in a new window or tab (**Tools > Internet options > General**).

**More Information**

- Alarm Notifications (page 96)
- Creating Trends (page 166)
9.7.1 Viewing Quick Trends in Sites Window

1. In the Sites window on the Zones and Locations tree, select a Zone.
2. On the Status tab select a Location, then select the View Trend toolbar button (or right-click to select View Trend).
3. In the open Trend window, you can modify the trend start and end times, and the graph contents.

9.7.2 Viewing Quick Trends in Sites Manager Window

1. In the Sites Manager window on the Zones and Locations tree, select a Zone.
2. On the Location Properties tab select a Location, then select the View Trend toolbar button (or right-click to select View Trend).
3. In the open Trend window you can modify the trend start and end times, and the graph contents.

9.7.3 Viewing Quick Trends in Overview Window

1. In the Overview window on the Views tree, select a view.
2. On the Status tab select one or more Locations, then select the View Trend toolbar button (or right-click to select View Trend).
3. In the open Trend window, you can modify the trend start and end times, and the graph contents.

9.8 Reporting

Using the historical data collected by Vaisala devices, you can automatically create reports to analyze changes in data over a specific period of time, or compare conditions recorded by different devices. Reports can be used to:

- Review data readings for specific monitored areas over selected time periods.
- Obtain summary or detailed alarm history values for one or more Locations, including alarm duration, acknowledgements and corrective actions taken.
- Produce presentation-ready materials, including data, statistics and graphs.
- Deliver data by email on a schedule to specific personnel.

9.8.1 Types of Reports

viewLinc provides a set of default reports to help you easily view data trends or alarm statistics. Users with Manage Reports right can create custom reports to set specific content parameters, and make them easily accessible by others from the Sites and Overview windows.

No specific rights are required to generate reports – any user can generate a report for a Zone or Location to which they have View permission.
- **Alarm reports**: Provide an overview of alarm events over a period of time. Events related to every alarm are grouped together and presented in a readable form.
- **Location History reports**: Provide a detailed history of Location data values presented in both graphical and tabular format.
- **System reports**: Provide overall snapshots of specific system information, such as system configuration, and lists of available templates. You can also generate a system report to list current users and groups, Locations, and permission details.

**More Information**

- Sharing Quick Reports (page 175)

### 9.8.2 Generating Reports

All available reports are listed in the Reports window. The reports available are either default viewLinc reports, reports you have created, or reports that others have shared with you.

Reports are templates, waiting to be populated with generated data. Once a report is generated, open the Downloads tab to find out when the report is ready to print (a generated .pdf file) or export to a spreadsheet (a generated .tsv file).

You can also automatically generate and send a report to an email recipient (.pdf) on a regular schedule. Any sent report can also be downloaded from the Downloads tab.

Generated report content is limited to the Zones and/or Locations you have permission to view. If you require additional Location information in a report, request view permission for the Zone/Location, or ask to receive reports by email.

1. In Reports select a report, then select Generate.
2. Choose a report option:

**PDF (.pdf)**
Choose this option to generate the report according to PDF settings specified in the Scheduled Generation parameters. This option is available for Alarm and Location History reports.

**Excel (.tsv)**
Generate the report in .tsv format.

**Email**
Generate and send report to predetermined list of users or groups, as a .pdf attachment (system reports are only .xls attachments). Once generated, the report is sent according to the report's scheduled generation parameters.

> Automatically generated and emailed report content is generated according to the recipient's language preference.
> • If no language preference is specified for the recipient, the content is generated in the language specified for the report (language can be specified for reports that are automatically generated and saved).
> • If no language is specified for the recipient or the report, the content is generated in the system default language (System Preferences).

3. On the **Downloads** tab, the most recently generated report appears at the top of the list. Once report generation is complete, open or save the report by clicking the link in the **Progress** column.

Manually generated and scheduled reports are available to download for 24 hours, to ensure that any reports auto-generated during off-peak hours remain available in regular work hours.

More Information
- Generating Quick Reports (page 176)
- Viewing Report Downloads (page 176)

### 9.8.3 Sharing Quick Reports

**Manage Reports**

Allow other users to quickly generate a report from the **Sites** and **Overview** windows. Report content is limited to the **Zones and Locations** a user or group has permission to view.

Administrators, users who are part of groups assigned **Manage Reports** right, and report owners can specify which of their reports can be made available as a quick report.

> Quick report content is generated according to the user's logged in language.

1. In the **Reports** window, select a report, then select **Edit**.
2. In the Available as quick report field, select Yes.
3. Save the change.

9.8.4 Generating Quick Reports

A quick report is a report made available to others to generate easily from the Sites or Overview windows. The structure of the report adheres to the structure defined by the report owner, but the content of the report (data) is limited to the Zones and Locations the user is permitted to view.

If you have Manage Reports right, you can make a report available to others as a quick report.

When a user generates a quick report, the content is generated according to the user’s logged in language, even if it is different from their language preference.

1. In the Sites window or Overview window, select one or more Locations or Zones.
2. Select Options > Quick Reports, choose a report type (Alarm, Location History, or System), then select an available quick report.
4. To create a report you can manipulate in a spreadsheet, select Generate for Excel (*.tsv).
5. To send the report to another user, select Generate and Email Report:
   a. Choose the report format.
   b. Type the email address of the recipient, and any additional viewLinc users or groups to whom you want the report sent.
   c. Optional: Modify the Subject and Body fields for the email message.
   d. Select Send.
6. To find out when the report is ready to download and print, open Reports > Downloads.

More Information

- Sharing Quick Reports (page 175)

9.8.5 Viewing Report Downloads

Each time a report is generated the Downloads tab updates to show when the report is available to download and print.

1. In the Reports window, select the Downloads tab.
2. To check the report status, locate your report in the list:

**Generated By**
Identifies the person who initiated the report generation (username), or if it was automatically generated (System).

**Generated As**
Indicates whether the report owner generated the report (report includes all source data), or, if another user generated it as a quick report (report only includes data for the Locations user has permission to view).

**Generated**
When report content was generated, seen as the user's local time.

**Available For**
Indicates remaining time the generated report will be available to download and print. Manually generated and scheduled reports remain available for 24 hours.

To save a report permanently, download and save it before available download time runs out, or edit the report properties to **Autogenerate and save** (requires Manage Reports right).

**Timezone**
The server time zone. If a report you want to see is generated by a server in a different timezone, select your time zone to see reporting details in local time.

**Progress**
Indicates when the report is available to download, queue status, or report generation errors.

**Status**
Indicates whether a scheduled report was saved to a network location or sent to a recipient.

If the report is taking too long to generate, you can click **Cancel** to remove the report from the queue. If a scheduled report is canceled, viewLinc notifies recipients via email.

3. To download and/or print a generated report, in the **Progress** column select the report link and open your downloads folder (or follow the prompt to open or save the file).

### 9.8.6 Deactivating Reports

When you deactivate a report, you prevent it from being used or auto-generated for a specific period of time. When you want to use it again, simply reactivate the report. If you no longer need a report, delete the report (🗑️).

1. In the **Reports** window, select a report.
2. Select **Deactivate**.
9.8.7 Activating Reports

1. In the Reports window, select View > Include Deactivated Reports.

   To sort all deactivated reports to display at the top of the list, select the Active column heading.

2. Select the report you want to reactivate, then select Activate.

9.8.8 Generating Alarm Reports

Default viewLinc alarm reports—Last 8 hours, Last day, Last week—can be generated by all users from the Sites or Overview windows. Additional custom alarm reports are available from these windows if they are set up as Quick Reports.

1. In the Sites window on the Zones and Locations tree, select a Zone or a Location. Hold the [Ctrl] key to select multiple Zones/Locations.

2. Select Options > Quick Reports > Alarm Reports, then select the report type and the output format: .pdf (standard presentation format), .tsv (modifiable format with a spreadsheet program), or send the report as an email attachment (.pdf).

3. To generate and send the report to an email recipient:
   a. Type the email address of the recipient, and any additional viewLinc users or groups to whom you want the report sent.
   b. Optional: Modify the Subject and Body fields for the email message.
   c. Select Send.

4. To find out when the report is ready to download and print, or when it was sent, open Reports > Downloads.

More Information

- Printing Current Alarm Data (page 151)
- Exporting Current Alarm Data (page 152)
- Creating Custom Reports (page 178)

9.9 Creating Custom Reports

Create a new Location History, Alarm or System report to include the reporting information you need.

You can also specify:

- A user or group authorized to modify the report
- The time zone to use when generating data
- The groups who can receive the report by email
• A schedule to generate the report automatically
• Availability as a quick report

You require Manage Reports right to create or modify reports.

9.9.1 Creating Location History Reports

Location History reports identify specific information about condition values over a period of time.

1. In Reports select Add > Location History Report.

To reuse settings from an existing Location History report, select the report, then select Add > Copy Selected Report.
2. Complete the **General** tab.

![Add Location History Report](image)

**Name**
Type a unique name for the new report.

**Report owner**
Your viewLinc username appears automatically, as the report owner. If you have **Manage Reports** right, you can select a different or additional user to modify this report.

**Range type**
Specify the period of time you want the report to include. A fixed date sets duration according to specific dates, or choose a period in hours/days/weeks/months.

**Duration of report**
Specify the time period you want included in the report. If you want to include only the last 8 hours of data, type **8** and then choose **hours** from the drop-down list.

**Time zone**
Change this value if reporting time zone is not the same as the server time zone.

**PDF font**
If you want to generate a report that uses in Chinese or Japanese characters, select the language. Otherwise, leave as **No Asian Characters** to reduce the generated file size.

**Available as quick report**
Allow users to generate this report from the **Sites** and **Overview** windows. Quick reports generate data for the user’s selected Location(s) or view(s).
3. If you selected the range type **Most recent events**, you can choose to generate the report automatically. Complete the **Automatic Generation** section:

For large reports, we recommend that you schedule report generation at a time when few users are using the system, such as after business hours.

**Generate and email**
Generate and then send the report directly to specific viewLinc users and groups.

**Generate and save**
Generate and then save the report to a specific file location.

- **Save To**
  Specify an accessible network server or restricted file location where you want the report saved.

- **Language**
  Saved reports are automatically generated in the system default language unless a report language is specified.

**Start generating**
Set the data generation start date and time.

**Generate report every**
Set the start date and time you want the report generated.

**Report format**
Specify whether you want the report generated hourly, daily, weekly, or monthly.
4. On the **Content** tab, identify the data you want included in the report.

**Title page**
Include content overview.

**Trend graph**
Generate a graphical display of the report data. You can choose to include separate graphs for each Location, compile all Location data on a single graph (the default option, limited to a maximum of 16 Locations), or choose to group measurement units together on the same graph (up to 4 measurement types per graph). If you choose to include a statistics summary, a statistics summary table is included in the report. Choose samples in the section, Include in statistics tables.

**Report summary table**
This option can be deselected independent of the statistics summary table.

**Interval statistics table**
Select a timeframe measured in days/hours, or on a calendar month. If the **General** tab setting for the **Duration of report** is set on a weekly interval and you want to daily interval statistics, specify 1 day, 0 hours. Choose **Show graph** to include an additional graphical representation of the statistics. Choose samples in the section, **Include in statistics tables**.

Interval statistics table will only appear if the duration is less than the report duration.

**Historical sample statistics tables**
Include statistics calculated by Location (ordered according to measurement type). Choose samples in the section, Include in statistics tables.

**Group statistics table**
Generate one statistics table for all Locations with the same measurement type. For example, the maximum temperature of all the temperature recording Locations included in the report. Choose samples in the section, Include in statistics tables.

**Real-time samples and/or Historical samples**
If you choose to include historical samples, select a set data period (every 5, 15, 30, or 60 minutes) and indicate whether the last sample reflects the closest reading to the period interval timestamp. This option is useful when reporting Locations have different sample rates.

**Include in statistics tables**
Select the historical sample data to include in all statistics tables.
5. On the **Source Data** tab, use the **Zones and Locations** navigation tree to select the Zones and/or Locations you want to include in the report.

**Zones and Locations**

To select all Locations in a Zone, select the checkbox corresponding to the Zone name. When a Zone is selected, all current and future Locations are automatically included in the report. To select or deselect a specific Location in a Zone, expand the Zone.

**Line Color**

Specify a color to identify Locations (color not available for Zones). Auto chooses the next available color (see How does viewLinc select colors for reports?).

**Vertical Axis Scale Min/Max Values**

If trend graphs will be generated (Content tab, Trend graph - One Location per graph) each Location graph can have specific min/max values, or accept the default values.

**Default Values for Vertical Axis Scale**

Choose the minimum and maximum values to define the upper and lower limits for the graph measurement range.
6. Modify report output display options on the **Page Layout** tab:
   - **Paper**
     Choose the report page size and orientation.
   - **Page Header/Page Footer**
     For header or footer options, choose to display on all pages, on the first page only, on the last page only, or on the first and last page.
   - **Left header, Center header or Right header**
     To define the content of your header or footer, type text in the **Left header, Center header or Right header** fields. You can also use the **Footer** field to include a Signature box or Comments box.
   - **Image**
     To include an image instead of text in **Left header**, select **Image**, then choose a .jpg image file from the drop-down (for previously used images) or upload a new .jpg image file using **Upload new** button.

7. Save the new report.

More Information
- Generating Reports (page 174)

### 9.9.2 Creating Alarm Reports

**Manage Reports**

Alarm reports identify alarm event patterns over a period of time.

1. In Reports select **Add > Alarm Report**.

   To reuse settings from an existing alarm report, select the report, then select **Add > Copy Selected Report**.

---

Chapter 9 – Daily Tasks

185
2. Complete the **General** tab:

**Name**
Type a unique name for the new report.

**Report owner**
Your viewLinc username appears automatically, as the report owner. If you have **Manage Reports** right, you can select a different or additional user to modify this report.

**Range type**
Specify the period of time you want the report to include. A fixed date sets duration according to specific dates, or choose a period in hours/days/weeks/months.

**Duration of report**
Specify the time period you want included in the report. If you want to include only the last 8 hours of data, type 8 and then choose **hours** from the drop-down list.

**Time zone**
Change this value if reporting time zone is not the same as the server time zone.

**PDF font**
If you want to generate a report that uses in Chinese or Japanese characters, select the language. Otherwise, leave as **No Asian Characters** to reduce the generated file size.

**Available as quick report**
Allow users to generate this report from the **Sites** and **Overview** windows. Quick reports generate data for the user’s selected Location(s) or view(s).
3. If you selected the range type, Most recent events, you can choose to generate the report automatically. Complete the Automatic Generation section:

![Tip]

For large report data sets, we recommend that you schedule report generation at a time when few users are using the system, such as after business hours.

**Generate and email**
Generate and then send the report directly to specific viewLinc users and groups.

**Generate and save**
Generate and then save the report to a specific file location.

- **Save To**
  Specify an accessible network server or restricted file location where you want the report saved.

- **Language**
  Saved reports are automatically generated in the system default language unless a report language is specified.

**Start generating**
Set the data generation start date and time.

**Generate report every**
Set the start date and time you want the report generated.

**Report format**
Specify whether you want the report generated hourly, daily, weekly, or monthly.

4. On the Content tab, identify the data you want included in the report:

- **Include content**
  Include a summary of all active, activated, deactivated and acknowledged alarms by Location.

- **Report detail level**
  Choose to group all alarm details in shortened form or expand the length of the report to include all alarm details. Depending on the number of alarms, this can increase the size and time required to generate the report significantly.

- **Alarm content**
  Choose to report on specific types of device alarms.

5. On the Source Data tab, use the navigation tree to select the Zones and/or Locations you want to include in the report:

- **Zones and Locations**
  To select all Locations in a Zone, select the checkbox corresponding to the Zone name. When a Zone is selected, all current and future Locations are automatically included in the report. To select or deselect a specific Location in a Zone, expand the Zone.
6. Modify report output display options on the **Page Layout** tab:
   **Paper**
   Choose the report page size and orientation.
   
   **Page Header/Page Footer**
   For header or footer options, choose to display on all pages, on the first page only, on the last page only, or on the first and last page.
   
   **Left header, Center header or Right header**
   To define the content of your header or footer, type text in the **Left header, Center header or Right header** fields. You can also use the Footer field to include a Signature box or Comments boxes.
   
   **Image**
   To include an image instead of text in **Left header**, select **Image**, then choose a .jpg image file from the drop-down (for previously used images) or upload a new .jpg image file using **Upload new** button.

   **Only .jpg files** can be used in reports. The image file must not exceed 154 × 48 pixels.

7. Save the new report.

More Information

- Generating Reports (page 174)

### 9.9.3 Creating System Reports

**Manage Reports**

System reports provide an overall snapshot of select system information.

1. In **Reports**, select **Add > System Report**.

   To reuse settings from an existing alarm report, select the report, then select **Add > Copy Selected Report**.
2. Complete the **General** tab:
   - **Name**
     Type a unique name for the new report.
   - **Report owner**
     Your viewLinc username appears automatically, as the report owner. If you have **Manage Reports** right, you can select a different or additional user to modify this report.
   - **Time zone**
     Change this value if reporting time zone is not the same as the server time zone.
   - **PDF font**
     If you want to generate a report that uses in Chinese or Japanese characters, select the language. Otherwise, leave as **No Asian Characters** to reduce the generated file size.
   - **Available as quick report**
     Allow users to generate this report from the **Sites** and **Overview** windows. Quick reports generate data for the user’s selected Location(s) or view(s).

3. Complete the **Automatic Generation** section:
   - **Generate and email**
     Generate and then send the report directly to specific viewLinc users and groups.
   - **Generate and save**
     Generate and then save the report to a specific file location.
     - **Save To**
       Specify an accessible network server or restricted file location where you want the report saved.
     - **Language**
       Saved reports are automatically generated in the system default language unless a report language is specified.
   - **Start generating**
     Set the data generation start date and time.
   - **Generate report every**
     Set the start date and time you want the report generated.
4. On the **Content** tab, identify the data you want included in the report:

- **Server**
  Include viewLinc Enterprise Server configuration details.

- **System Preferences**
  Include the currently selected viewLinc system preferences.

- **Alarm templates**
  Include details for selected templates (active and deactivated).

- **Users and groups**
  Include all users and/or groups, and their assigned permissions to Locations. The report shows the highest available permission for each Location, listed alphabetically by user or group.

- **Sites**
  Include Location details about current threshold and device alarm templates, and permission levels granted to users/groups for each Location (active and deactivated).

|💡 The report lists highest available permission for the user or group, listed alphabetically by Location. |

- **Devices**
  Include a list of all linked system hosts, data loggers and transmitters (active and deactivated).

5. Save the new report.

**More Information**

- Generating Reports (page 174)

### 9.10 Viewing Data with viewLinc Mobile

Several viewLinc functions are accessible via mobile device. To log in, open a device browser and type the IP address/mobile (**##.##.##.##/mobile**). The initial screen that appears after you log in is the **Sites** window navigation tree. Tap the name of a Zone to reveal the Locations below it. Select a Location and then tap the **Options** button to view available options:

- **Refresh**
  Update display to show most recently collected data.

- **Pop-up Trend**
  Display selected Location data in trend graph.

- **Pause/Resume Threshold Alarming**
  Pauses threshold alarming temporarily on all Locations in the selected Zone for 1 hour.
Ways to Display Mobile Data

**Sites view:** Display trends, change trend graph settings, pause threshold alarming. When a Zone is selected, the view expands to display sub-zones and Locations.

- To go up a folder, tap the previous screen button (do not use your device Back button, it closes the active tab and ends the browsing session).

**Table view:** Displays detailed Location information for whichever Location was selected from the Sites view. Pause threshold, host or device alarming.

- To view Location information, select the Location, then double-tap to view details. Click \( \times \) to return to the previous screen.
- To go up a folder, tap the Sites button (do not use your device Back button, it closes the active tab and ends the browsing session).

**Alarm view:** Displays alarm information for whichever Location was selected from the Locations pane view (or all Location alarms, if none selected).

- To view alarm information, select the Location, then double-tap to view details. Click \( \times \) to view the previous screen.
- To go up a folder, tap the Sites button (do not use your device Back button, it closes the active tab and ends the browsing session).

Only Locations that have active alarms display on the mobile device. For example, if you are at the system level when you press the alarm grid, it displays all active alarms in the system, if any.

### 9.10.1 Opening a Pop-up Trend

Before you can view pop-up trends on a mobile device, ensure the device browser is not set to block pop-ups. Refer to your device-specific user guide for more information.

1. Tap the Sites button, then navigate to a specific Location.
2. Tap Options > Pop-up Trend. The pop-up trend window appears in a new browser tab.

![Pop-up Trend Window]

**Interval**
Trends display up to 1 month of data logged up to the current date.
- Tap the calendar button to set the end date.
- Tap the settings icon to include real-time samples or threshold lines on the graph.

**Auto Refresh**
Select this option to update the trend with real-time data readings. Only available for trends set to a maximum duration of 7 days.

Use the arrows to scroll the trend forward and back.

More Information
- Trend Navigation (page 169)

### 9.10.2 Pausing or Resuming Alarming with viewLinc Mobile
You can pause or resume alarms on a mobile device for the Locations you have permission to view on your desktop display.

1. Open Table view.
2. Select the Location you want to pause or resume alarming, then select Options.
3. To pause alarming, tap **Pause Threshold Alarming**, **Pause Host Alarming**, or **Pause Device Alarming**.

- Once alarming is paused, it remains paused for one (1) hour.
- To resume alarming within the hour, repeat these steps and select **Resume Threshold Alarming**, **Resume Host Alarming** or **Resume Device Alarming**.

More Information
- Pausing Alarms (page 159)

9.10.3 Acknowledging an Alarm with viewLinc Mobile

If you are authorized to acknowledge alarms for the Locations you can view, you are authorized to acknowledge those alarms remotely.

1. Open **Alarms** view.
2. Select the alarm you want to acknowledge.
3. Tap **Options > Acknowledge**. At the prompt, type the action taken, select a predefined comment (if required) and add extra comments (optional).
4. Fill in the required information and then tap **Acknowledge**.

More Information
- Acknowledging Alarms (page 153)
9.10.4 Viewing Data on a Remote Display

Several viewLinc functions are available on a remote display.

If the display terminal does not have touch-screen capability, a connected keyboard is required.

1. Open the Internet browser on the display terminal.
2. Type your viewLinc IP address followed by /display (for example, ##.###.##.##/display).
3. Select the language you want to display. When changing to a language other than English, the page automatically refreshes to display the new language.
4. Log in as the remote display user. The content displayed is defined by the default view for the signed in user. These settings are remembered until the user logs out.
5. Select display options:
   • Open the Dashboard tab to display a graphic of monitored Locations in the view.
   • Open the Trend tab and select a view. The graph automatically loads data for all Locations in the view.
   • To view multiple Location trends on a single monitor, open multiple browser windows. In each browser window, log in to viewLinc as a different user, each with a different default view.

If a browser reboots unexpectedly, viewLinc automatically relaunches the browser and logs in as the last user. The browser opens the user’s default view with the last open tab displayed.

9.10.5 Changing a Display Terminal View

To change the view displayed on a display terminal, you can either select a different view assigned to the user currently logged in, or log in as a new user with different views available.

1. To select a different view:
   a. On the viewLinc remote display, expand the Views pane.
   b. In the Views tree, select another available view. The display updates automatically.
2. To log in as a new user:
   a. On the viewLinc remote display, select User > Logout, then select Yes.
   b. At the viewLinc log in prompt, type the new username and password.
   c. Expand the Views pane to select an available view.
10. Administrator Tasks

After the viewLinc system is set up and system monitoring is active, ongoing system maintenance tasks can be performed by members of the Administrators group, or users assigned the required rights.

10.1 Groups and Users

As your team grows or responsibilities change, you can quickly adjust user profile and group properties.

More Information
• Groups and Users (page 73)

10.1.1 Editing User or Group Details

Manage System

1. In the Users and Groups window, select the user or group you want to edit, then select **Edit** (or right-click and select **Edit**).

2. Edit settings as needed.
   • Only members of the Administrators group can modify a user’s group assignments.
   • Only viewLinc passwords can be modified.

3. Select **Save**.

More Information
• Groups and Users (page 73)

10.1.2 Deactivating Users

Manage System

Users cannot be deleted from the viewLinc database; however, you can use the deactivate function to ensure users who have moved to other positions or left the company are no longer included in group alarm notifications and/or group report distribution (this is easier than removing groups from individual alarm templates or reports).

1. In the Users and Groups window select the Users tab.

2. Select the user you want to deactivate. If your user list is long, use the Search tool to locate a user, or click the top column header to sort names in alphabetical order.

3. Select **Deactivate**.

4. To confirm, select **Deactivate**. The user row is automatically hidden.
To show all deactivated users, select View > Include Deactivated Users.

10.1.3 Reactivating Users

Manage System

1. In the Users and Groups window select the Users tab.
2. Select View > Include Deactivated Users.
3. Select a deactivated user row (greyed out text row).
4. Select Activate.
   The user row reappears in the table.

10.1.4 Deactivating Groups

Manage System

Groups cannot be deleted from the viewLinc database; however, you can use the deactivate function to ensure that the group is no longer used for alarm notifications or group report distribution (this is easier than removing the group from multiple alarm notification templates and/or reports).

All users in a group must be deactivated before a group can be deactivated.

1. In the Users and Groups window select the Groups tab.
2. Select the group you wish to deactivate.
3. Select Deactivate.
4. To confirm, select Deactivate.
   The group row is automatically hidden.

To show all deactivated groups, select View > Include Deactivated Groups.

10.1.5 Reactivating Groups

Manage System

1. In the Users and Groups window select the Groups tab.
2. Select View > Include Deactivated Groups.
3. Select a deactivated group row (greyed out text row).
4. Select **Activate**.
The group row reappears in the table.

10.2 Zones and Locations

Modification to Zones and Locations is performed in the **Sites Manager** window. Common administrator activities include changing a Zone or Location name, unlinking and moving a Location to a different zone, applying different permissions, creating schedules, and/or applying different threshold templates.

**Full Control** permission is required to make changes to Zones or Locations.

10.2.1 Editing Zone Display Properties

**Manage System**

1. In **Sites Manager** on the **Zones and Locations** tree, select the Zone you want to edit.
2. Right-click to select **Edit Properties** or select **Manage > Edit Properties**.
3. In the **Edit Zone** window, modify the information viewLinc uses to display the Zone: name, dashboard folder icon, description.
4. Save the changes.

10.2.2 Editing Location Display Properties

**Manage System**

1. In **Sites Manager** on the **Zones and Locations** tree, select the Location you want to edit.
2. Right-click to select **Edit Properties** or select **Manage > Edit Properties**.
3. In the **Edit Location** window, modify the information viewLinc uses to display the Location: name, description, units and decimal places. These settings control the way the Location appears throughout viewLinc. If you enter a smaller number of decimal places than your device reads, viewLinc automatically rounds the data it receives from the device to the nearest decimal point.
4. Save the changes.

10.2.3 Viewing Location Properties

In the **Sites Manager** window use the **Location Properties** tab for at-a-glance review of important Location details. Access to the **Sites Manager** window requires **Manage Sites** right.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="view.png" alt="View Trend" /></td>
<td><strong>View Trend</strong>: View a Location’s historical data as a trend in a new browser window.</td>
</tr>
<tr>
<td><img src="find.png" alt="Find in Tree" /></td>
<td><strong>Find in Tree</strong>: Highlight the selected Location in the Zones and Locations navigation tree.</td>
</tr>
<tr>
<td><img src="show.png" alt="Show Linked Channel History" /></td>
<td><strong>Show Linked Channel History</strong>: Find out how long a specific device channel has been linked to a selected Location, when the link first began, and for how long it has been linked.</td>
</tr>
</tbody>
</table>

**Table 26  Location Properties Columns**

<table>
<thead>
<tr>
<th>Column</th>
<th>Contains</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The Location Type icon. This column cannot be moved.</td>
</tr>
<tr>
<td>Zone</td>
<td>Full path of the parent Zone.</td>
</tr>
<tr>
<td>Location</td>
<td>Location name as displayed in the navigation tree.</td>
</tr>
<tr>
<td>Location ID</td>
<td>Number assigned by viewLinc to a new Location. It can never be changed.</td>
</tr>
<tr>
<td></td>
<td>Used to avoid confusion if more than one Location is given the same name.</td>
</tr>
<tr>
<td>Description</td>
<td>User-entered device description.</td>
</tr>
<tr>
<td>Device Description</td>
<td>Name of a device, as defined by a user.</td>
</tr>
<tr>
<td>Device Serial Number</td>
<td>Device serial number automatically stored in viewLinc .</td>
</tr>
<tr>
<td>Channel Description</td>
<td>Description provided by a user.</td>
</tr>
<tr>
<td>Device ID</td>
<td>A number assigned to a new device, generated by viewLinc, and can never</td>
</tr>
<tr>
<td></td>
<td>be changed. Used to avoid confusion if more than one device is given the</td>
</tr>
<tr>
<td></td>
<td>same name.</td>
</tr>
<tr>
<td>Channel ID</td>
<td>A number assigned to a new channel, created by viewLinc, and can never</td>
</tr>
<tr>
<td></td>
<td>be changed. Used to avoid confusion if more than one channel is given the</td>
</tr>
<tr>
<td></td>
<td>same name.</td>
</tr>
<tr>
<td>Channel Index</td>
<td>Channel number assigned to the linked Location.</td>
</tr>
<tr>
<td>Location Units</td>
<td>Unit display format set in viewLinc, often modified for reporting purposes</td>
</tr>
<tr>
<td></td>
<td>(for example, American sites may want to see readings in standard</td>
</tr>
<tr>
<td></td>
<td>measurement units, Fahrenheit, while Canadian operations may prefer them</td>
</tr>
<tr>
<td></td>
<td>in metric, Celsius).</td>
</tr>
<tr>
<td>Preferred Units</td>
<td>Unit display option (such as C or F), for the specific Location (units can</td>
</tr>
<tr>
<td></td>
<td>be set differently for different Locations).</td>
</tr>
<tr>
<td>Device Units</td>
<td>Data logger or transmitter units, such as C, DEGC, TDC, set by Vaisala.</td>
</tr>
<tr>
<td></td>
<td>These can be changed in viewLinc to display in a more meaningful way (Location</td>
</tr>
<tr>
<td></td>
<td>or Preferred Units).</td>
</tr>
<tr>
<td>Measurement Type</td>
<td>The value being measured (temperature, humidity, boolean, pressure).</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>System-defined preference.</td>
</tr>
<tr>
<td>Column</td>
<td>Contains</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Device Address</td>
<td>System folder path to this Location.</td>
</tr>
<tr>
<td>Link Start</td>
<td>Date the Location started recording data (Unlimited indicates this Location has remained linked to the current channel since it started monitoring data).</td>
</tr>
<tr>
<td>Link End</td>
<td>Date the Location stopped recording data (Unlimited indicates the Location is still linked to the current channel, and continuously recording data).</td>
</tr>
<tr>
<td>Permission</td>
<td>The permission a user has been granted for this Location.</td>
</tr>
<tr>
<td>Threshold Alarm Schedule</td>
<td>The name of the threshold alarm schedule set for this Location, if one has been assigned.</td>
</tr>
</tbody>
</table>

More Information

- Icons (page 144)

10.2.4 Renaming Location or Zone

Manage Sites

Renaming Zones edits the Zone name only; it does not change the Locations assigned within it.

1. In Sites Manager on the Zones and Locations navigation tree, select the Location or Zone you want to rename.
2. On the Manage menu, select Edit Properties, or right-click and select Edit Properties.
3. Type a new unique name, then select Update.
4. Select Save or Undo to cancel the change.

10.2.5 Unlinking or Relinking Locations and Channels

Manage Sites

As your company's monitoring needs change, perhaps due to a change in monitored spaces or a facility move, you may want to link a device channel to a different viewLinc Location. This is an easy change with viewLinc's unlink/relink function.

Full Control permission is required for all Zones where Locations are being linked or unlinked.

Channels can be unlinked individually, or you can unlink all channels within a Zone at one time. This option saves you time when you want to deactivate a Zone that is no longer being monitored. For some organizations, the list of Locations and Zones is lengthy, and the first step is to identify the Location to which a channel is linked.
10.2.5.1 Unlinking a Location from a Channel

When a device channel is unlinked from a viewLinc Location, data history is retained in the Location History report.

1. In Sites Manager navigate the Zones and Locations tree to the linked Location.
2. Select Manage > Unlink Channel (or right-click and select Unlink Channel).
3. Select Unlink. The device channel is now available to link to another Location.
4. Select Save.

10.2.5.2 Unlinking All Locations in a Zone

These steps are required if you want to delete a Zone.

1. In Sites Manager, navigate the Zones and Locations tree to find the Zone with the Locations you want to unlink.
2. Select Manage > Unlink Channels (or right-click and select Unlink Channels).
3. Select Unlink to confirm the change.
4. Select Save.

More Information

- Removing Zones and Locations (page 202)

10.2.5.3 Linking a Previously Linked Channel to a New Location

1. In Sites Manager select the Hosts and Devices tab.
2. In the Zones and Locations tree, navigate to a new, unlinked Location.
3. In the Hosts and Devices tree select an unlinked channel (the channel may have been linked before, but is now in the unlinked state, displaying italicized text).
4. Select Configure > Link Channel.
5. In the Link Channel to Location window, choose when you want this new Location to start monitoring data:
   - **Start now**
     Data is recorded at this Location starting from the next available sample recorded on the channel.
   - **Start from earliest available link time**
     New channel data starts recording to the Location based on last time the channel was linked.
   - **Start from a specified time**
     Set the time to start recording data history.
6. Select **Link**.
7. Select **Save**.

### 10.2.5.4 Linking a New Channel to a Previously Linked Location

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. In the **Zones and Locations** tree, navigate to an unlinked Location (the Location may have been linked previously to another channel, but is currently in the unlinked state, displaying italicized text).
3. In the **Hosts and Devices** tree select the unlinked channel.
4. Select **Configure > Link Channel**.
5. In the **Link Channel to Location** window, choose when you want this new Location to start monitoring data:
   - **Start now**
     Data is recorded at this Location starting from the next channel reading.
   - **Start from earliest available link time**
     New channel data starts recording to the Location based on last time the Location was linked.
   - **Start from a specified time**
     Set a specific time to start recording data history.
6. Select **Link**.
7. Select **Save**.

### 10.2.5.5 Linking Previously Linked Channel to a Previously Linked Location

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. In the **Zones and Locations** tree, navigate to an existing, unlinked Location.
3. In the **Hosts and Devices** tree, select an existing, unlinked channel.
4. Select **Configure > Link Channel**.
5. In the **Link Channel to Location** window, choose when you want this Location to start monitoring data:
   - **Start now**
     Data is recorded at this Location starting from the next available sample time.
   - **Start from earliest available link time**
     This option automatically selects the most recently linked time, the Location or the channel linkage. This prevents data duplication and invalid alarms.
   - **Start from a specified time**
     Set a specific time to start recording data history.
6. Select **Link**.
7. Select **Save**.
10.2.6 Moving Locations

viewLinc recognizes devices regardless of their assigned Zone, which allows you to move devices and channels from one Zone to another, without losing data history. For example, if you need to move a monitored refrigeration unit to another physical location, in viewLinc, simply move the device Location data point to a different refrigeration Zone. Full Control permission for the Location is required.

1. In Sites Manager make sure you have a destination Zone created for the Location.
2. On the Zones and Locations tree, select the Location you want to move.
3. To move the Location with your mouse, in the Zones and Locations tree select a Location and drag it to the new Zone.

If the new Location has the same name as another Location in the Zone, at the prompt modify the Location name.

4. To move the Location manually, in the Zones and Locations tree select a Location:
   a. Select Manage > Cut (or right-click and select Cut).
   b. Select the Zone where the Location will be moved and then select Manage > Paste.
5. Select Save, or Undo to cancel the move.

10.3 Removing Zones and Locations

As your company grows, or monitoring needs change, you may find that you no longer need a Zone or Location displayed on your desktop. To ensure complete audit trail records, Locations can be deleted only if they have never been linked to a channel to collect data. Any Locations that cannot be deleted can still be prevented from appearing on the viewLinc desktop, with the deactivate function.

- **Deactivate**: The Location is hidden from view (Zones and Locations tree) and can be reactivated at a later time.
- **Delete**: The Zone or Location can no longer be used. This option is a good way to remove the visual clutter associated with deactivated Zones or Locations.

You cannot delete the top-level Zone or a Zone with Locations that have been used to collect data. Zone deletion is only available when all child Locations are deleted or moved to another Zone.
10.3.1 Deactivating Locations

Manage Sites

When you no longer want to record data or monitor a Location, deactivate the Location so it is no longer visible on the Zones and Locations tree. All previously recorded history is saved.

1. In Sites Manager on the Zones and Locations tree, select a Location to deactivate.
2. Select Manage > Deactivate (or right-click and select Deactivate).
3. At the prompt, select Deactivate. The Location is hidden from view.
4. Select Save, or Undo to cancel the change.

To show or hide all deactivated Zones or Locations, select More > Include Deactivated Locations.

10.3.2 Reactivating Locations

Manage Sites

Only deactivated Locations which were never linked to a device channel may be reactivated.

1. In Sites Manager on the Zones and Locations tree, select More > Include Deactivated Locations.
2. Select the deactivated Location (appears as red strikeout text Lab A), then select Manage > Activate (or right-click to select Activate).
3. At the prompt, confirm activation.
4. Select Save.

10.3.3 Hiding or Showing Deactivated Locations

Manage Sites

When you deactivate a Location, it is hidden from view in the Zones and Locations tree. You can make them visible again in Sites Manager.

1. In Sites Manager, select or deselect More > Include Deactivated Locations.

10.3.4 Deleting Locations

Manage Sites

Unlinked Locations which have never been linked to a device channel can be deleted. Once deleted, they are no longer available in the Zones and Locations tree.

If a Location has been linked to a device channel, the Location can only be deactivated. Deactivated Locations are hidden from view and can be reactivated.
1. In **Sites Manager** select an unlinked Location.
2. Select **Manage > Delete** (or right-click to select **Delete**). If the option to delete is not available, the selected Location was previously linked to a channel and cannot be deleted, only deactivated.
3. Select **Save**.

More Information

- Deactivating Locations (page 203)

### 10.3.5 Deleting Zones

**Manage Sites**

Zones can only be deleted if all child Locations are deleted.

1. In **Sites Manager** select an empty Zone to delete. To verify that the Zone does not contain any hidden deactivated Locations, select **More > Include Deactivated Locations**.

   ![Tip]

   *If the Zone you want to delete contains any deactivated Locations, you can drag them to another unused Zone.*

2. Select **Manage > Delete** (or right-click and select **Delete**).
3. Select **Save**.

### 10.4 Enabling or Disabling Alarming

To prevent unnecessary alarming during system maintenance periods, which may take more than 24 hours, disable device alarms.

- Disable or enable device alarming
- Disable or enable threshold alarm settings
- Disable or enable threshold alarm template level (affects all Locations using the template)

To disable alarming on devices for a temporary period of up to 24 hours, you can pause the alarm.

To stop device alarming and data logging until further notice or even permanently, you must deactivate a device or host.

More Information

- Pausing Alarms (page 159)
- Deactivating Hosts or Devices (page 207)
10.4.1 Enabling or Disabling Threshold Alarm Settings

Manage Sites

Disabling threshold alarm settings is useful when you want to temporarily prevent threshold alarming on one or several Locations. You can also disable individual levels in a threshold alarm template. You must have at least Configure Alarms permission for selected Location(s).

Disabled threshold alarm settings remain visible on your viewLinc screen and can be enabled at any time.

When you no longer want threshold settings used, use the deactivate option (threshold alarm settings cannot be deleted). Deactivated threshold alarms are hidden from view, but can be reactivated at any time.

1. In Sites Manager navigate to a Location in the Zones and Locations tree.
2. On the Threshold Alarm Settings tab, select one or more rows (CTRL+click to select multiple), then select Edit threshold alarm settings (or use the right-click menu).
3. On the Edit Threshold Alarm Settings window, enable or disable the Status setting.
4. Select Save.

More Information

• Deactivating Threshold Alarms (page 87)
• Enabling or Disabling Threshold Alarm Template Levels (page 205)

10.4.2 Enabling or Disabling Threshold Alarm Template Levels

Manage Alarm Templates

When creating a threshold alarm template, you may not want to enable all levels. You may want to apply the threshold alarm template to several Locations, then enable specific levels at different times.

Enabling or disabling a threshold alarm template level affects all Locations using the template.

1. In Alarm Templates select the Threshold Alarms tab.
2. Select the threshold alarm template you want to modify, then select Edit.
3. On the thresholds grid in the Enabled column, enable or disable threshold levels. At least one threshold level must remain enabled.
4. Select Save.
10.4.3 Enabling or Disabling a Device Alarm Assigned to a Location

Manage Sites, Manage Alarm Templates

To prevent unnecessary alarming during system maintenance periods, which may take more than 24 hours, disable device alarms. You can also disable all alarming on a device for a temporary period, up to 24 hours.

Alternatively, to stop all device alarming and data logging until further notice or even permanently, you can deactivate a device or host.

1. In Sites Manager select a Location in the Zones and Locations tree.
2. On the Device Alarm Settings tab select the device alarm type you want to enable or disable. You must have at least Configure Alarms permission for the selected Location.
3. Select Edit device alarm settings.
4. In the Edit Device Alarm Settings window set the Status option to Enabled or Disabled.
5. Select Save.

More Information

- Pausing Alarms (page 159)
- Deactivating Hosts or Devices (page 207)

10.4.4 Enabling or Disabling Multiple Device Alarms

Manage Sites

1. In Sites Manager select one or more Zones or Locations in the Zones and Locations tree (CTRL+click). You must have at least Configure Alarms permission for selected Location(s).
2. On the Device Alarm Settings tab, select the alarm types you want to enable or disable.
3. Select Edit device alarm settings.
4. In the Edit Device Alarm Settings window select the status option: Enabled or Disabled, or, if multiple alarm types are selected, leave the default option selected, (Mixed - leave unchanged).
5. Select Save.

10.4.5 Enabling or Disabling Host Alarming

Manage Devices

Disable host alarms to prevent continuous alarming during maintenance periods.

1. In Sites Manager on the Hosts and Devices tree, select a host.
2. Select **Configure > Host Communication Alarm Settings** or **Configure > Host Configuration Alarm Settings**.

3. Set the **Status** option to **Enabled** or **Disabled**.

4. Select **Save**.

10.5 Device Maintenance

Users who are part of the default **Administrators** group, or are part of a group assigned **Manage Devices** right, use the **Sites Manager** window to manage and maintain hosts and devices.

**More Information**

- Configure Hosts and Devices (page 50)

10.6 Device Removal

**Manage Devices**

Before you remove a device from your network, or transfer it to a new monitoring area on the same network, the device must be deactivated. A deactivated device stops logging data and disables all device and threshold alarming.

You may want to remove a device when:

- a device requires maintenance (such as recalibration)
- a device is no longer required

When a device is swapped it is automatically deactivated.

**More Information**

- Deactivating Hosts or Devices (page 207)
- Releasing RFL Data Loggers (page 208)
- Swapping Devices (page 209)

10.6.1 Deactivating Hosts or Devices

**Manage Devices**

You can deactivate a single device or all devices connected to a host. This action will stop all alarming and all data collection until you reactivate the device or host.

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. On the Hosts and Devices tree, select the host or device you want to deactivate.
3. Select Configure > Deactivate (or right-click and select Deactivate).
4. A message appears, asking that you confirm deactivation of the host or device. Select Deactivate.

The host/device is no longer visible on the Hosts and Devices tree, but the network connection is still intact, allowing you to reactivate the host/device at a later time.

Deactivated devices are not included in the total number of licensed devices.

10.6.2 Reactivating Hosts or Devices

Manage Devices

1. In Sites Manager select the Hosts and Devices tab.
3. Select the deactivated host/device (indicated by red strikeout text), then select Configure > Activate (or right-click and select Activate).

10.6.3 Hiding or Showing Deactivated Hosts or Devices

Manage Devices

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree select More, then check or uncheck the option, Include Deactivated Devices.

10.6.4 Releasing RFL Data Loggers

Manage Devices

Before moving or removing RFL data loggers on your network, they must be released from their access point to prevent unnecessary alarming.

Refer to the device user guides for more information about managing data loggers and access points in your facility.

1. In Sites Manager select the Hosts and Devices tab.
2. Select one or more RFL data loggers in the Hosts and Devices tree.
3. Select **Configure > Release Device from Access Point**.

![i]

After releasing an RFL data logger, it can be accepted later by the same or by another access point host.

4. At the prompt, select **Release**.

### 10.7 Swapping Devices

**Manage Devices**

The swap device function allows you to exchange a device that is currently linked to a Location, while retaining the threshold and device alarm settings which are currently applied to the Location. A swap may be required for maintenance purposes, such as calibration of the device or probe, an update of the data logger firmware, or to change to a wireless device.

When a device is swapped, the change is noted on the Location History report (the report shows the device serial number for a reporting period). If, during the reporting period, the device was swapped, this event is listed in the report summary.

Any device linked to a Location can be swapped without interruption to threshold monitoring or causing a device alarm.

![i]

Only a device with the same settings may be swapped (for example, a device with 3 channels cannot be swapped for a device with 2 channels, and the channels must record the same type of data).

1. Make sure the replacement device is:
   - connected to your network
   - on the same host as the device to be swapped
   - has the same sample rate
   - has the same channel indexes and measurement types

2. In **Sites Manager** select the **Hosts and Devices** tab.
3. On the **Hosts and Devices** tree, select the device to be swapped.
4. Select **Configure > Swap This Device With**.

![i]

Only compatible and available replacement devices are displayed.
5. In the **Swap Device** window, select the replacement device.

**Show device currently connected to port**
If you are swapping a DL logger and the new device is already connected, enable this option to help locate a specific device.

**Link start time**
Select Start now to associate all channel data starting from this point forward with the linked Location.

**Start from last channel sample recorded at Location**
This option automatically starts from the most recently linked time. This option prevents data duplication and invalid alarms.

6. Select **OK**.

### 10.8 Adding Modbus Devices

viewLinc can be configured to retrieve data from both Vaisala and non-Vaisala Modbus-enabled measurement devices containing a maximum of 8 channels per device. Vaisala Modbus devices can be connected to a viewLinc Device Host as part of your standard viewLinc license, while third-party/non-Vaisala Modbus devices require the purchase and addition of a Modbus license.

To see the current number of licensed Modbus devices or available viewLinc device spaces, see **Help > About**.

Several of Vaisala’s measurement devices and other manufacturer’s devices use the Modbus communications protocol. The associated device documentation provides important details you will need to configure a Modbus TCP or Modbus RTU device in viewLinc.

**Connecting Modbus Devices**

Modbus RTU devices may be connected to your network with a Digi or other Ethernet device, or with a serial cable to connect directly to a viewLinc Device Host. Modbus TCP devices are connected directly to your network with a network cable.
Connecting Modbus devices to your network requires advanced networking expertise. Refer to your Modbus device documentation to complete the installation steps, including installation of required Digi or Ethernet device drivers on the host server, and verification of network connectivity.

**Input and Holding Registers**

Modbus devices contain input and holding registers that read and write data using 16-bit or 32-bit wide integers. The data structure used by the Modbus device manufacturer defines the way you will need to configure ViewLinc.

![Modbus Device Diagram]

The first step is to refer to your Modbus device documentation to determine whether the register format is based on an address (decimal or hexadecimal) or a number. If your device uses the wider 32-bit format, the data format may be higher byte/word first or lower byte/word first.

<table>
<thead>
<tr>
<th>Register Types</th>
<th>Register Number Ranges</th>
<th>Data format options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coil</td>
<td>00001-09999</td>
<td>Boolean / Boolean Inverted</td>
</tr>
<tr>
<td>Discrete Input</td>
<td>10001-19999</td>
<td>Boolean / Boolean Inverted</td>
</tr>
<tr>
<td>Input Register</td>
<td>30001-39999</td>
<td>• 16-bit Integer / Unsigned Integer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 16-bit Boolean / Boolean Inverted</td>
</tr>
<tr>
<td>Holding Register</td>
<td>40001-49999</td>
<td>• 32-bit Integer, Little-endian / Little-endian, word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Integer Big-endian / Big-endian word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Unsigned Integer, Little-endian / Little-endian, word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Unsigned Integer Big-endian / Big-endian word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Float Little-endian / Little-endian word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Float Big-endian / Big-endian word swapped</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 32-bit Boolean / Boolean Inverted</td>
</tr>
</tbody>
</table>
Additional Modbus reference information about mapping registers can be found online, such as www.modbus.org.

Since Modbus device documentation is not standardized, it may provide configuration information in a variety of ways. To learn more about Modbus, useful online resources include: www.modbus.org, and ‘How to add a Modbus Device’, available from the Tours menu.

### 10.8.1 Configure Modbus Device Connections

Refer to your Modbus device documentation to collect required register configuration details.

#### Manage Devices

Before completing this configuration task, make sure the Modbus device is connected to your network and, if installing third-party/non-Vaisala Modbus devices, make sure the Modbus license key has been added. If you are adding a Modbus RTU device, make sure you have the COM port number assigned (Go to Windows Start menu to open **Device Manager > Ports > Communications Port**). If you are adding a Modbus TCP device, refer to the device manual to determine Port number and IP address.

If you are using a Digi device connection, install the Digi device drivers on the host server.

1. In **Sites Manager** select the **Hosts and Devices** tab.

2. In the **Hosts and Devices** tree select a viewLinc Device Host server, then select **Configure > Add Device > Vaisala Modbus Device** or, if licensed, **Non-Vaisala Modbus Device**.

3. If you are adding a Vaisala Modbus device or have added a similar non-Vaisala Modbus device and saved the device configuration details as a template, select **Template...** and select the template you want to use.

4. In the **Add Modbus Device** window type a device **Description** (do not use < or >), **Model** (do not use dashes, --), then add a unique **Serial number** (alpha numeric only).

5. To modify calibration details or to set up calibration reminder notifications, select **Edit calibration data...**:
   - **Calibration date**: The original calibration date for the measurement probe, set by the factory and cannot be modified.
   - **Calibrated by**: The name of the person or company who performed the calibration service.
   - **Next calibration date**: Type a new date to automatically have viewLinc generate a calibration notification to remind you when calibration service is needed.
6. Add communication settings: **Modbus TCP**: Type the Modbus device IP address, port number (default 502), and unit ID. This must be a unique combination. **Modbus RTU Serial**: Type the COM port number the Modbus device is connected to, the device’s Slave ID, the serial bit rate (default 9600), parity and stop bits, as specified in the Modbus device documentation.

7. Add viewLinc channel details:
   - **Measurement type / Unit**: Choose from the available viewLinc measurement type and unit options.

8. Add Modbus register details:
   - **Format**: Choose a format option based on the register number or address (defined in the Modbus device documentation).
   - **Register type**
     - **Coil** or **Discrete input**: Type the number or a decimal address.
     - **Input register** or **Holding register**: Type the decimal address and then choose byte format.
   - **Number or Address**: Depending on the format selected, add the required number or address in decimal or hexadecimal format.

   After details are saved, when you select a different option in the Format field, the entered details automatically convert to the selected format.

9. Define scaling parameters (optional). You can use the **Scale** field to add a multiplier value, and the **Offset** field to add a positive or negative number, to calculate a recognized or expected **Current value**. Some integer registers need a scaling adjustment to make sure the value read from the register corresponds with the actual value it is communicating. For example, if a register stores a value of 2406, it requires a scaling factor of 100:1 to display as an actual temperature of 24.06 ºC.

10. Click the test icon, ![test icon] to test the connection. If an expected value appears in the row, the configuration is complete. If the value is not displayed, is incorrect, or the warning icon remains in view, ![warning icon], review and adjust the configuration and/or scaling settings entered for the device. Re-test as required. Modbus documentation may indicate a specific order that data will be sent; however, viewLinc may expect receive it in another syntax. If the combination of register format and address selection is not correct, the device value will be significantly different than expected. You may need to enter register details in a variety of formats and test until the correct device value displays.

11. Save the channel detail row and start a new row for an additional device channel. To delete an extra row, click ‘X’.

12. When you are finished entering details and the **Add device** button is enabled, select **Save** or **Save as template...** to save the details as a reusable template.
10.9 Editing Modbus Device Settings

Manage Devices

1. In Sites Manager select the Hosts and Devices tab.
2. In the Hosts and Devices tree select the Modbus device, then select Configure > Edit Properties (or right-click to view the options menu).
3. Save changes.

10.10 Device Calibration

Calibration ensures that data recorded by the measurement equipment (data loggers, transmitters, probes) is reliable and accurate.

For example, most people are used to adjusting their watches to the correct time. Working standards (clocks) are visible and almost everywhere, and making a comparison—calibration—is easy. If the time on the watch differs from the trusted reference, make an adjustment. The measured data (the time) shown on the trusted reference (the clock) can be relied upon as a reference point.

Use viewLinc to update your device, probe and channel calibration values. To make sure your devices are calibrated on schedule, set up viewLinc calibration reminders for your devices and their probes.


10.10.1 Editing Channel Calibration Properties

Manage Devices

Channel calibration settings are the reference values used for testing measurement accuracy on Vaisala data loggers

Ensure that the initial calibration values have been downloaded from the device to viewLinc (automatically discovered when device detected by viewLinc).

1. In Sites Manager select the Hosts and Devices tab.
2. In the Hosts and Devices tree, select a data logger channel to edit.
4. In the Edit Channel Properties window, edit the properties, Calibration scale and Calibration offset using information provided by Vaisala or collected from on-site calibration testing.
5. If you are changing calibration settings on an HMT140 device, you are prompted to reset the device calibration settings.
6. Select OK.

More Information
- Editing Channel Properties (page 57)

### 10.10.2 Editing Device or Probe Calibration Properties

**Manage Devices**

When you set calibration dates for devices and their probes, viewLinc automatically issues calibration reminder notifications at 3 months and 1 month before the due date, and again on the due date.

You can set the properties for calibration notifications (priority, delay, acknowledgement) in a device calibration alarm template, and add a notification message, such as who to contact to initiate the calibration service.

- Calibration duration can be set for all devices in System Preferences by selecting the value column beside the option, Default calibration duration; however, the calibration duration set on a data logger or a probe overrides the system preference.
- Calibration information on some devices is set automatically and cannot be modified.

1. In Sites Manager select the Hosts and Devices tab.
2. In the Hosts and Devices tree, select a device.
4. In the **Edit Device Properties** window, calibration fields are available for the device and any attached probes. Add calibration details:

**Calibration date**
Type the last calibration date, unless preset by Vaisala Calibration Services.

**Calibrated by**
Type the name of person who last calibrated the device, unless preset by Vaisala Calibration Services.

**Next calibration date**
Type the date for next calibration. If no date entered, the system automatically sets the date to one year after last calibration date.

5. Select **OK**.

**More Information**
- Editing Channel Properties (page 57)
- Setting System-Wide Default Calibration Duration (page 112)

### 10.10.3 Off-site Calibration

To maintain the high accuracy measurement of the viewLinc system, Vaisala offers calibrations and complete functional testing in our own ISO 17025 accredited lab, which meets the standards of ISO/IEC 17025 & ANSI/NCSL Z540-1-1994.

Calibration services include:

- Verification of specifications against the original calibration
- Battery check and replacement if necessary
- Update firmware if necessary

### 10.10.4 On-site Calibration

When sending devices in for recalibration is impractical, Vaisala's on-site calibration team is ready to assist. On-site calibration includes a NIST-traceable certificate and reminders of recalibration due dates.

To reduce the costs of calibration Vaisala offers optional 3 or 5-year pre-paid plans that not only provide protection from price increases, but also offer significant savings on calibration costs. For convenience, rental devices are available.

### 10.11 Locking or Unlocking DL Data Loggers

If your viewLinc monitoring system includes DL data loggers, viewLinc can be set to prevent other software (such as other installations of viewLinc or vLog) from being used to make changes to DL data loggers.

Lock DL data loggers to ensure other software cannot be used to:

- Modify data logger or channel description
- Enable or disable a channel
DL data loggers that are linked to vLog or Spectrum software prior to being connected to viewLinc are remote locked. You can unlink data loggers in vLog (refer to your vLog user guide for instructions), or undo the remote lock in viewLinc.

10.11.1 Locking a DL Data Logger to viewLinc

**Manage Devices**

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select one or multiple DL data loggers (CTRL+click).
3. Select Configure > Lock Device.
4. Select Save.

10.11.2 Unlocking a DL Data Logger from viewLinc

**Manage Devices**

DL data loggers with a pre-existing link to other software, a remote lock, can only be unlocked by a member of the Administrators Group.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select one or multiple DL data loggers (CTRL+click).
3. Select Configure > Unlock Device.
4. Select Unlock.

10.12 Clearing Historical Samples in DL Data Loggers

**Manage Devices**

If your system includes DL data loggers, use the clear history function to:

- Remove collected data on a DL data logger prior to sending it out for calibration or repair.
- Remove data collected on the DL data logger during calibration (you can also choose to ignore the interim data when you relink the device channel to a Location in viewLinc).
• Set DL data logger sampling to **Wrap When Full** (the required device setting for continuous data collection in viewLinc).

  Editing DL data logger properties (sample interval, sample warmup time, enable/disable channels, calibration settings) automatically clears data history.

• If you use older models of Vaisala DL data loggers (with gray case) which do not support timebase synchronization, clearing history automatically synchronizes the data logger clock with the viewLinc clock to correct any time drift.

  Over time, the clock time in a data logger begins to differ from the clock time in viewLinc; this is called time drift. Some time drift is expected over long data monitoring periods and is corrected through synchronization. Synchronized timing ensures more accurate data collection results.

  If your DL data loggers are already set to **Wrap When Full** (by a calibration team or using vLog), clearing of historical samples is not required.

1. In **Sites Manager** select the **Hosts and Devices** tab.
2. On the **Hosts and Devices** tree, select one or more DL data loggers (**CTRL**+click).
3. Select **Configure > Clear Historical Samples**.
4. At the warning prompt, select **Clear**.
5. At the confirmation prompt, select **OK**.

### 10.13 Clearing Tampered Security Status

Only a member of the default viewLinc **Administrators** group can perform this task.

If a DL data logger security status indicates tampered (in **Sites Manager** on the **Hosts and Devices** tab, **Properties** table, **Security Status** column), it is advised that a member of the **Administrators** group investigate the issue to determine the cause. For assistance, contact Vaisala Technical Support. Once the issue is identified and/or corrected (according to your company security policy) you can complete the following steps to reset the security status.

Change to the security status does not interrupt continuous monitoring.
1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select one or multiple DL data loggers (CTRL+click) you want to edit.
4. At the warning prompt, select Yes.
5. At the completion prompt, select OK.

10.14 Testing Network Communications

Only a member of the default viewLinc Administrators group can perform this task.

If you are receiving communication alarms, you may want to verify the stability of network communications.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select a host.
3. Select Configure > Ping Host. This may take up to a minute, depending on network traffic.
4. The Ping Results window indicates whether any communication failures were detected. Select OK to close the window.

10.15 Restarting viewLinc Enterprise Server

Only a member of the default viewLinc Administrators group can perform this task.

Occasionally, you may want to take viewLinc offline, or complete a reboot of your system (this does not affect the data collection). You can choose to restart or stop viewLinc temporarily.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select the viewLinc Enterprise Server, then select Configure > Restart viewLinc Enterprise Server.
3. Select Yes to confirm restart. An event message is generated and an email is sent to the IT Network Manager (specified in System Preferences > System Alarms).
10.16 Restarting viewLinc Device Host or Access Point

Manage Devices

You can restart a device host or an access point host to return it to factory settings. Restarting a device host or access point does not interrupt data collection on connected devices.

A system or host restart is recorded in the Event Log.

1. In Sites Manager select the Hosts and Devices tab.
2. On the Hosts and Devices tree, select a device host or access point, then select Configure > Restart [Device Host/Access Point]. A system-wide message alerts all logged in users that viewLinc is about to restart.
11. Frequently Asked Questions

11.1 Installation Tips

How does viewLinc upgrade data for use in viewLinc 5.1?

viewLinc automatically detects and converts your data. This is done transparently when you install viewLinc.

Upgrading from v3.6.1 to 5.1:

1. New top-level Zones are created based on the Zone structure you set up in the earlier version. In addition, a top-level Zone called ‘Unassigned’ is created for any unassigned Zones.
2. Locations are created for all active channels. The Location name is copied from the channel’s preferred description (the assigned alias or device description, depending on the system preference). Duplicate channels assigned to multiple Zones are ignored.
3. If the earlier version of viewLinc has restricted users configured, new permissions are applied, according to the following procedure:
   a. All users are assigned to the group Everyone.
   b. The group Everyone is assigned View permission to the top-level Zone, without inheriting View permission to the Locations in the top-level Zone.
   c. Users have their historical permission level automatically assigned to Zones.
   d. If previously granted permission to a channel, users have their historical permission level automatically assigned to the linked Location.
   e. Users are assigned to groups according to their historical permissions.
   f. Users with Full Control permission are automatically added to the default Administrators group.
4. Thresholds configured on active channels are applied to linked Locations.
5. Reports are upgraded to retrieve data from the new Locations/Zones.
6. POS displays are upgraded to retrieve data from the new Locations.

For more about upgrade changes, see What’s New for Upgrade Users (page 16).

How do I configure a firewall for viewLinc?

viewLinc will have exceptions added in the Domain and Private networks. Exceptions will not be added to Public networks. If this is required, they must be added manually. Please contact Vaisala Technical Support if you require assistance.

Why am I receiving a certificate error? Will it go away?

viewLinc requires certificate and security key files to establish a secure connection between network PCs and the viewLinc Enterprise Server. The files encrypt data and authenticate the viewLinc Web Server. If your system uses an automatically generated (viewLinc-signed) security certificate, users may see this error each time they log in, but it does not prevent user
from logging in. To prevent the warning from appearing, set each user's browser to trust the certificate (for example, open Chrome and go to Settings > Advanced > Privacy and Security > Manage Certificates). Alternatively, purchase a trusted certificate from a Certificate Authority (CA). Updating the viewLinc-signed certificate with a trusted certificate automatically prevents certificate errors from appearing.

**How do I install a certificate on local PCs?**

1. On each client PC, copy the certificate file (viewLinc-CA.crt) to any desktop location, then right-click on the file to select Install Certificate.

   For systems with many users, it may be more efficient to automate the installation of security certificates on client PCs. Contact your local IT group to determine whether distribution of certificates via Group Policy is an option.

2. In the Certificate Import Wizard Welcome screen, select Local Machine.

3. On the Certificate Store screen select Place all, click Browse, and then select Trusted Root Certification Authorities. If you receive an unknown publisher warning, click OK.

4. Click Finish, then Yes.

Users who are currently logged in to viewLinc must log out and then log in again to establish a secure browser session.

**My security certificate has expired. Will viewLinc still run? How do I renew it?**

If your certificate expires, you will start to receive a certificate warning in your browser, but viewLinc will continue to run. Use the certificate signing utility included on the viewLinc USB drive (SignCSR.exe) to generate a new viewLinc-signed certificate.

**How do I purchase a trusted certificate?**

Trusted certificates can be purchased from a Certificate Authority (CA). You will use a viewLinc-generated certificate request file (.csr) to purchase the trusted certificate.

1. If you generated viewLinc-signed certificate files during initial installation, go to step 5.
2. If you did not generate viewLinc-signed certificate files during initial installation, copy the certificate request software, CreateCSR.exe from the viewLinc installation USB drive to C:\Users\Public\Documents\Vaisala\Vaisala\viewLinc\config\keys folder.
3. Drag your existing key file, viewLinc-yyyy-mm-dd.key, and drop it onto CreateCSR.exe.
4. Answer the questions. This process generates a certificate request file (.csr).
5. In your ….\config\keys folder locate the generated certificate request file (viewLinc-yyyy-mm-dd.csr). The date in the filename reflects the date it was created.
6. Complete the purchasing steps required by your selected certificate signing authority.
7. When you receive the trusted certificate:
   • If the trusted certificate is received as a file, save the file as viewLinc-yyyy-mm-dd.crt.
   • If the trusted certificate is received as text, copy all the lines between BEGIN CERTIFICATE and END CERTIFICATE, and save as viewLinc-yyyy-mm-dd.crt.
8. Replace the existing viewLinc-yyyy-mm-dd.crt file with the new trusted file in the viewLinc config\keys folder.
9. Open Windows Services Manager.
10. Restart the viewLinc Web Server service.
    Users who are currently logged in to viewLinc must log out and then log in again to establish a secure browser session.

How do I update my security certificate and key files?

viewLinc stores certificate and key files in the viewLinc installation directory. You can update the files at any time:

1. Copy new files to the viewLinc Enterprise Server data directory (<data folder>\config\keys).
2. If the filenames are different from the original filenames, update the viewLinc.cfg file (<data folder>\config\viewLinc.cfg):

   ```
   [web]
   privatekeyfile = <newname>.key
   certificatefile = <newname>.crt
   ```

3. Restart viewLinc Web Server (see Restarting viewLinc Enterprise Server (page 219)).

11.2 Managing Data

What happens with the sampling in viewLinc when I attach a USB cable to a device for configuration etc.?

If a USB cable is attached to a device (i.e. the HMT140), the sampling is interrupted. When the USB cable is removed, sampling resumes. The sample timestamps start when the cable is removed, and are not an integral number of sample rate seconds since the previous sample. This should not affect operation. If the USB cable is attached for a long time, greater than twice the transmit rate, configuration alarms occur for missing historical data. They will clear once the sampling resumes.
My upload keeps failing when using a file to upload logger info. How do I upload successfully?

Check that you have separated your parameters with tabs, not spaces, commas, etc. Only parameters entered as tab-separated lines (.tsv format) work.

11.3 Managing Devices

How do I create a definitions file to add multiple device types at one time?

Create a .txt definitions file that identifies the device class and device properties (separating each field with a tab):

### Table 27  Definitions File Fields

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Properties to Define</th>
</tr>
</thead>
<tbody>
<tr>
<td>DL</td>
<td>Define the COM Port number to which a device is connected, for example: vcom com_port=101 vcom com_port=102 vcom com_port=103</td>
</tr>
<tr>
<td>HMT330</td>
<td>Define the following: sample_rate = the internal sample rate of the device timeout = the timeout for communication events connection = the type of connection, COM Port or TCP com_port = a COM Port number to which your device is connected (values for COM Port connections are user-defined) serialno = the serial number of your device udp_port = UDP Port number ip_port = the TCP Port (values for TCP connections, ip_address and ip_port, are user-defined)</td>
</tr>
<tr>
<td>HMT140</td>
<td>Common values for both TCP and COM Port connections: sample_rate = 10s 90s (default), 12m, 2h, 2d, or 12d</td>
</tr>
<tr>
<td></td>
<td>Optional values for COM Port connection: baud = 300, 2400, 4800, 9600, 19200 (default), 57600, or 115200 stopbits = 1 (default) or 2 databits = 7 or 8 (default) parity = odd, even or none (default)</td>
</tr>
<tr>
<td></td>
<td>Define the serial number: hmt140 serial_number</td>
</tr>
</tbody>
</table>
How do I add IP addresses for Vaisala devices using Ethernet devices (such as Digi, Moxa, or vNet devices)?

You don't. However you do assign IP addresses to your Vaisala devices. Because viewLinc communicates using COM ports, attaching Vaisala devices to the network using Ethernet/IP addresses requires the use of vNets or other Ethernet interface devices. Ethernet interface devices create virtual COM ports that allow Vaisala devices to communicate with viewLinc using Ethernet.

We recommend that you do not use dynamic IP addresses for your Vaisala devices; instead, use a reserved or static IP address (obtained from your IT department). IP addresses are assigned to Ethernet interface devices during driver configuration.

To learn more about using vNet devices, see www.vaisala.com/products. To learn more about Digi devices, see www.digi.com.

How can I connect via wireless or Ethernet with 300 Series Transmitters?

Internal LAN-1 Module (Ethernet): Allows single PTU300*, HMT330, DMT340 or MMT330 transmitter to connect to a viewLinc host computer via standard TCP/IP Ethernet network. LAN-1 Module is internally powered by the transmitter.

- **Internal WLAN-1 Module (802.11b/g Wi-Fi):** Allows single PTU300*, HMT330, DMT340 or MMT330 device to connect to a viewLinc server via standard 802.11b/g wireless networks. WLAN-1 Module is internally powered by the transmitter.
- **Single Port Ethernet Device:** Allows single PTU300, HMT330, DMT340 or MMT330 device to connect to a viewLinc server via standard TCP/IP Ethernet network. Requires installation of related device drivers and configuration of virtual COM ports on the viewLinc host computer. Requires transmitter configured with DB9 serial cable. Requires DB9-serial cable connection between Ethernet device and transmitter.
- **Multi-port Ethernet Device:** Allows multiple PTU300, HMT330, DMT340 or MMT330 devices to connect to a viewLinc server via standard TCP/IP Ethernet network. Requires installation of Ethernet device drivers and configuration of virtual COM ports on the viewLinc host computer. Allows for multiple PTU300, HMT330, DMT340 or MMT330 to connect to the host computer through a common TCP/IP network interface module. Requires transmitter configured with DB9 serial cable. Requires DB9-serial cable connection between Ethernet device and Vaisala transmitter.
- **Single Port Network Device (802.11b/g Wi-Fi):** Allows single PTU300, HMT330, DMT340 or MMT330 device to connect to the viewLinc host computer via standard 802.11b/g wireless networks. Requires installation of networking device drivers and configuration of virtual COM ports on viewLinc host computer. Requires transmitter configured with DB9 serial cable.
- **Multi-port Network Device (802.11b/g Wi-Fi):** Allows multiple PTU300, HMT330, DMT340 or MMT330 devices to be connect to the viewLinc server via standard 802.11b/g wireless networks. Requires installation of networking device drivers and configuration of virtual COM ports on viewLinc host computer. Allows for multiple data loggers to connect to the host server through common 802.11b/g wireless networks. Requires transmitter configured with DB9 serial cable.
- PTU300 can only support WLAN-1 and LAN-1 modules when no data logger modules are installed.
Check COM port assigned to a vNet or other Network Device:

1. From the Windows Control Panel, open Device Manager.
2. Expand Ports (COM & LPT) to see which COM ports are connected to which devices. By default, vNet devices are named CDL-VNET-P - model name.
3. For more detail, in Device Manager under Multiport serial adapters, right-click the device in question. Choose Properties, select the Advanced tab, and click Properties. On the left will be a list of the COM ports used for the device. To see which devices are controlled by viewLinc, open the System tab.

11.4 Predefined Settings

How does viewLinc select colors for reports?

When Location line colors are set to 'Auto', viewLinc assigns the next free color from a built in palette of colors. Colors are selected in the following order/sequence:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Black (0, 0, 0)</td>
</tr>
<tr>
<td>2</td>
<td>Red (255, 0, 0)</td>
</tr>
<tr>
<td>3</td>
<td>Green (0, 128, 0)</td>
</tr>
<tr>
<td>4</td>
<td>Orange (255, 165, 0)</td>
</tr>
<tr>
<td>5</td>
<td>Blue (0, 0, 255)</td>
</tr>
<tr>
<td>6</td>
<td>Yellow (255, 255, 0)</td>
</tr>
<tr>
<td>7</td>
<td>Purple (128, 0, 128)</td>
</tr>
<tr>
<td>8</td>
<td>Brown (150, 75, 0)</td>
</tr>
<tr>
<td>9</td>
<td>Grey (128, 128, 128)</td>
</tr>
<tr>
<td>10</td>
<td>Maroon (128, 0, 0)</td>
</tr>
<tr>
<td>11</td>
<td>Lime (0, 255, 0)</td>
</tr>
<tr>
<td>12</td>
<td>Tomato (255, 99, 71)</td>
</tr>
<tr>
<td>13</td>
<td>Azure (30, 127, 255)</td>
</tr>
<tr>
<td>14</td>
<td>Amber (255, 204, 0)</td>
</tr>
<tr>
<td>15</td>
<td>Byzantium (112, 41, 99)</td>
</tr>
<tr>
<td>16</td>
<td>Bronze (205, 127, 50)</td>
</tr>
<tr>
<td>17</td>
<td>Silver (192, 192, 192)</td>
</tr>
<tr>
<td>18</td>
<td>Crimson (220, 20, 60)</td>
</tr>
<tr>
<td>19</td>
<td>Emerald (80, 200, 120)</td>
</tr>
<tr>
<td>20</td>
<td>Coral (255, 127, 80)</td>
</tr>
</tbody>
</table>
What content variables can I add to a notification template?

Auto-generated content can be added to an email, SMS or voice template using macros. Not all macros are available in all notification templates.

Table 28  Notification Macros

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available to use with all custom notification templates</td>
<td></td>
</tr>
</tbody>
</table>
| [AlarmMessage] | Include the custom alarm message, if specified for the corresponding alarm template (threshold, device or system). If no alarm message available, no content is generated for the macro.  
You can add alarm messages to:  
• Threshold alarm settings (Sites Manager > Threshold Alarm Settings).
• Device alarm settings Sites Manager > Device Alarm Settings.
• System Event Log and Database Validation alarms System Preferences > System Alarms. |
| [Comments]  | Include the predefined or custom comment, if specified for the corresponding alarm template (threshold, device, or system). If no comment available, no content is generated for the macro.  
Predefined comments are created in System Preferences > Comments.  
You can add custom or predefined comments to:  
• Threshold alarm settings (Sites Manager > Threshold Alarm Settings).
• Device alarm settings (Sites Manager > Device Alarm Settings).
• System Event Log and Database Validation alarms (System Preferences > System Alarms). |
<p>| [Date]      | Date of alarm.                                                               |</p>
<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[AlarmObject]</td>
<td>Description of where alarm was triggered, from a channel, a data logger or host.</td>
</tr>
<tr>
<td>[AlarmType]</td>
<td>Type of alarm, Communication or Threshold.</td>
</tr>
<tr>
<td>[AlarmTimestamp]</td>
<td>Time alarm occurred.</td>
</tr>
<tr>
<td></td>
<td><strong>Alarm Acknowledgement Messages</strong></td>
</tr>
<tr>
<td>[Acknowledger]</td>
<td>Person who acknowledged the alarm.</td>
</tr>
<tr>
<td>[AcknowledgerAction]</td>
<td>What was done in response to the alarm.</td>
</tr>
<tr>
<td>[AcknowledgerComments]</td>
<td>Comment entered by person acknowledging the alarm.</td>
</tr>
<tr>
<td>[AcknowledgeTimestamp]</td>
<td>Time alarm was acknowledged.</td>
</tr>
<tr>
<td>[AlarmID]</td>
<td>Alarm ticket ID (used for remote acknowledgements).</td>
</tr>
<tr>
<td></td>
<td><strong>Threshold Alarms</strong></td>
</tr>
<tr>
<td>[AlarmValue]</td>
<td>Location value when alarm occurred.</td>
</tr>
<tr>
<td>[MaxAlarmValue]</td>
<td>Maximum Location alarm value during alarm period.</td>
</tr>
<tr>
<td>[CalibrationUrl]</td>
<td>Calibration Services website address.</td>
</tr>
<tr>
<td>[LocationValue]</td>
<td>Location alarm value when email issued.</td>
</tr>
<tr>
<td>[ThresholdCondition]</td>
<td>Summary of the threshold condition.</td>
</tr>
<tr>
<td>[LocationTimestamp]</td>
<td>Device Communication Alarms</td>
</tr>
<tr>
<td>[DeviceChannelsSummary]</td>
<td>Brief description of all data logger channels associated with the alarm event.</td>
</tr>
<tr>
<td>[LocationSummary]</td>
<td>List of data logger channels in alarm state.</td>
</tr>
<tr>
<td></td>
<td><strong>Host Communication Alarms</strong></td>
</tr>
<tr>
<td>[DeviceHostDevicesSummary]</td>
<td>Brief description of all data loggers on a host, associated with the alarm event.</td>
</tr>
<tr>
<td>[DeviceChannelsSummary]</td>
<td>Brief description of all data logger channels associated with the alarm event.</td>
</tr>
</tbody>
</table>
11.5 Troubleshooting Tips

Why can’t I log in to viewLinc using the correct username and password

Ensure the viewLinc Enterprise Server service is running: If viewLinc is not running, a blue screen and status message appears on your desktop display. If the viewLinc Web service is not running, you will see a browser error message. In Windows Control Panel, choose Administrative Tools | Services, then find “viewLinc Enterprise Server” on the list and rightclick to select Start.

Has your domain name changed? If you are using Windows authentication, ensure your domain name matches your current log in password.

Why can’t I see any Zones and Locations?

viewLinc Zones and Locations are only visible if a group has been granted permission to view them. viewLinc Administrators set up group permissions on Zones. Permission to a Zone is required before you can access Zones and Locations in Sites Manager, Sites, Alarms or Events windows.

Why can’t I access all viewLinc navigation pane windows?

viewLinc Administrators set up group rights to functional areas of viewLinc. If you require additional rights to access another viewLinc window, contact your Administrator.

Why am I receiving a device configuration alarm indicating a low battery alarm when I know the batteries are new?

If you are using an older model DL data logger, some low battery alarms are triggered even when the battery is not the issue. Look up the event corresponding to the device configuration alarm in the Events window, and review the event details. For more assistance, contact Vaisala Technical Support.

I’m receiving communication alarms in viewLinc. I think my network device or Vaisala device has stopped responding. What do I do?

1. Make sure your data loggers and transmitters are plugged in and/or batteries are full.
2. Make sure your network devices are connected to a power supply and the power supply is plugged in. On a Digi or vNet network device, the power light on the front of the device should be solid red.
3. Ensure each device is connected to and communicating with the network. Try to connect with the device (see Testing Network Communications (page 219)).
4. If there is communication between the device and the network, check that the Vaisala-supplied cable is connected properly. If the light is solid red, there is a problem with the network device or device cable. Make sure your device has been configured to use RealPort (see http://www.vaisala.com/en/lifescience). If this still doesn’t fix the problem, go to step 6.

5. If the light is working correctly but you are still receiving communication alarms, open Windows Device Manager on the viewLinc computer and ensure the device is still installed:
   b. Under the Multiport serial adaptor category in Device Manager, look for duplicate drivers using the same COM port.

6. If the light on the cable is not working properly, open vLog and determine if the cable can communicate with the Vaisala device. If there is a problem with the device communicating with the vLog graphing application, it is likely the device or device cable is not functioning properly. Try connecting the device to a new vNet or Digi networking device, or to a computer using USB, and see if you can connect to it from vLog.

How can I stop alarming while we reconfigure a storage area?

Table 29  Tips for Managing Alarms

<table>
<thead>
<tr>
<th>What do you want to do?</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop Location threshold alarming temporarily.</td>
<td>Pause/Resume</td>
<td>You can pause Location threshold alarming for up to 24 hours (threshold alarming resumes automatically after 24 hours). To pause Location threshold alarming for a longer period, disable the threshold alarm template (affects all Locations using the template). Sites &gt; Zones and Locations &gt; Alarming</td>
</tr>
<tr>
<td>Stop device alarming temporarily.</td>
<td>Pause/Resume</td>
<td>Stop device alarming up to 24 hours (device alarming resumes automatically after 24 hours). Affects the device and all device channels (and linked Locations). Sites &gt; Zones and Locations &gt; Alarming</td>
</tr>
<tr>
<td>Stop host alarming temporarily.</td>
<td>Pause/Resume</td>
<td>Stop host alarming temporarily up to 24 hours (host alarming resumes automatically after 24 hours). Affects the host, all devices connected to the host, and all device channels (and linked Locations). Sites &gt; Zones and Locations &gt; Alarming</td>
</tr>
<tr>
<td>Stop all threshold alarming for more than 24 hours, at a specific Location or Zone.</td>
<td>Disable/Enable</td>
<td>Stop all threshold alarming for the selected Location or Zone. Sites Manager &gt; Threshold Alarm Settings &gt; Edit</td>
</tr>
<tr>
<td>What do you want to do?</td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Stop all threshold alarming for more than 24 hours, at several Locations.</td>
<td>Disable/Enable</td>
<td>Stop threshold alarming at all Locations using the selected threshold alarm template. <a href="#">Alarm Templates &gt; Threshold Alarms &gt; Properties</a></td>
</tr>
<tr>
<td>Ignore one or more threshold levels, at several Locations.</td>
<td>Disable/Enable</td>
<td>Prevent a threshold level from being recognized by all Locations using the template. <a href="#">Alarm Templates &gt; Threshold Alarms &gt; Edit &gt; Deselect level</a></td>
</tr>
<tr>
<td>Delete a threshold alarm template.</td>
<td>Threshold alarm templates cannot be deleted. They can be deactivated or disabled at the Locations where they are applied.</td>
<td>Deactivate/Activate</td>
</tr>
<tr>
<td>Delete a Location.</td>
<td>Disabled threshold settings remain with the Location, but are not used for monitoring or reporting.</td>
<td>Deactivate/Activate</td>
</tr>
<tr>
<td>Disable/Enable</td>
<td>Sites Manager &gt; Threshold Alarm Settings</td>
<td></td>
</tr>
<tr>
<td>Delete a device or host.</td>
<td>Device continues to record data in viewLinc, but hidden from display in viewLinc UI (you cannot delete devices for audit trail purposes).</td>
<td>Deactivate/Activate</td>
</tr>
</tbody>
</table>

### Vaisala OPC UA Server Service not running

Check your Group Security Policy settings to make sure your user account has the necessary permission to run software on the installation server.

By default, both viewLinc Enterprise Server and Vaisala OPC UA Server software are installed as Windows services. These services are only permitted to run on the LOCAL SYSTEM user account, the Windows default account which has full control on the system. If your computer system is configured with custom security settings, the viewLinc/Vaisala OPC UA services may need additional configuration to run.

1. Go to the Windows **Start** menu and open or type **Services**.
2. Locate the Vaisala OPC UA Server Service and open the Properties window.
3. On the Log on tab select This account, then enter an authorized username and password. The user must have read and execute permission on all installed program files sub folders, inheritable Full Control access on all sub folders, and network access rights to allow it to connect to other systems.

11.5.1 Responding to Alarms

Table 30  Tips for Responding to Alarms

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>How to respond</th>
</tr>
</thead>
</table>
| Configuration Alarm - Unable to receive packet from COM port. | If you are using a Digi device, there may be a physical device issue. Try swapping equipment to test the following:
• Port on the Digi leading to the data logger
• CAT5 cable running to the data logger
• CAT5 to serial adapter used to connect the cable to the data logger |
| Configuration Alarm - Unable to receive packet from COM port(some bytes missing). | If you are using a vNet device, viewLinc may not detect a data logger attached to it. Check for loose connections, or remove the data logger from the vNet and inspect for broken or bent PINS. If the issue continues, try swapping the data logger or vNet to determine which piece is not functioning. |
| Configuration Alarm - Missing Historical Data. | RFL100 data logger: This is a normal alarm when first setting up RFL devices, and could last 24 hours or more. If it continues beyond that, this could indicate a wireless issue with the RFL connecting to the AP10. Try moving the RFL100 closer to the AP10.
HMT140 data logger: The wireless connectivity may be weak or there is congestion on your network. If the alarm persists, try using the HMT140 Utility software to identify the problem when the device is in an alarm state. |
| Configuration Alarm - Sensor Failure. | HMT140 or RFL100 data loggers: If your device is using an HMP110 probe, it could indicate damage to the probe or the device. We would recommend first powering down the device, then disconnecting the probe to inspect for damage. If the problem continues after reconnecting the probe, try swapping with another functioning probe (to see if the problem follows the probe, or stays with the device). |
| Configuration Alarm - Database validation failed. | If an external application has corrupted any viewLinc files, or has broken the digital locks on the files, viewLinc will attempt to correct the corruption and trigger this alarm. Severe enough corruption could cause viewLinc not to start up, and you should restore the system from a known working and tested backup. Possible software suspects include anti-virus, security or backup applications. Contact your IT team to identify processes that preceded the alarm. |
### Alarm Message | How to respond
---|---
Configuration Alarm - **Data sample inconsistency.** | Discrepancy between real-time and historical samples on a device. Check cables, low batteries, or malfunctioning data logger. Make sure that timebase synchronization is enabled ([System Preferences](#)), or clear the device ([Sites Manager > Hosts and Devices](#)).

Failure to generate a report or report generation aborted | Review the number of reports in the queue. Very large reports or excess report generation may slow down performance. Refer to the [viewLinc Datasheet](#) for system performance specifications.

System running slow | Check for unacknowledged alarms. Removing the acknowledgment requirement can stop the build-up of alarm notifications from re-occurring.
Glossary

access point (AP)
A host device that enables communication between wired and wireless parts of a network. Access points typically use specific network standards. Also known as a gateway. Required to connect RFL100-series data loggers to viewLinc.

Acknowledge Alarms permission
A permission level which allows a group to view Locations and acknowledge Location alarms.

acknowledgement
User response to an alarm event.

Administrators group
Members of the Administrator’s Group have all rights, plus extra system-level rights which allow them to: undo Remote-lock on DL data loggers; restart viewLinc; test network communications; acknowledge inactive alarms; acknowledge system alarms; correct security status; add users to the Administrator group; edit user profiles of Administrators group members.

alarm condition
Environmental state which initiates an alarm event.

alarm event
A record of an alarm condition.

alarm notification template
Defines who is notified, when and how. Can be applied to a Location using a threshold template, or a device using a device alarm template.

Alarm off margin
Also known as deadband. An active alarm will not turn off if conditions fluctuate within set margin.

Alarms window
Window used to monitor active alarms.

Alarm Templates window
Window used to create threshold, device, and notification alarm templates; Define content for email and SMS alarm messages; Create schedules.

ANSI characters
Keyboard characters for all supported European languages. See https://www.w3schools.com.

audit trail
Continuous record of all changes made to a device or the viewLinc system. The viewLinc audit trail is recorded in the Event Log.
calibration
The process of checking and correcting the reading of any instrument giving measurements.

channel
A device data transmission path. A device may have more than one channel available.

child
Location which resides within a Zone, or a sub-zone that resides within a Zone.

Communication alarm
Notification that there is a problem with the transfer of data.

Configuration alarm
Notification of an internal system error.

Configure Alarms permission
A permission level which allows a group to view Locations, acknowledge Location alarms, and add or modify Location threshold alarms.

continuous monitoring
Unbroken record of environmental surveillance.

dashboard
An image file that provides a visual reference to a physical space being monitored.

deadband
Alarm off margin. An active alarm will not turn off if conditions fluctuate within the set margin.

device
Data collection hardware connected to your network (data loggers, transmitters).

device hosts
Additional servers running viewLinc device host software. Allows for easier management of connected devices and greater network stability.

drift
When data logger time gradually deviates from viewLinc server time.

Enterprise Server
Required Vaisala viewLinc monitoring system software.

Events window
Window used to record all system activities. Functions include: add comments about events, generate reports on specific event periods.

excursion
When Location conditions exceed or deviate outside specified threshold limits.

Full Control permission
A permission level which allows a group to view Locations, acknowledge Location alarms, configure Location threshold alarms, and modify or delete Zones and Locations.
**inherit**
To automatically grant a permission level assigned to a top-level folder to its sub-zones or Locations.

**IQOQ**
Installation Qualification / Operation Qualification protocol document used for system validation.

**IT network manager**
The person responsible for maintaining your network, including connected software and hardware.

**Location**
A viewLinc data collection point, such as a freezer or storage shelf, connected to a device channel that is part of the Vaisala viewLinc Monitoring System.

**Location alarm**
Notification that a threshold level has been exceeded or communication problem has occurred at point of data collection.

**macros**
Predefined text strings you can add to custom email, SMS and voice alarm notification message templates.

**Manage Alarm Templates**
A right assigned to a group to allow configuration of alarm templates (for threshold alarms, device alarms, alarm notifications, and notification content).

**Manage Devices**
A right assigned to a group to allow addition or removal of devices, configure and edit device settings.

**Manage Events**
A right assigned to a group to allow addition of custom events, add comments to events, print and export event details.

**Manage Reports**
A right assigned to a group to allow addition and configuration of reports created by others (all users can add, edit and delete their own reports).

**Manage Sites**
A right assigned to a group to allow addition or modification of Zones and Locations, add threshold alarms, permissions, and schedules.

**Manage System**
A right assigned to a group to allow configuration of all system preferences, add users and groups, add schedules and predefined comments.

**Manage Views**
A right assigned to a group to create new views, add or rename Zones, define access permissions for Zones, add dashboard images, share and manage trends.
**MKT Activation Energy**  
Mean Kinetic Temperature

**Overview window**  
Window used to display user-defined and shared views, specific collections of Zones and Locations. Set a default view to open automatically at login, generate view-specific reports and trends.

**parent**  
Zone which includes sub-zones or Locations

**permission**  
An access level which allows groups to view, configure or manage specific Locations and Zones.

**PIN**  
Personal Identification Number

**PoE**  
Power over Ethernet. Allows one cable to provide both data and electrical power to devices such as wireless access points. Benefits of PoE include longer cable lengths and elimination of the need for nearby power outlets.

**real-time data**  
viewLinc collects real-time data from devices more frequently than a device’s set sample rate (usually in 10 second intervals).

**report owner**  
Individual who created a report.

**Reports window**  
Generate and create reports; download user-generated and shared reports.

**RFL**  
VaiNet wireless data logger.

**rights**  
Rights allow group access to viewLinc windows and additional window functions. All users have Manage Views right, which allows access to the basic functions in Overview, Sites, Reports, Alarms, Views Manager, and Events windows. Permissions must be granted for groups to see and perform functions on Zones and Locations in these windows.

**ROC**  
Rate of Change. Measures the amount of variation within one (1) minute. For example, you may want to know how quickly the temperature in a refrigerator rises when the door is opened.

**sample**  
One (1) recorded and time-stamped data logger measurement.

**sampling rate**  
Frequency of samples recorded over time.
sites
Term used to refer to a collection of Zones and Locations.

Sites Manager window
Window used to manage Zones, Locations, devices, and hosts. Functions include:
Manage hosts and devices, create Zones and Locations, configure permissions, set
Location threshold and notification settings, load dashboard images.

Sites window
Windows used to display Zones and Locations a group is permitted to view. Functions
include: pause alarming, generate quick reports, monitor conditions on the dashboard,
build trends.

System alarm
Notification when viewLinc detects changes made outside standard viewLinc operation
(such as possible database tampering).

System Preferences window
Define global settings, such as: system language, enable remote acknowledgement, set
up audible alarming, enable use of schedules, set device default settings, enable
comments.

threshold
A level that when exceeded, initiates a threshold alarm.

Threshold alarm
Notification that a threshold level has been exceeded.

TLS (SSL)
Transport Layer Security (formerly Secure Sockets Layer). Communications protocol
used to secure communications between network servers and web browsers.

VaiNet devices
Vaisala wireless communication devices that use LoRa technology.

Validation alarm
Notification when a problem with data collection is detected.

view
User- or group-specific collection of Locations. Created in Views Manager, available in
the Overview window.

View permission
A permission level which allows a group to view Locations, acknowledge Location
alarms, configure Location threshold alarms, and modify or delete Zones and Locations.

vLog
Configuration software shipped with DL data loggers (prior to viewLinc 5).

Wrap when full
This setting ensures a device will continue to record data, overwriting the earliest
recorded data with new history when it reaches capacity. No interruption in data
recording.
Zone
A collection of Locations being monitored. Zones can be divided into sub-zones.
Index

Symbols
140-series Wi-Fi data loggers........................................ 49
alias.............................................................................. 55
timeout......................................................................... 55
transmit period......................................................... 55
300-series transmitters
adding......................................................................... 46
alias.............................................................................. 55
sample rate.................................................................. 55
timeout......................................................................... 55

A
access
to Locations............................................................... 126
to views....................................................................... 133
access points................................................................ 36
adding.......................................................................... 46
communication alarms............................................. 79
configuration alarms.................................................. 79
releasing devices...................................................... 208
restarting..................................................................... 220
Acknowledge Alarms permission.................................. 126
acknowledging alarms............................................... 109, 152
about.......................................................................... 153
e-mail/SMS/voice....................................................... 109
inactive alarms.......................................................... 148, 157
system alarms............................................................ 148
active alarms, viewing............................................. 149
adding.......................................................................... 49
300 series transmitters............................................... 46
access point hosts.................................................... 46
comments.................................................................. 122
comments to events.................................................. 163
custom events........................................................... 164
dashboard images.................................................... 68
device host server...................................................... 45
devices....................................................................... 44, 46–48, 50
DL data loggers.......................................................... 48
groups......................................................................... 75
hosts.......................................................................... 45
license keys............................................................... 114
Locations..................................................................... 62, 202
Modbus devices........................................................ 210, 212
multiple devices....................................................... 50
permissions.................................................................. 126
reports......................................................................... 178
schedules.................................................................... 110, 129
security certificate...................................................... 30
signal towers............................................................. 135
sub-zones.................................................................... 61
thresholds to Locations.............................................. 82
units............................................................................ 116
users........................................................................... 76
Vaisala OPC UA Server................................................ 141
views.......................................................................... 132
Zones........................................................................... 61
adding/removing columns...................................... 146
adding()....................................................................... 47
adding licensed features.......................................... 15
adjusting
dashboard layout....................................................... 69
scale value in a trend............................................... 170
administrator, notifying............................................. 117
Administrators group
rights......................................................................... 74
system rights............................................................. 73
alarm messages......................................................... 232
alarm notifications..................................................... 152, 232
audible....................................................................... 152, 232
command................................................................... 96, 110
e-mail.......................................................................... 149
email......................................................................... 149
launching an application or device............................ 149
scheduling................................................................. 128
SMS............................................................................ 149
SMS web service....................................................... 97
voice.......................................................................... 97
ways to acknowledge ........................................ 109
alarm notification templates ................................. 79, 96
adding to device alarms ....................................... 103
adding to Location threshold alarms ..................... 101
adding to system alarms ..................................... 121
creating ................................................................. 98
editing ...................................................................... 104
alarm off margin ................................................... 82
alarm reports .......................................................... 79
creating .................................................................... 178, 185
deactivating .......................................................... 177
printing current data .............................................. 151
reactivating .............................................................. 178
alarms ...................................................................... 79
acknowledging ....................................................... 153
audible ..................................................................... 76, 96, 110, 158
calibration .............................................................. 88, 112
communication ...................................................... 88, 90, 229
configuration .......................................................... 79, 91
deactivating/activating .......................................... 87
device ...................................................................... 88
disable device alarming ......................................... 204
disabling/enabling ................................................. 205, 206
editing device alarm settings .................................. 95
editing threshold alarm settings ............................ 86
host ........................................................................... 79
identifying ............................................................... 149
inactive ..................................................................... 148
low battery .............................................................. 229
message content ...................................................... 79
monitoring .............................................................. 147, 148
multiple notifications ............................................. 96
pausing .................................................................... 159, 161
reporting ................................................................. 151
responding to ........................................................ 232
resume alarming ..................................................... 162
system ..................................................................... 121
threshold ................................................................. 79, 81, 86
validation .................................................................. 88
viewing in Overview window ................................. 88
viewing in Sites window ......................................... 143
Alarms window .......................................................... 88
acknowledging alarms ........................................... 157
monitoring alarms .................................................. 148
printing current alarm data ..................................... 151
alarm templates .......................................................... 79
about ........................................................................ 96, 98
device alarms .......................................................... 92, 95
device alarms .......................................................... 92, 95
e-mail/SMS/voice content ....................................... 104
schedules ................................................................. 129
threshold alarms ..................................................... 81
aliases for channels .................................................. 57
for devices .............................................................. 55
using ................................................................. 107, 112
android phones ....................................................... 9
API-license key, entering ........................................ 114
applying ................................................................. 114
alarm notification templates to thresholds, 101
threshold alarm templates to Locations, 84
assigning permissions ............................................... 126
rights ........................................................................ 74
audible alarming ..................................................... 135
audible alarms .......................................................... 96
enabling/disabling .................................................. 110
for a user ................................................................. 76
responding to ........................................................ 158
signal towers .......................................................... 135
turning off .............................................................. 158
audit trail ................................................................. 162
authentication .......................................................... 10
availability of generated reports ............................. 176
B-backing up ............................................................. 224
blocks per beacon........................................................................55
browsers
opening multiple trends.........................................................172
supported.................................................................................9, 11
building
dashboards..............................................................................67
trends.......................................................................................167
views.......................................................................................133
C
calibration
about......................................................................................214
alarms.......................................................................................88, 112
duration, setting.........................................................................215
editing channel settings.......................................................214
editing device settings.............................................................215
request off-site service.........................................................216
request on-site service.............................................................216
calibration alarms.....................................................................79
calling tree.................................................................................97
calling trees.............................................................................139
canceling a generated report................................................176
celsius or fahrenheit.................................................................111
certificates................................................................................141
fixing errors..............................................................................221
generating..................................................................................10
installing with............................................................................30
security.....................................................................................29
changing
alarm notification templates......................................................104
dashboard display.......................................................................69
default view..............................................................................134
device alarm settings.................................................................95
devices........................................................................................209
linked Locations.......................................................................201
Location alarm settings.............................................................86
monitored areas........................................................................201
threshold alarm settings............................................................86
trends.......................................................................................170
unit display.................................................................................116
channels
alias......................................................................................107, 112
description...............................................................................57
enable/disable.............................................................................55
finding linked Location.............................................................66
linking to Locations..................................................................63, 64, 199, 202
naming.....................................................................................64
unit display.................................................................................116
unlinking/relinking to Locations..............................................64, 200
viewing link history...................................................................65
Channels
finding.....................................................................................66
checklist
for site preparation..................................................................29
clearing
DL data logger history.............................................................217
historical samples.....................................................................217
color
default palette..........................................................................226
selecting for reports..................................................................179
columns
add/remove..............................................................................146
hiding.......................................................................................146
sort order....................................................................................146
command notifications
adding......................................................................................98
comments
about......................................................................................122
adding on a report.....................................................................185
adding to Events..........................................................................163
predefined.................................................................................123
viewing in event log....................................................................162
communication alarms
device or host..........................................................................88
disabling/enabling.....................................................................206
pausing......................................................................................159
setting for hosts..........................................................................90

Index

243
troubleshooting................................................. 229
communications
network test......................................................... 219
COM Ports
viewing.................................................................. 224
conditions
identifying................................................................ 149
configuration alarms
device or host....................................................... 88
setting on hosts..................................................... 91
Configure Alarms permission............................ 126
configuring
devices.................................................................... 50
viewLinc........................................................... 38, 39
connecting
DL data loggers.................................................... 23
DL Data Loggers........................................... 24, 25
Modbus devices........................................... 23, 210
connection type
IMAP........................................................................ 117
POP3....................................................................... 117
contact information
Vaisala Calibration Services.................................. 214
content of email/SMS/voice messages............ 104
controlling access to Locations/Zones........... 124
copying
alarm notification templates.............................. 98
device alarm templates......................................... 92
threshold alarm settings...................................... 84
threshold alarm templates................................... 82
correcting device security status
DL data loggers.................................................... 218
creating
alarm notification templates.............................. 98
alarm report.......................................................... 185
dashboards.............................................................. 68
device alarm templates......................................... 92
e-mail/SMS/voice message content............... 104
groups..................................................................... 75
Locations.............................................................. 62
reports.................................................................... 176, 178
schedules.................................................................. 110
sub-zones.................................................................. 61
threshold alarm templates................................ 84
trends....................................................................... 167
user profiles................................................................ 76
views....................................................................... 132, 133
Zones....................................................................... 61, 62
custom
e-mail/SMS/voice message content............... 104
events....................................................................... 164
reports.................................................................... 178, 185

D
dashboards
about.................................................................. 67, 150
adding data points............................................... 68
adding images....................................................... 68
changing font....................................................... 69
deleting data points............................................... 71
deleting images....................................................... 71
find linked Location............................................ 151
modifying data display........................................ 69
reading Location data........................................... 150
view trend.............................................................. 151
data
clearing history.................................................... 217
database validation alarms................................. 80
data loggers
adding................................................................. 44
channel properties............................................... 57
clearing history.................................................... 217
configuring with viewLinc................................. 55
connecting.............................................................. 21
correcting security status................................ 218
description and alias........................................... 55
device alarms......................................................... 88, 95
setting up.............................................................. 21
supported.............................................................. 11
swapping.............................................................. 209
timebase synchronization.........................................................113
data trends..................................................................................167
deactivating
Locations......................................................................................203
reports..........................................................................................177
threshold alarms...........................................................................87
threshold alarm settings..............................................................87
deactivating/reactivating
devices/hosts..................................................................................207
groups............................................................................................196
Locations......................................................................................202
users...............................................................................................195
Zones..............................................................................................202
decimal places..................................................................................197
default application file locations..................................................14
definitions view................................................................................134
definitions file...................................................................................50
delay
alarm notification..............................................................................98
deleting
dashboard images or data points..................................................71
Locations......................................................................................202, 203
permission to Zones or Locations..................................................127
reports............................................................................................177, 178
units.................................................................................................116
users...............................................................................................195
Zones..............................................................................................200, 202, 204
device alarms
about..............................................................................................79, 88
applying a notification template..................................................103
communication...............................................................................88, 90
configuration..................................................................................88, 91
device alarm templates...................................................................88, 91
enabling/disabling..........................................................................92, 94
definitions file...................................................................................50
device alarm templates
applying...........................................................................................94
creating...........................................................................................92, 95
editing...........................................................................................95
device hosts
adding...........................................................................................45
alarm types......................................................................................88
pause alarming................................................................................161
resume alarming..............................................................................162
Device Host software.........................................................................9, 30
devices
adding...........................................................................................15
adding AP hosts..............................................................................45
adding data loggers or transmitters..............................................48, 50
adding Modbus................................................................................210
adding PC hosts..............................................................................46
alarms...............................................................................................88
alarm settings...................................................................................95
alarm templates..............................................................................92
alias.................................................................................................107, 112
calibration.......................................................................................216
calibration alarms...........................................................................79, 88, 112
calibration duration..........................................................................215
calibration properties......................................................................214, 215
channel calibration properties......................................................214
channel properties...........................................................................57
clearing history................................................................................217
communication alarms.....................................................................79
configuration alarms.........................................................................88
configuring.......................................................................................50
connecting.........................................................................................21
correct security status......................................................................218
deactivating/reactivating..................................................................207
decimal places..................................................................................197
definitions file...................................................................................50
discoversing.....................................................................................47, 50
discovery............................................................................................55
installing...........................................................................................21
license key, entering..........................................................................114
locking...............................................................................................217
locking/unlocking............................................................................216
managing...........................................................................................44
Modbus.............................................................................................212
pausing device or host alarms.......................................................161
properties.........................................................................................51
releasing..........................................................................................208
removing..............................................................207
resume alarming.................................................162
RFL data loggers...............................................208
supported................................................................ 11
swapping.............................................................209
unlocking.............................................................. 217
validation alarms..................................................79
devices()...................................................................47
Digi devices
troubleshooting................................................. 224
disabling/enabling
audible alarms..................................................... 110
communication alarms.......................................206
device alarms....................................................... 206
schedules functionality....................................... 110
threshold alarm levels........................................ 205
threshold alarms.................................................. 205
viewLinc Aware Service.....................................113
discover after scan.............................................. 55
discovering
devices...............................................................46, 47, 50
displaying viewLinc on a remote terminal... 194
DL Data Loggers
adding.....................................................................48
discovering............................................................ 47
installing with serial cable................................. 25
installing with USB cable.................................... 24
sample interval..................................................... 55
warmup time.........................................................55
downloading reports........................................... 176
drag and drop
to add Locations to a dashboard....................... 68
to create a trend.................................................. 167
to link Locations.................................................. 64
drivers
USB........................................................................ 24

e

channel properties.............................................57
device alarm settings..........................................95
device alarm templates................................. 95
device properties................................................ 55
email/SMS/voice message content............... 104
host properties................................................... 53
Location or Zone properties.......................... 197
Modbus device settings.................................... 214
RFL data logger properties.............................. 55
threshold alarm settings................................ 86
threshold templates.......................................... 86
user accounts................................................... 195
Zones and Locations........................................ 199
eLearning........................................................... 27
e-mail
message content................................................104
e-mail notifications.......................................... 152
acknowledgement............................................. 109
message content............................................. 104
receiving........................................................... 149
server settings................................................... 117
templates........................................................... 98
e-mail settings
IT network administrator address...................117
notification settings......................................... 117
enabling/disabling
audible alarms.................................................... 110
communication alarms.................................... 206
device alarms..................................................... 206
schedules functionality.................................... 204, 206
threshold alarm levels...................................... 205
threshold alarms................................................ 205
viewLinc Aware Service...................................113
enabling licensed features............................. 114
Enterprise Server
about.................................................................... 9
security certificate................................. 30
errors
certificate.......................................................... 221
Index

escalation path....................................................... 98
Ethernet interfaces
  connecting with....................................................23
troubleshooting....................................................224
event log validation alarms.................................80
Events window
  about......................................................................162
  adding comments.............................................. 163
  adding custom events...................................... 164
  exporting.............................................................. 165
  printing........................................................................164
  viewing events log............................................. 162
Excel reports..........................................................188
exporting
  alarm data, current............................................. 151
event logs.....................................................................165
Location alarms report.......................................... 178
F
features......................................................................10
file locations............................................................. 14
find
  assigned permissions........................................ 128
  dashboard Locations.......................................... 151
  linked Location..................................................... 66
  search tool............................................................ 145
firewall..................................................................... 221
fix security status................................................... 218
fonts, changing....................................................... 69
Full Control permission........................................ 126
G
generating reports
  about...................................................................... 174
  download status................................................... 176
  quick reports....................................................... 176
getting started
  eLearning............................................................. 27
  overview.............................................................. 9, 143
  planning worksheet............................................ 39
setup checklist....................................................... 29
upgrading.............................................................. 16
what's new............................................................. 15
graphing a trend.................................................... 167
groups
  access to Locations and Zones............................ 126
  access to views................................................... 133
  creating.............................................................. 75
  deactivating/reactivating.................................. 196
  reactivating....................................................... 196
  rights.................................................................... 74
GxP-compliance...................................................... 111
H
hardware..................................................................... 9
hiding/showing
  columns................................................................... 146
deactivated devices/hosts...................................... 207
deactivated groups.................................................. 196
deactivated Locations/Zones.................................. 203
deactivated users................................................... 195
history
  clearing.................................................................. 217
  of linked channel................................................ 65
HMT110 probe......................................................... 57
HMT140 Series Wi-Fi Data Loggers...................... 49
installing............................................................... 22
max blocks per beacon......................................... 55
properties.............................................................. 57
sampling in viewLinc............................................ 223
timeout................................................................... 55
transmit period...................................................... 55
HMT140 Series Wi-Fi Data Loggers()........................ 47
host alarms........................................................... 88
hosts
  adding................................................................... 45, 46
  communication alarms..................................... 79, 90
  configuration alarms........................................ 79, 91
  deactivating/reactivating.................................. 207
  editing properties.............................................. 53
installing viewLinc Device Host............... 32
restarting.....................................................220
testing network communications..............219

I
identifying alarm conditions....................149
image requirements for dashboards.............68
IMAP...............................................................117
inactive alarms
acknowledging.............................................157
inherited permissions.........................124, 127
installation..................................................36
devices..............................................................35
verifying connectivity............................37
installation, system test.........................42
installing
device hosts.................................................32
Device Host software.................................30
DL data loggers...........................................23
DL Data Loggers........................................24, 25
Modbus devices........................................23
upgrade a new server...............................34
viewLinc as an upgrade.........................32
viewLinc Enterprise Server software........30
vNet Devices................................................23
Internet browsers, versions supported........11
iphone.............................................................9
items on the dashboard
display options..........................................69
find linked Location...................................151
view trend.....................................................151
IT network administrator.....................121

L
language
in reports..................................................174
message content.........................................104
on screen......................................................36
setting for users..........................................76
supported in viewLinc...............................115
learning about viewLinc.............................20
legacy user rights.................................16, 74
license keys
entering......................................................114
linked channel/Location, finding.............66, 145
link history, viewing...............................65
linking/unlinking channels and Locations
62–64,.............................................................199
Location data on dashboards.............150
Location history reports
creating......................................................178, 179
deactivating/reactivating.........................177
reactivating..................................................178
Locations
about..........................................................60
adding alarm notification schedules........130
adding schedules.......................................129
adding threshold alarms..........................84
alarms status...............................................148
applying alarm notification templates.......101
assigning permissions..............................126
changing linked channel.........................199
changing threshold alarm settings...........86
dashboards..................................................67
deactivating...............................................203
deleting......................................................202
editing properties........................................197
finding..................................................66, 151
linking/unlinking channels......................63, 64
moving.........................................................202
pausing threshold alarming......................159
permissions.................................................124
reactivating...............................................203
renaming.....................................................199
reporting....................................................179
resuming threshold alarming...................162
searching for..............................................145
setting up..................................................60, 62
status..........................................................197
swapping devices....................................209
adding to Location threshold alarm settings
101
customizing.........................................................226

O
off-site calibration................................................216
on-site calibration................................................ 216
OPC UA Server
license key, entering........................................... 114
licensing.................................................................. 15
organizing
Locations and Zones............................................61
views...................................................................... 133
orientation
viewLinc desktop............................................... 143
Overview window
about......................................................................132
acknowledging alarms....................................158
adding views........................................................132
pause alarming............................................160, 161
printing current alarm data.............................. 151
resume alarming...............................................162

P
passwords
devices.................................................................55
users....................................................................195
Patlite signal towers.............................................135
pausing/resuming
alarms....................................................................159
device or host alarming................................. 160, 161
threshold alarming............................................159
PC requirements..................................................... 14
PDF reports............................................................ 188
permissions
about......................................................................124
assigning to Locations...................................... 126
defined................................................................... 126
inherited.................................................................127
upgrading..............................................................124
Permissions Viewer.............................................. 128
PIN
for modem SIM Card........................................... 118
user......................................................................... 76
POP3......................................................................... 117
ports
serial........................................................................ 25
POS........................................................................... 137
predefined comments...................................... 137
preferences
audible alarms.................................................... 110
language................................................................ 115
predefined comments...................................... 122
schedules................................................................ 128
system alarms....................................................... 121
temperature units.............................................. 111
printing
current alarm data.............................................. 151
custom reports.................................................... 178
event logs............................................................. 164
Location alarm reports..................................... 178
Location alarms.................................................. 179
Location history reports................................. 179
quick reports................................................... 175, 176
reports............................................................... 174, 176
system reports.................................................... 188
properties
channels..................................................................57
devices....................................................................55
Locations............................................................ 197
Q
quick reports...................................................175, 176
generating........................................................... 176
R
reactivating
groups................................................................. 196
Locations............................................................ 203
reports................................................................. 178
certificates................................................ 10, 29, 30
trusted certificates............................................. 221
security status, DL data loggers.......................... 218
serial ports.................................................. 25
server
name..................................................................... 53
requirements...................................................... 11
services not running........................................... 229
session expiry..................................................... 114
setting up
channel calibration properties........................214
configuration steps............................................ 38
default view, Overview window............................. 134
device calibration properties............................ 215
devices.................................................................. 21, 47, 48, 50
Locations and Zones........................................... 60
Modbus devices.................................................. 210
notifications..................................................... 117
planning worksheet............................................ 39
remote acknowledgment.................................... 153
remote display.................................................... 138
schedules............................................................ 128
SMS modem or web service............................... 118
voice call web service........................................ 120
setting up()....................................................... 47
setup.................................................................... 28, 29
sharing
reports............................................................... 175
views..................................................................... 133
show/hide deactivated
devices/hosts.................................................... 207
groups.................................................................. 196
Locations/Zones................................................ 203
threshold alarm settings.................................... 87
users..................................................................... 195
signal towers..................................................... 135, 152
adding............................................................... 44, 135
signatures
adding to reports................................................. 179
SIM Card PIN..................................................... 118
site map
dashboards....................................................... 67
sites
about.................................................................... 60
Sites Manager window
about.................................................................... 60
dashboards....................................................... 67
device alarm settings........................................... 88, 94
hosts and devices............................................. 44
permissions......................................................... 126
schedules........................................................... 130
threshold alarm settings.................................... 84
Zones and Locations......................................... 60
Sites window
acknowledging alarms................................. 158
building trends............................................... 167, 172
generating quick reports................................. 175
monitoring alarms........................................... 147
pausing alarms.............................................. 160, 161
printing current alarm data.......................... 151
resuming alarming.......................................... 162
SMS.................................................................... 139
message content............................................. 104
modem or web service....................................... 118
notification settings......................................... 118
SIM Card PIN..................................................... 118
SMS notifications
acknowledgement............................................. 109
message content............................................. 104
modem or web service settings........................ 117
templates........................................................... 98
SMS or Voice Web Services
about................................................................. 97
licensing............................................................ 15
SMS via web service......................................... 139
SMS web service
license key, entering........................................ 114
SMTP settings................................................... 117
Index

sorting columns .................................................... 146
sound
 signal towers .................................................. 135
sound in a browser ............................................. 110
stopping viewLinc ........................................... 220
sub-zones .......................................................... 61
supported browsers .......................................... 11
supported devices ............................................. 11
supported languages ....................................... 115
swapping devices ............................................. 209
synchronization
 logger timebase ............................................... 113
system
 installation test ................................................. 42
IT network ....................................................... 117
system alarms
 about .................................................................. 80
acknowledging .................................................. 156
preferences ....................................................... 121
system components ......................................... 9, 10
system preferences
 alarm acknowledgement .................................... 109
comments ......................................................... 122, 123
e-mail/SMS/voice notifications .......................... 117
language ............................................................ 115
license key, entering ......................................... 114
schedules .......................................................... 128
session expiry .................................................. 114
temperature units ............................................ 111
units ................................................................. 116
viewLinc Aware Service .................................... 113
system reports
 creating ............................................................ 178, 188
defactivating ..................................................... 177
generating ........................................................ 174
reactivating ....................................................... 178
T
 technical support logs ....................................... 115
temperature
 setting measurement units ............................. 111
templates
 alarm notification ............................................. 96
custom notifications ......................................... 226
device alarm ..................................................... 88, 94, 95
device alarming ................................................ 79
device alarm ..................................................... 104
device alarming ................................................ 79
email/SMS/voice ............................................... 79
predefined comments ....................................... 123
schedules .......................................................... 129
threshold alarm ................................................ 79, 82, 86
testing
 network communications ................................. 219
system installation ........................................... 42
threshold alarms
 about .................................................................. 81
deactivating ..................................................... 87
disabling temporarily ....................................... 205
identifying conditions ...................................... 149
pausing ............................................................. 159
reactivating ....................................................... 87
schedules .......................................................... 130
threshold alarm templates
 about .................................................................. 79
adding notification templates ........................... 101
alarm off margin ................................................. 82
applying to Locations ....................................... 84
copying ............................................................. 84
creating ............................................................. 82
device alarm ..................................................... 86
editing ............................................................. 86
threshold values, reading ................................ 166
timeout period .................................................. 55, 114
300 series transmitters .................................... 55
HMT140 Wi-Fi data loggers ................................ 55
time synchronization ........................................ 113
TLS (SSL)
 security .......................................................... 29
uploading definitions file........................................50
USB
installing DL series with USB..............................24
users
access to views.................................................133
activating.........................................................196
adding...................................................................76
adding a schedule..............................................131
adding to groups.................................................76
assigning rights..................................................74
deactivating/activating...........................................195
deactivating/reactivating.......................................195
editing...............................................................195
for remote display terminal................................134
legacy rights......................................................16
logging in.............................................................36
permissions.......................................................124, 126
preferred language..............................................76
schedules...........................................................129
setting timeout period........................................114
views...............................................................132

V
Vaisala devices
adding.............................................................46, 48
discovering..........................................................46
setting up...........................................................21
Vaisala OPC UA Server
installing...........................................................141
validation alarms................................................79, 80, 88
notification settings.............................................121
viewing
active alarms.....................................................149
COM ports..........................................................224
device properties..................................................51
event comments..................................................163
event logs............................................................162
Locations and Zones..........................................144
Location status...................................................197
measurement units.............................................116
adding........................................................................61
adding Locations......................................................62
assigning permissions..............................................126
dashboards...............................................................67
deleting........................................................................202
device alarms...........................................................88
moving Locations......................................................202
pausing/resuming threshold alarming.....................159
permissions............................................................124
renaming.................................................................199
searching for..........................................................145
setting up..............................................................60, 61
viewing data............................................................60
Warranty

For standard warranty terms and conditions, see www.vaisala.com/warranty. Please observe that any such warranty may not be valid in case of damage due to normal wear and tear, exceptional operating conditions, negligent handling or installation, or unauthorized modifications. Please see the applicable supply contract or Conditions of Sale for details of the warranty for each product.

Technical Support

Contact Vaisala technical support at helpdesk@vaisala.com. Provide at least the following supporting information as applicable:

- Product name, model, and serial number
- Software/Firmware version
- Name and location of the installation site
- Name and contact information of a technical person who can provide further information on the problem

For more information, see www.vaisala.com/support.

Recycling

Recycle all applicable material.

Follow the statutory regulations for disposing of the product and packaging.